Photoshop CC 22.2 isn't deleting cropped pixels

Community Beginner ,
Feb 13, 2021 Feb 13, 2021

Copy link to clipboard

Copied

Not sure when this started, but I think it's fairly recent:  Even with the "Delete Cropped Pixels" box checked, Photoshop does *not* delete the unwanted pixels.

 

This causes a noticeable slowdown in my work doing photo enhancements.  I often scan multiple photos at a time in high resolution then crop them into individual files.  With PS now *not* deleting the pixels upon cropping, every adjustment I apply is applied to the size of the original large scan, not to the smaller single-photo file like I want.  PSD file sizes are much larger, too, of course.

 

Is there somehow to get PS to revert to the correct action to delete everything but what's inside the Crop tool bounds when "Delete Cropped Pixels" is selected?

TOPICS
Windows

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Feb 13, 2021 Feb 13, 2021
First try resetting the Crop Tool by right-clicking on its icon in the Options Bar Using the Brush Tool as an example. If that fails, Reset Preferences:

Likes

Translate

Translate
Adobe Community Professional ,
Feb 13, 2021 Feb 13, 2021

Copy link to clipboard

Copied

First try resetting the Crop Tool by right-clicking on its icon in the Options Bar

Using the Brush Tool as an example.

 

Brush reset.png

If that fails, Reset Preferences:

reset prefs 2020.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

That seems to have done the trick.  After resetting Tools & Preferences, Photoshop is worrking as expected.  Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 13, 2021 Feb 13, 2021

Copy link to clipboard

Copied

I don't know why it's working this way on your computer. It's fine here. Two things to try:

  • Prefs > General > Reset Preferences on Quit (after backing up customization)
    or
  • Use the Rectangle Marquee tool "M" > drag a rectangle (or set options in the options bar to a specific size or ratio) >
    then go to Image > Crop

~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 14, 2021 Feb 14, 2021

Copy link to clipboard

Copied

Are there Smart Objects involved? 

Could you please post screenshots with the pertinent Panels (Toolbar, Layers, Options Bar, …) visible? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Doesn't work on smart objects, fyi!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

LATEST

omg thank you!!! i went mad trying to crop. Thank you so much!!! here are some screenshots for anyone who needs it

look in layers for the smart object icon.

Screenshot 2022-04-08 at 8.55.46 PM.pngScreenshot 2022-04-08 at 8.56.30 PM.pngScreenshot 2022-04-08 at 8.58.02 PM.pngScreenshot 2022-04-08 at 8.59.40 PM.png

please note smart objects wont crop pixels outside the crop area , even when you have that option turned on!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines