P: Decimal symbol can only be comma or period, as opposed to ID of AI

4 Votes
LEGEND ,
Apr 16, 2015 Apr 16, 2015

Copy link to clipboard

Copied

If you ever put a decimal value in any field in Photoshop and the decimal separator happens to be not the one you have as a default in your OS, Photoshop shows an error message and forces you to follow the settings you have on your system. This is very annoying, since both InDesign and Illustrator handle it just fine, you can type in either a comma or a period. I'm using two keyboard layouts on a Mac, and sometimes it's easier for me to type a comma rather than a period, but it's just a nightmare when I have to be aware that in Photoshop only one symbol works, while in InDesign and Illustrator I don't have to worry about it.

Idea No status
TOPICS
macOS , Windows

Views

81

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
4 Comments
Explorer ,
May 03, 2017 May 03, 2017

Copy link to clipboard

Copied

+100500!!!
The same problem. It is so ridiculous!
I've even created a new issue about this problem:
https://feedback.photoshop.com/photoshop_family/topics/photoshop-should-parse-both-dots-and-commas-f...

Votes

Translate

Translate

Report

Report
Explorer ,
May 03, 2017 May 03, 2017

Copy link to clipboard

Copied



Is it very difficult to parse BOTH dots (.) and commas (,) for fractional numbers (1.5pt; 1,5pt) ?

The numpad on my keyboard insets either dots, or commas. It depends on the current layout.
And it is sooo unconvenient and annoying when Photoshop shows this ridiculous message:

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 04, 2020 Aug 04, 2020

Copy link to clipboard

Copied

I mean, it's kinda old, but I just ran across this problem. Don't know how to solve it yet, but here's a workaround:

If you type in a dot or a comma it shows the same error, but if you use the comma (in my case) that's already there and type the numbers around it, it works like a charm 😉

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 27, 2022 Feb 27, 2022

Copy link to clipboard

Copied

LATEST

I'm in Europe and for several reasons (e.g. date/time format) I have set the OS setting to Europe and for even more good reasons (not at least to have smooth access to the PS hot keys) I'm on a US keyboard with the period as a decimal separator on the num pad.

 

I don't mind, whether the input field shows a comma or a dot. BUT when I enter blindly on "auto pilot" a number via the num pad, I slam into various error messages basically meaning the number would be invalid. So, click away the error message, start over, enter the number "manually" by searching the comma on the main part of the keyboard.

 

A real annoyance... Please make this setting configurable, or even better, accept both, the dot and comma, as a separator.

Votes

Translate

Translate

Report

Report