• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Locked

Captions: I don't see my subtitles appear in preview (Premiere Pro 14.9 and earlier)

New Here ,
Aug 17, 2018 Aug 17, 2018

Copy link to clipboard

Copied

Hello,

 

I get stuck with subtitles. I know how to make subtitles in Premiere, by using Captions. I know how to Create, Insert and adjust them. But I just don't see them appearing in the preview screen, the "Reference" screen. I tried changing position, color, the type (Pop-on, Roll-up 2 lines,...)

 

Remarkably, I can export them into a separate SRT file and this way I can use the exported media. But it would be nice to see them in Preview.

 

Is there anyone out there that can help me please?

 

 

 

Premiere_Problem.png

TOPICS
Editing , Effects and Titles

Views

47.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 17, 2018 Aug 17, 2018

You can see the captions in premiere pro by enabling them from the program monitor settings as follow -

1. Go to the settings icon in the program monitor -

Screen Shot 2018-08-17 at 4.07.30 PM.png

2. Go to Closed Caption > Enable and go to Settings (choose the same standard & steam as of the caption your using) -

Screen Shot 2018-08-17 at 4.07.36 PM.png 

Likes

Translate

Translate
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Hi Stan,

 

Appreciate your quick response. I am using Adobe Premier Pro 2020 which may be my problem? 

 

My caption steam is in the screenshot below: 

JessM2021_0-1622080846550.png

 

I have selected "override file settings" and still no captions are showing. Are these settings correct now? 

JessM2021_1-1622080949591.png

 

Thanks,
Jess

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

PS. Caption settings. Appreciate your help with this.

JessM2021_2-1622081171839.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

The screenshots are helpful. PR 2021 vs 2020 is not your problem.

 

Your override shows they should now be Open Captions. Your Caption Panel shows that stream is Closed 608. Your display settings are for 708.

 

Change the display panel to 608, and you should see the captions.

 

Import a different srt and see if that stream is now Open Captions. Open Captions ignore the display settings; they should always show in the Program Monitor.

 

If you don't need closed captions, you can change the 608 stream to Open Captions. Right click, Modify -> Captions. But you cannot change them back.

 

If this doesn't get you sorted, keep asking!

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Thanks Stan! The captions are now showing thanks to your guidance. Now that they are showing, I see they look very far apart. Do you know how to make the kerning closer? 

JessM2021_0-1622085113516.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Yes, progress!

 

That is the way closed captions look in the program monitor. There is a limited number of characters per line. And the appearance on a user's TV set is determined by their settings, so you have limited control. 

 

What is your final purpose? Burned in or embedded?

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Hmm I see, that is a shame as the words are skewed. I'd like them burned in but I noticed that when I exported it, they didn't appear at all?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

If you want burned in, change them to Open Captions. 

 

Be sure that in the Export dialogue, you go to the Captions tab, and set them to "burn in."

 

Stan

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Ah I see, thanks so much Stan. Your legendary help and guidance has made my job so much easier!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

Can anyone please help me, I have no option to enable closed captions in the program monitor settings.. nor can I find the option in any drop down menus so it won't show in any renders? Thanks!Screenshot 2021-09-21 at 16.00.16.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

ColeMingus,

 

This thread is about PR 14.9. As indicated by your screenshot you are using PR 15.x. You no longer need the "enable" options to show 608/708 captions. And, as shown by your screenshot, your captions are showing in the Program Monitor.  

 

The export options, as in PR 14.x, are set in the Export Settings dialogue (burn in, embed, sidecar).

 

Let us know if this does not answer your question.

 

Stan

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 11, 2022 Oct 11, 2022

Copy link to clipboard

Copied

Captions with a different aspect ratio than your sequence (sequence settings) is a typical culprit of them not being able to show in preview during playback. Cumbersome... as you have to redo them in the right aspect ratio / new caption file- now if someone has a way to alter the aspect ratio without creating a new caption file, or knows better how to streamline the process of redoing them- that I would like to know 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 11, 2022 Oct 11, 2022

Copy link to clipboard

Copied

LATEST

John,

 

Your comment applies to the versions in use when this thread was started: PR 2020 (14.xx) and earlier. I think you'll find that captions no longer have an aspect ratio since the new workflow (PR 2021; version 15.xx). Once caption tracks were no longer Video clips, some concepts did not apply. If you look at SRT file in Project Panel, you will see that there is no aspec ratio. The 30fps it shows is actually arbitrary. It simply uses the timecode in the srt.

 

If you look at the PR Properties for that SRT, it shows no aspect ratio and no framerate.

 

But you can get the problem you are describing related to frame size in a sequence. This has most often been report in the new caption workflow where someone is using a vertical frame size.

 

There are gotchas here, and I do not understand some of them.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines