Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Dialog boxes pop up on wrong monitor

Explorer ,
Feb 24, 2012 Feb 24, 2012

Copy link to clipboard

Copied

I have my workspace spread out over two monitors, with a third preview screen on a TV. My timeline and preview monitors are on my center screen with the main title bar, considered the "main" screen by OSX. However, any time a dialog box pops up, it appears on my leftmost monitor. It's a pain, since the majority of my work takes place on the center screen, to constantly have to move back and forth between monitors to address any dialog boxes that pop up to adjust clip speed, export settings, watch preview render progress, cancel auto-saves, etc. Is there any way to change the default position of these dialog boxes? Moving them over when they appear doesn't seem to change anything.

Views

38.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Explorer , Feb 24, 2012 Feb 24, 2012
Thanks for the suggestion—it led me to the solution. It turns out the dialog boxes appear on whichever screen contains the "main" window box—that is, the window with the bar at the top that shows the directory path of the project you're working on. Rearranging my workspace so the window was on the main screen fixed the problem.

Likes

Translate

Translate
New Here , Oct 11, 2019 Oct 11, 2019
I know this is an ancient thread, but this was the first google result, so here's a solution for future macosx users.This behavior is operating system dependent. How to fix:1. Click the apple icon.2. Click System Preferences3. Click display4. Click arrangement.On one of the monitors, you will see a white rectangle at the top, whatever monitor that is, that's where dialog boxes will appear when they pop up.5. Click and drag that white rectangle to the monitor you wish dialog boxes to appear.

Likes

Translate

Translate
Community Beginner ,
Feb 24, 2012 Feb 24, 2012

Copy link to clipboard

Copied

This happens with me with other programs to like photoshop etc...the only fix I think might work is to set your monitors to one monitor, bring up the dialog box again, save, then try working on the three monitors again.  Tell me if that works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 24, 2012 Feb 24, 2012

Copy link to clipboard

Copied

Thanks for the suggestion—it led me to the solution. It turns out the dialog boxes appear on whichever screen contains the "main" window box—that is, the window with the bar at the top that shows the directory path of the project you're working on. Rearranging my workspace so the window was on the main screen fixed the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2012 Feb 24, 2012

Copy link to clipboard

Copied

cool...glad to help....im taking note if this issue arises again

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2017 Jan 06, 2017

Copy link to clipboard

Copied

I have this problem in WIN10. I use two monitors, one is a Wacom Cintiq, so I tend to draw a lot on the Cintiq then move PS to my main (large) monitor to make layer adjustments and color corrections. It doesn't matter which monitor my PS is actively running in, all my pop up windows go to the last monitor they were opened in. It is a real pain. I wish there was either a WIN or PS setting that commanded all windows to open in the active window rather than where it last was. I realize this wouldn't be ideal for most users that aren't swapping screens frequently, but the option would sure be nice for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2017 Oct 29, 2017

Copy link to clipboard

Copied

I have the same issue and I'm not switching between monitors frequently. My Windows 10 setup has my left monitor as my primary, but it happens to be identified as monitor 2. Premiere can't seem to grasp this, as it throws certain dialog windows onto the right monitor (1). This is particularly problematic since I have full-screen playback enabled on monitor one, so if I need to adjust Sequence Settings, the window comes up behind the video and I can't get to it, forcing me to dig into my preferences, turn off full-screen playback, adjust my settings, then turn it back on.

As was mentioned by others, moving the dialog over to the primary monitor doesn't help. It always pops up on the other one. Premiere seems to be intent on opening things on monitor 1, regardless of what is set to the primary monitor by the operating system, at least when it comes to Windows. Physically switching the monitors around is a chore since I have them VESA-mounted on a single stand.

I have similar issues with Photoshop so it seems to be a problem on Adobe's end. I don't have these issues in any other programs I use, such as Nuke and Silhouette.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2019 Oct 11, 2019

Copy link to clipboard

Copied

I know this is an ancient thread, but this was the first google result, so here's a solution for future macosx users.

This behavior is operating system dependent. How to fix:

1. Click the apple icon.

2. Click System Preferences

3. Click display

4. Click arrangement.

On one of the monitors, you will see a white rectangle at the top, whatever monitor that is, that's where dialog boxes will appear when they pop up.

5. Click and drag that white rectangle to the monitor you wish dialog boxes to appear.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 15, 2019 Oct 15, 2019

Copy link to clipboard

Copied

this didn't work for me. My preferences are probably screwed up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

Wicked!! Thank you - was looking for a solution to this for a while. I started to get into code land before I came across this solution, A place I'd rather avoid.

 

So simple.

Legend.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

This doesn't work for me.  However, I have a vertically-stacked monitor setup, and the popups appear in the monitor phyically below the monitor where I placed the white rectangle in settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2020 Jun 03, 2020

Copy link to clipboard

Copied

That worked! Miraculous, thank you!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Thank you for the simple to follow solution! Yip!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 29, 2020 Aug 29, 2020

Copy link to clipboard

Copied

I've been struggling with this for a while now and this worked!
YOU ARE A LEGEND!

THANK YOU! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2020 Nov 16, 2020

Copy link to clipboard

Copied

THANKS! I was puzzling over this forever and the tech support guy at Adobe did not know the answer.  I discovered this via Google while chatting with Adobe tech support. So now he knows the answer too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2021 Jan 31, 2021

Copy link to clipboard

Copied

Thanks! This totally worked for me on macOS Catalina v10.15.7. If it hasn't worked for you, try saving AE and closing then re-opening it, I needed to do this after making the changes suggested by @cb-sjstewart before they took effect.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

I have already done this before and it didnt't work.

 

If I move any Adobe app from display 1 to 2 or from 2 to 1, the next time I open the app, the dialog box will open on the opposite display. Please, check it out the images attached.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2020 Jan 17, 2020

Copy link to clipboard

Copied

Could you please be more specific about which window it is that you need to move? There is not window called "Main Window." Based on your description of the file directory I guessed it would be the media browser window but that did not work. Each window has a specific name. Just look at the "Window" tab if you aren't sure.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

Hi all - for those of you on OSX that haven't found a solution yet, I found one that works, that I saw on https://illustrator.uservoice.com - which is simply to toggle Window > Application Bar on and off again. Worked for me, might help you. 

OSX Mojave / Adobe Illustrator 2020

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

Here happens the same with all Adobe apps. It is very annoying. Ans thks funkbomb but your solution doesn't work for me. I need all dialogue boxes following the app and not poping up wjhere they want to.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 11, 2021 Feb 11, 2021

Copy link to clipboard

Copied

If you have even one pixel of a window on X screen on Y screen, which you might not even be able to see, you can get this behavior.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Righ click on the ID logo on the menu bar, click Options > Assign to > All desktops.  It will follow the program then. Hope this helps!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Hi @elk2013 thanks but which ID logo? Where?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Alas, I am out backpacking and I can’t get to my computer to answer that or take screenshots. I don’t remember off the top of my head.

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

well, in that case, have a nice trip.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Sorry ... the InDesign logo in the program dock:

 

Screen Shot 2021-03-03 at 10.57.27 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2