Exported Video Has Random Glitch Lines

Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

https://youtu.be/fRf31zyKU7M
glitches start at around 01:23

hello there. im having this glitch error with my exported videos. some times in the preview also.
i dont really know what to do. i have read a lot of posts here but none of them helped me.
in the video example there are only a few glitch lines, but other videos have huge ones
im using static png files made with photoshop, and i add a little bit of movement with automation

my pc specs:
win 10
cpu: amd fx8350 8 core
ram 8gb ddr3
gpu: amd radeon r9 200 series 3gb

i tried a lot of different export settings en premiere. render at max depth, use max render quality, higher target bitrate, export with media encoder. format is h.264. also hardware and software render options, but the issue stays.

 

any soul willing to help?

TOPICS
Error or problem , Export

Views

230

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Feb 01, 2022 Feb 01, 2022
Hmm. Well, I did download the project and assets and exported on my end with the settings that you had in there (except I did use Software and not Hardware encoding) and I didn't notice any lines. So we can probably rule out any kind of issue with the media.   Did you say you had updated your GPU with the latest drivers? What happens if you change Premiere's Renderer to Software Only? (File > Project Settings > General) - export straight from Premiere and don't send to AME otherwise you'd ha...

Likes

Translate

Translate
Explorer , Feb 02, 2022 Feb 02, 2022
ok. so the solution was to process the whole video through software, as phillip said - file > project settings > general > video rendering and playback > mercury playback engine soft only - export media > video > encode settings>software encoding thats it. it bypass your gpu (i believe) and use software to render/export. it will take more time but at least it works. maybe my gpu is about to end his life, i dont know. remember, premiere wont be able to process your preview in real time as you ed...

Likes

Translate

Translate
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

ill pay for help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

I didn't watch the whole thing but I clicked around and let it go for a bit in different spots. I didn't see anything. Can you provide a timecode or even a screenshot with what is happening?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

hello phillip.
im sorry i forgot to mention the glitch lines are at the top of the video at around 01:23

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

I didn't see anything either, Phillip. Sorry, Lucio.

 

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

i forgot to mention the glitch lines are at the top of the video at 01:23

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

https://youtu.be/NL5akaDgCqM 
another example

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Lucio,

I see some black lines now. Can you try Software Encoding in the Video Tab of your Export Settings as a test? It looks like you have some effects plug-ins working there, so they also may be a factor in overloading the GPU.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

thanks for your time kevin

i've already tried software encoding  a few times before this post, with no positive results.
https://youtu.be/RohcjjapGxk
this example is the same video as before but with software encoding. it looks good, i cant see any glitch lines.

but i didnt trust this solution because the video was too short, it didnt "give" time to premiere to make those glitches, and as i said, ive already tried software encoding, getting mixed results. so i ran the software encoding export setting with the very first excample and this is the outcome https://youtu.be/t6_6LKlJhys
glitch lines again. such pain in my soul now. looks like the glitch lines are random

im using one png noise texture overlay and one mp4 dust texture overlay. no plugins or crazy effects are being used in those videos. only automation to generate movement.

also, can you please tell me how to stop plugins from loading? i use audio software to make music and i have a few plugins installed. looks like premiere is loading a few of those plugins when i start a proyect

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Ah, okay. I see them. My first thought was to make sure that they are aren't part of the overlays that you're using.

  

Beyond that my instinct would be to encode to a high quality master first like ProRes 422, and then compress that file and see if that works. You have overlays and lot of noise and stuff going on, and going directly into a Long-GOP codec, especially if you're using Hardware Encoding rather than Software Encoding, might be the culprit. Crossing fingers.

 

I would leave max depth and max render off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

thanks for your time phillip

those textures and overlays are:
  - one noise png image which is only one image with the background
  - and one mp4 dust overlay
im not using effects or plugins to make those textures. also, glitch lines appear with or without the mp4 overlay

 

https://youtu.be/aeof7VJ0yXA
this is the attempt at quicktime pro res 422 encode. im not a premiere pro or video editor expert so i dont fully know what im doing here. also this is the .mov file.
it didnt go well. the glitch lines are at the bottom

ill leave an image with the settings

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hmm.

Well, I did download the project and assets and exported on my end with the settings that you had in there (except I did use Software and not Hardware encoding) and I didn't notice any lines. So we can probably rule out any kind of issue with the media.  

 

Did you say you had updated your GPU with the latest drivers?

 

What happens if you change Premiere's Renderer to Software Only? (File > Project Settings > General) - export straight from Premiere and don't send to AME otherwise you'd have to change the setting there as well.

 

Can you download an earlier version of Premiere from CC? Like version 15.4.1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

the gpu drivers are update, i did that yesterday.

https://youtu.be/Zo-9bczP1Vw

this is the new export version with renderer mercury playback engine soft only, straight from premiere. attached screenshot. it looks good so far. someome said that this types of glitch erros are due to gpu problems, maybe my gpu is about to die?

https://youtu.be/eIowBRBKhDY

and this is another attempt of renderer mercury playback soft only setting on. im writing this while the video exports. its taking so loooooong. hope its ok. i believe i tried this option yesterday with no positive result. lets see now.
(update) my god, the export seems fine. i watched the entire 3min video and i didnt see any glitch lines.

im using renderer soft only + export encode soft only. if it makes sense

also whats the difference between "video rendering and playback>mercury playback engine soft only" vs "export media>video>encode settings>software encoding"?

i did try using older versions of premiere but i got the same results. it seems that renderer soft only is the solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

maybe this could help? https://we.tl/t-dPIFt0gnLr
the proyect

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

https://youtu.be/NL5akaDgCqM
this is another example. same settings
update drivers, update everything. my gpu is a few years old. could it be that?

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Well, yes failing GPU is quite likely, though I'd would not exclude some weird Adobes bug. Maybe try to install 2021 version, and check if the gitch is still there. I was able to convert you project to 2020 version and export it without any errors or glitches (on GTX1060)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

thanks for your time.


i update to the latest version of premiere yesterday morning because i was having this glitch error.
now i cant open the "new" projects on the old versions. but anyway, the error was also there with the previous premiere version, thats why i update.


can you tell me how to convert files to old versions? so i can try

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Here it is, the tool and explanation how it works (so you can do it manually): http://joshcluderay.com/downgrade-premiere-project-converter/

I did manual conversion, by setting version number to 38 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

this is the entire proyect. only 80mb

https://we.tl/t-dPIFt0gnLr

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hi Lucio,

Thanks for the project file and media. Nice. I took a look and exported it using hardware encoding, and it looked fine and did not have glitches. Therefore, I think it's related to your CPU, GPU, RAM setup. Please read the system requirements carefully and see if you have any weaknesses. I'm sticking with my advice to smart render the export. It's more than a simple ProRes export. You need the video preview files to make it happen using this technique. If you don't do it correctly, it won't work as I told you it would.

 

I've made an FAQ, but maybe it would help if you had a good recipe for success right here.

 

  1. Select the Sequence. Choose Sequence > Sequence Settings.
  2. Set up your Sequence Settings and make a few changes in the Video Previews section so that you will create ProRes render filesScreen Shot 2022-02-01 at 12.30.08 PM.png
  3. Choose Sequence > Render In to Out (remove any mark In or mark Out points, if necessary).
  4. You have a green bar above all clips in the Timeline.
    • Play the sequence and make sure there are no glitches in the playback.
    • If there are glitches, try deleting render files and render the sequence in smaller sections (In to Out) until you can playback the full sequence without the issue.
  5. Choose File > Export Media
  6.  Set up the Export Settings as ProRes with a setting that matches sequence settings. Click the "Use Previews" button (important).
  7. Here's how to set it up. Screen Shot 2022-02-01 at 12.40.53 PM.png
  8. Create a preset with these settings so you can reuse the setup.
  9. Click the Export button.
  10. A visually lossless ProRes Master is created. Create H.264 copies with this master as the source. You can import it back into the Premiere Pro project or use the raw file in Media Encoder and Queue up your exports.

 

I hope this gets you a clean export. My advice for the future is that you upgrade your hardware to meet or exceed system requirements. I think the glitches may be because you are taxing system resources, perhaps when using blending modes and multiple tracks of video. Keep up the good work and come back with questions.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

All good advice here 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

this is the kind of help i was searching for. thank you so much for your time kevin.
i turned my computer off for today, let me try this tomorrow. ill ge back to this comment.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Sure, Lucio. Enjoy your time off! 🙂

 

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

ok. so the solution was to process the whole video through software, as phillip said

 

- file > project settings > general > video rendering and playback > mercury playback engine soft only
- export media > video > encode settings>software encoding

 

thats it. it bypass your gpu (i believe) and use software to render/export. it will take more time but at least it works.
maybe my gpu is about to end his life, i dont know.

remember, premiere wont be able to process your preview in real time as you edit, when "soft only" is active.
i use "hardware only" to edit the whole video, and then i change to "soft only"

thanks phillip, you saved my life

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

LATEST

Cool! Good job, Phillip.

 

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines