H.264 gamma shift/washed out colours on export

Community Beginner ,
Sep 10, 2012 Sep 10, 2012

Copy link to clipboard

Copied

I know this has been discussed before but I've been researching this topic for the past two hours and still can't find a solution.

I have .mov source files from a Canon 7D. Exporting them from PP CS5.5 (Mac OS X - Lion, 10.7.4) in h.264 or by 'matching sequence settings' results in a gamma shift/desaturated colours. Playing the resulting h.264 file in QuickTime Player, VLC, Elmedia all result in the same colour shift so this is not an issue with QT simply interpreting the gamma incorrectly.

Uploading to Vimeo and Youtube results in the same gamma shift. The monitor I'm using is not calibrated but when puling up a VLC window of the exported file next to the Program Monitor (on the same monitor) shows that there is a definite difference. Below is a screenshot.

Is there any way to produce an exported file for Vimeo use that reproduces the gamma as I see it in the Program Monitor?

Any help would be massively appreciated.

Thanks.Gamma shift.png

TOPICS
How to

Views

154.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Jan 30, 2014 Jan 30, 2014

The fix may be within your Nvidia Control Panel settings.  I was having this issue when exporting from Premiere CS6 and uploading to Vimeo (the video once posted to Vimeo was washed out and/or hazy).

From this link: http://danbeahm.blogspot.com/2011/01/fix-windows-media-center-andor-vlc.html

The fix I found was to use the NVIDIA control panel to control your video playback instead of the video player’s settings. 

  1. Open your NVIDIA Control Panel (type NVIDIA in your start menu search field and selec
...

Likes

Translate

Translate
LEGEND ,
Sep 10, 2012 Sep 10, 2012

Copy link to clipboard

Copied

Before I went about adjusting things, I would try in another player, besides QT. It is known to have Gamma issues, and also color issues, though I know of those mainly from QT on the PC, but perhaps it's the same, or similar on the Mac?

Good luck,

Hunt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2012 Sep 10, 2012

Copy link to clipboard

Copied

I am aware of the issues that QT has and so I have tried it in other media players but they all look the same as each other. This is the same for Vimeo and Youtube also. The only place it looks different is in Premiere Pro.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 10, 2012 Sep 10, 2012

Copy link to clipboard

Copied

OK, and thanks for that clarification. I did not want you joisting with windmills, when it was but a player issue.

Now, I have not encountered what you showed, and am also a PC-only guy, so not sure how much help I can be. However, there are some great folk here, and they will be by soon, with some useful ideas.

Good luck,

Hunt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 10, 2012 Sep 10, 2012

Copy link to clipboard

Copied

Did you use Quicktime's H.264 export option? Or just standard h.264 using the .mp4 container? If you used the Quicktime h.264 the option itself is flawed. Here are some links regarding the issue.

http://provideocoalition.com/index.php/cmg_blogs/story/brightness_issues_with_h264_quicktime_movies/

http://www.videocopilot.net/blog/2008/06/fix-quicktime-gamma-shift/

http://imnotbruce.blogspot.com/2011/07/fixing-quicktimes-gamma-export-problem.html

https://discussions.apple.com/thread/1358418?start=0&tstart=0

http://byteful.com/blog/2010/07/how-to-fix-the-h264-gamma-brightness-bug-in-quicktime/

https://discussions.apple.com/message/8551140?messageID=8551140#8551140?messageID=8551140

https://discussions.apple.com/thread/2292530?start=0&tstart=0

If you read around the net a lot of people have had this issue with h264. A couple of the articles I posted are supposed to "fix" the problem although I haven't ever tried any of them myself. I've never experinced a gamma shift when using the standard h.264 format option in Premiere, however if you have already used that option and you're still having issues then I have no clue what is going on. However when I import ProRes files into Premiere they don't appear washed out, but when I play them in Quicktime or VLC they do appear washed out. I've always just assumed Premiere was somehow correcting it, because when I export my video to mpeg-2 for playback on our server it looks like it looked in Premiere.

From what I have read though the reason the Quicktime format does this when using the h.264 codec looks and looks washed  out is because of a incorrect gamma tag. But Premiere isn't affected/fooled by this like most media players are. According from how they made it sound on provideo and the one other site I read it on anyways.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 11, 2012 Sep 11, 2012

Copy link to clipboard

Copied

Thanks for the information ComputerNovice25.

I use the standard H.264 option when encoding from PP or Media Encoder. There are H.264 Blu-Ray and Quicktime options but I use H.264 which results in /mp4 files. Strangely, even when I use MPEG-2 or MPEG4 I'm still seeing the same issues.

I have a feeling that my problem is not limited to the H.264 codec but, like you said, something to do with how PP is interpreting the footage for playback. If this is the case, would the simple solution be to compensate for the gamma shift before encoding - so the footage looks too dark in PP - but acceptable when playing afterwards?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 11, 2012 Sep 11, 2012

Copy link to clipboard

Copied

Since you're having issues with mpeg-2 I know something wierd is for sure going now. Do you have a NVIDIA graphics card? Sometimes when people have NVIDIA GPU's and they have their color range set to limited 16-235 it causes stuff in their media players to look washed out. I'm not sure how to weak this on a mac though but you need to make sure your colors aren't set to 16-235 because that's what I'm starting to suspect, because I haven't ever had issues with mpeg-2 appearing "washed out". Unless their is some wierd bug going on here.

Also often times with mac's you need to check the following settings

Check this too... Scroll to the bottom of the post there is also one towards the middle that might help.

https://discussions.apple.com/thread/3718001?start=0&tstart=0

There are a couples settings mac's have that make things look washed out. Also could you upload a small test file that I could check on my system? The reason I don't think it would be good to make the color darker is because I'm thinking this is probably a GPU/OS on your specific machine possibly causing the issue. Video used to be washed out on my PC too but once I found the 16-235 and changed it then all my media players looked correct. Before they looked terrible though and Premiere looked okay.

Hopefully this doesn't turn out to be a bug but I don't think it is, because I use mpeg-2 several times a day when I export for  broadcast and I haven't ever had it wash my video out in any media player at all unless my GPU settings weren't correct.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 11, 2012 Sep 11, 2012

Copy link to clipboard

Copied

I do indeed have an NVIDIA card - NVIDIA GeForce GT 330M 256 MB - running on OS X 10.7.4. Your theory sounds quite close to what the problem actually could be.

Here's a test clip (mp4) - https://www.dropbox.com/s/12h1htyacchr8dk/Gamma%20test%206.mp4

Here's an MPEG2 for comparison as well - https://www.dropbox.com/s/tprd7k7blprpztl/Gamma%20test%207.mpg

Both look identical in both VLC and QT, ie. washed out compared to what I'm seeing in PP.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 11, 2012 Sep 11, 2012

Copy link to clipboard

Copied

On my computer VLC matches Premiere perfectly, I'd recommend trying some of the tweaks I mentioned.

VLC AND PREMIERE.JPG

Then on my computer KMplayer actually appears darker than Premiere.

KMPLAYER.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 30, 2014 Jan 30, 2014

Copy link to clipboard

Copied

The fix may be within your Nvidia Control Panel settings.  I was having this issue when exporting from Premiere CS6 and uploading to Vimeo (the video once posted to Vimeo was washed out and/or hazy).

From this link: http://danbeahm.blogspot.com/2011/01/fix-windows-media-center-andor-vlc.html

The fix I found was to use the NVIDIA control panel to control your video playback instead of the video player’s settings. 

  1. Open your NVIDIA Control Panel (type NVIDIA in your start menu search field and select NVIDIA Control Panel).
  2. Go down to Video and select “Adjust video color settings.”
  3. Under #2 (How do you make color adjustments), select “With the NVIDIA settings.”
  4. Under the Advanced tab change the Dynamic Range with the drop down to “Full (0-255)” (not “Limited (16-235)”).
  5. For my display to look as it should, I had to uncheck “Dynamic contrast enhancement.”

My video now appears as it should (not washed out).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2015 Mar 28, 2015

Copy link to clipboard

Copied

YES, Digabyte!!!

I have been looking for a fix for a long time.

I'm a YouTuber and this problem was about to kill my channel, but this works!

Thank you so much!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2015 Apr 14, 2015

Copy link to clipboard

Copied

Wow.... After more than two years of frustration, this was the solution. Thank you digabyte.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2015 Jun 27, 2015

Copy link to clipboard

Copied

Hi, but this will fix the colors on the video for anyone who watches the video on Youtube for example? Or this fix the problem only on your monitor settings, but not in the video file?

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 27, 2015 Jun 27, 2015

Copy link to clipboard

Copied

The answer to your questions illustrates the difficulty of working with all the various devices we have: there is NOTHING you can do to see that those who view your video work have appropriately set devices, whether desktops, tv's, laptops, tablets, or smartphones. The best you can do without going crazy is:

1) CALIBRATE your own system with a decent "puck" and software package.

2) TEST your output across a variety of devices you WILL be delivering content to, especially if it is for-pay to B-cast stations, satellite/cable companies, content distributors, anything like that. You may need slightly different post-process practices for different markets/user-groups.

3) Accept that you cannot control the infinite variables of an un-calibrated world. And get on with getting work out the door by following 1) & 2) above.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2015 Jun 28, 2015

Copy link to clipboard

Copied

Yeah, I know, but this particular H264 issue with the washed out colors have been driving me crazy.

I work mostly with 2D animations, and the fact that a red background (which is the client color) suddenly turns to pink on the final H264 is a huge pain in the ass. In videos these washed out colors aren´t that big deal, but in animations, this is a deal breaker.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 29, 2015 Jun 29, 2015

Copy link to clipboard

Copied

The issue isn't that the color has changed in the file ... the issue is that the gamma or the outer-range of signal have been changed by a video player. Or both. Similar to the note above in this thread by another person, my video card (EVGA GTX-770/4Gb of course nVidia based) installed itself using it's own default setup for video programs: 16-235. Unless a video player (such as that within PrPro) insists on doing it's own thing, that will "rule" what happens. Shrink a 0-255 video to 16-235 and wow ... the darks just ain't so dark, the highlights mush, and the color tends to flatten a bit ... as of course does contrast (the last two are linked, of course, as far as "data" goes).

Now, let's throw on top the gamma question ... different video players treat gamma a bit differently. In other threads when someone provides an example of "bad" export by PrPro, another user has taken the "bad" clip, changed the gamma inverse to what the used video player typically does, and gee ... it suddenly and completely matched the "original" example set side by side with the "bad export" example. Again ... it wasn't that PrPro had done a bad job, but that the gamma used by the video player was a bit different.

You cannot control those variables in other machines run by other people ... the range issue or the gamma issue ... on all devices that will show your material. You can check if PrPro is exporting other than expected by bringing an exported clip back into PrPro ... with appropriate settings on the export, it SHOULD match the original. If on another machine in say Quicktime ... it probably will not. Given that many nVidia chipped cards set up with an assumed 16-235 range, and shrink all other material down into that range, there's a problem right there. Throw in the typical gamma mismatch between Quicktime and most anything else, you've got two variables that are WRONG. And that you as the "content provider" cannot control.

After changing the default nVidia control panel setting to assume 0-255, VLC seems to behave properly on my machine. Quicktime treats the same output into different codecs differently. Matched exports ... always play like the original in PrPro, and since I changed the nVidia setup default they play the same in VLC, but ... play differently depending on which codec is used in Quicktime.

Which is why around "here" a lot of folks stay the heck away from it. At least as far as any "critical" viewing goes. Or use it only to get an idea how Quicktime will mangle their efforts. If "your" market is all running Quicktime, then ... plan for it by testing and finding what settings you need to make in PrPro to make "in the wild" Quicktime players "show" your file somewhat maybe closer to what you want. And if they're on nVidia chips, well ... you might need to output to 16-235.

Or ... output correct material. And know you can't control what others do.

Whichever fits your market needs better.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 29, 2015 Jun 29, 2015

Copy link to clipboard

Copied

Thanks for the explanation man!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 30, 2015 Jun 30, 2015

Copy link to clipboard

Copied

I thought calibration for stills shooting such that what "we" saw on screen was what we got back from a lab as difficult.

Ha.

Video is SO much more complex ... but some of it is just out of one's control. Or you go nuts. Naw, set your gear up "righteous", know thy market, and get the stuff out. Get a glass of beer, wine or coffee, and enjoy life ...

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 12, 2015 Nov 12, 2015

Copy link to clipboard

Copied

Yay, your Nvidia suggestion saved the day.  I'm running after effects on PC to color grade my PP footage (Dynamic Link style) and every time I rendered .mov files using Quicktime H.264 it was washed.  Is there way to render just the H.264 mp4 version from After Effects?  Seems only the Quicktime H.264 is available to choose.  I would like to render straight from AE instead of send to Media Encoder.

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 12, 2015 Nov 12, 2015

Copy link to clipboard

Copied

Is that H.264 "washed" when viewed in PrPro ... or when viewed in a freebie player like the Quicktime player? It may be that if you're not viewing it in PrPro after export, you might be looking at it through a gamma-challenged player. Which is often the case.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

What do I do if my card is Intel?

 

I get the same quality in PP preview as the original raw file on my windows 10 PC, but when I export it the colours are washed out, I tried so many things from the web, none of them worked..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Raw is a specific form of media ... such as Arri-Raw, BRAW, and such. It is not debayered or at least fully debayered and has other things that are not fully processed for the image from the sensor.

 

And is very different from say log-encoded media. And of course, normal media in say H.264, mov, whatever.

 

So are you working with actual raw media, or do you mean the original files from the camera in a particular format/codec?

 

And have you checked the color space of the media in the Premiere Properties panel, or used the color management tools? Selecting one or more files in Project manager, then right-click/Modify/Interpret Footage, and set the Override to Rec.709?

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

The terms like Arri-Raw, BRAW, I have no idea what they mean 😞

 

"Selecting one or more files in Project manager, then right-click/Modify/Interpret Footage, and set the Override to Rec.709?"

 

How do I know if my settings are not correct already and if they're not where and how do I change them? I use Intel processor laptop, Huawei Matebook 13 i5.

 

I use GoPro 8 for cycling, just copy files from SD card to windows PC and then import to PP to work on them.. But again, as I said, PP looks great, onced the edit is rendered it's washed out..

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Here's how it looks for me (both PC and YouTube):

 

Original raw file (straight from SD card): https://ibb.co/dr2DJ1X

 

Edited and exported PP file with washed out colours compared to the above: https://ibb.co/TH1vNNL

 

My export settings: https://ibb.co/LhXF2Ps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

I also enable "Display Color Management", but I don't fully understand it and the exported file looks still washed out, no matter on what player I watch it, including VLC, but the raw file from the SD card is beautiful, shiny with vivid colours.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines