How do you delete TRACK keyframes in bulk?

Participant ,
Dec 19, 2012 Dec 19, 2012

Copy link to clipboard

Copied

Maybe I'm missing something, but I cannot lasso or highlight all keyframes of a track in a timeline.

Unlike clip keyframes, in which you can select and delete them all via the effect control window, in order to delete track keyframes in CS6, it appears one must manually select every single keyframe individually.  AAAARGH! Even though you can "lasso" or drag a "selection" around things on the track timeline, it will NOT select groups of track keyframes you lasso.

I've checked the CS6 documentation, and still see no way to do this...even though it mentions being able to click outside the clip and drag a selection.

Try it.

1. create timeline

2. set audio mixer channel 1 to "write"

3. hit play and go crazy with your channel 1 mixer slider

4. hit stop

5. change option on Audio 1 on timeline so that you can "show track keyframes"

6. see all those pretty keyframes?...now try to delete them all at once without deleting your audio/video clip...

Any questions?

There is no reason why, in a professional application such as this, you shouldn't be able to select multiple keyframes and delete them. Feature request? Or am I missing something.

NOTE: I'm talking about TRACK automation keyframes not CLIP keyframes.

Views

22.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Enthusiast , Dec 19, 2012 Dec 19, 2012
...or you could just use the pen tool to lasso and remove Track Keyframes... it works for me:#pen tool (p) lasso them cattle in, hit delete and wait a second (depending on your machine),hit Pos1, play, all good---and keep smiling

Likes

Translate

Translate
Community Beginner ,
Jan 13, 2016 Jan 13, 2016

Copy link to clipboard

Copied

to remove all keyframes from a clip in premiere pro CC 2014, right-click over the clip that has your keyframes. Select 'Remove Effects'. Uncheck everything except for Volume. You'll notice it says 'Remove parameters and reset keyframes'. Hit OK and you're done...all keyframes deleted and volume is reset back to neutral.

If you have several clips back to back, then drag-select all the clips (or Shift+click all of them) and do the same thing: right-click>Remove Effects>Volume. Done

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2016 Aug 07, 2016

Copy link to clipboard

Copied

Thank you someg47547554,

That just solved a problem for me!  In CC2015, after right click you now choose "remove attributes"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2017 Nov 08, 2017

Copy link to clipboard

Copied

Am just learning about keyframes in Premiere. I spent over an hour trying to figure out how to select multiple keyframes. This information was very useful.

Thank you!

--G

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

Thank you so much for this, I've been looking for an answer everywhere!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines