• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Pitch Shifter Distortion in Premiere Pro

Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Facing this issue in different projects therefore can't achieve a good result. 

I edit video in Premiere Pro CC2022 and when the project is done (mainly talking head)

I create a new sequence where put already finished sequence and speed up video and audio about102-106%

Of course, audio sounds unnatural and I apply pitch shifter. I've tried "Maintain Audio Pitch" it works even worse. 

For some reason, pitch shifter randomly distorts audio during playback, and if I play this part one more time I hear no distortion, but it reveals in a different part of the audio. 

This option works much better in Final Cut Pro. Hope to have it in PP. 

Maybe you have some recommendations on how to fix it? 

P.S. I can make 2 renders and this distortion can be in two clips but different places. 

TOPICS
Audio , Error or problem

Views

1.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 02, 2022 Jan 02, 2022

Finally I've found the problem. 

Seems like pitch shifter works really bad with stereo audio. 

I added Fill left with right effect and now everything sounds better. 

Anyway that's so strange that pitch shifter doesn't work with stereo....

Hope Adobe can fix this in a future update!

Likes

Translate

Translate
Community Beginner ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Finally I've found the problem. 

Seems like pitch shifter works really bad with stereo audio. 

I added Fill left with right effect and now everything sounds better. 

Anyway that's so strange that pitch shifter doesn't work with stereo....

Hope Adobe can fix this in a future update!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2022 Jun 02, 2022

Copy link to clipboard

Copied

Thank you for your solution! I ran into the same problem and was very frustrated and didn't realize it had to do with the stereo vs mono settings. This solution worked for me as well!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2022 Jul 05, 2022

Copy link to clipboard

Copied

Ohh Boooy 
That solved my problem.

Thank you very much:)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2023 Jan 11, 2023

Copy link to clipboard

Copied

LATEST

You genius! This worked for me, thanks!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

Bro is a genius

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

I had weird and inconsistent artifacts as well, I fixed it (finally [weirdly]) by unchecking "use appropriate default settings" and turning the splicing frequency down all the way to 5Hz, as far as it would go.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

Hi! Where did you uncheck "use app def settings"?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

In the Effect Controls panel, under Pitch Shifter, where it says Custom Setup, click the Edit button. That will open a popup window, the Clip Fx Editor. There it will be.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 24, 2022 Oct 24, 2022

Copy link to clipboard

Copied

Hi, this didn't work as audio produces overlaping. But the stereo/mono thing did great! Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

generally I find that sending the audio to Audition solves these sorts of problems.  Although you can throw almost anything at Premiere and it will do a decent job, sometimes working in a more specialized program like Audition, Photoshop or AfterEffects will give you more control and better quality...  Of course you'll need the full creative cloud suite...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines