• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Premiere not using Nvidia GPU even though it's enabled

Community Beginner ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

I've made dozens of videos this year using Premiere and getting it to use the GPU for encoding. About a month ago, Premiere started using CPU, taking my render times from around 8min to 1 hour or more.

 

Nothing has changed hardware-wise:

2080 RTX

i7-8700k

32GB Ram

 

My render settings are exactly the same: HEVC (H.265), Hardware Encoding using Nvidia Codec, 60fps, VBR 1 pass, 25 Mbps.

 

I have exhausted every resource I could find, and I still don't understand why Premiere refuses to use my GPU. PLEASE help.

TOPICS
Export

Views

1.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Advocate , Dec 04, 2020 Dec 04, 2020

assuming Premiere setting are proper, I'd suggest to manually check/update nvidia driver, use this page:

https://www.nvidia.com/Download/Find.aspx

Votes

Translate

Translate
Community Beginner , Dec 08, 2020 Dec 08, 2020

Well, I SOLVED it!

 

I uninstalled all Nvidia Drivers using Safe mode + DDU tool from guru3d.

Then I reinstalled Game Ready Drivers (Not the Studio Drivers, which probably work as well) because I do use ShadowPlay and a bunch of features a lot.

Tried the same settings in Adobe I always use and it worked. 2min to encode instead of 1 hour.

Votes

Translate

Translate
LEGEND ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Have you checked the settings for preferences for hardware encoding and decoding?

 

 I know they've made some changes, and truthfully I'm not too great on the details of how various CPU/GPU/settings changes work.

 

Neil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

60 fps is not supported at all by any hardware encoder. It must be precisely 59.94 fps for so-called "60 fps" video output (only broadcast-standard frame rates - 23.976, 25, 29.97, 50 and 59.94 fps - are supported). Any nonstandard frame rate (and yes, 30.00 fps and 60.00 fps are considered "nonstandard") will automatically default the encoder to the software-only mode.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

After reading your comment, I tried switching it to 59.94 fps and it is still using the CPU. So that's not it either unfortunately.

Screenshot 2020-12-04 083002.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

Next thing to check:

 

Have you ever updated the Nvidia drivers from the Nvidia Web site itself (not Microsoft Update, which almost NEVER offered the latest driver versions)? Newer versions of Premiere Pro now require newer driver versions just to work properly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

assuming Premiere setting are proper, I'd suggest to manually check/update nvidia driver, use this page:

https://www.nvidia.com/Download/Find.aspx

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

Might very well be a driver issue. Just tested an export to 120 fps and GPU was maxed out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

Should I download Studio Driver or Recommended?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

Studio Driver!

Which card do you have?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

2080 rtx

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 04, 2020 Dec 04, 2020

Copy link to clipboard

Copied

Sorry you posted that already.

this is the one you need to install

https://www.nvidia.com/Download/driverResults.aspx/166881/en-us

nvidia.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

Well, I SOLVED it!

 

I uninstalled all Nvidia Drivers using Safe mode + DDU tool from guru3d.

Then I reinstalled Game Ready Drivers (Not the Studio Drivers, which probably work as well) because I do use ShadowPlay and a bunch of features a lot.

Tried the same settings in Adobe I always use and it worked. 2min to encode instead of 1 hour.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

LATEST

I know this is an old thread, but I just ran into this exact same issue. Turns out that I exported an illustrator file as a much larger than needed png and i didn't even think that it would be an issue since it was just an image that i dropped the scale on to make it fit. Well, I was wrong, once i swapped the image out with something more reasonable in size it went back to using my GPU instead of my CPU. So for future people running into this issue, I hope this helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines