Premiere Pro 22.1.2 slow and freezes - Mac

Community Beginner ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Afternoon everybody. 

Using Premiere 22.1.2 on a Mac Mini, M1 chip, 16gb RAM. 

The application ran smoothly and efficinetly, with quick responses until last Friday afternoon where it decided to slow down to an unusable speed. Playback is still fairly decent, however I am almost unable to scroll through the timeline, any click takes at least 5 - 10 seconds to respond, footage takes a while to load up. If I exit the application and re-open it tends to work as should for a period; it's usually as soon as I open up the colour correction panel or effect panel where the issue kicks in. Even if I disable all effects or remove any colour changes, Premiere still runs unresponsive and inpractical. 

Source footage is stored on an external HDD. I'm usually working H.264 - I have attempted to see whether transcoding to ProRes would help and also used Proxies but both failed to fix the problem. 

I have also tried: 
Clearing the cache
Using full playback and HQ playback 
Unistalled and Renistalled
Installed older 2021 version
Clearing trash preferances
Optomised rendering for performance 
Disabled Mercury Transmit
Disabled Refresh Growing Files

I use Premiere for my work and it's currently in an unusable state. Any help would be much appriciated. 

TOPICS
Error or problem , Freeze or hang , Hardware or GPU , Performance

Views

1.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Also experiencing the same issue. It's going irritatingly slow. Following for updates.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hi mathewp8205596!

We appreciate you trying to troubleshoot steps for your own. Which device is used to record the footage? Have you tried running Premiere Pro through Rosetta mode? https://support.apple.com/en-us/HT211861

Let us know how it is with Rosetta mode.

 

Thanks,

Kartika

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Thank you for the response. 

Canon EOS 5D MKIV. 

I have tried running both versions 22.1.2 & 22 in Rosetta mode but with no improvements unfortunatly. 
Like I mentioned before, what's strange is that Premiere runs fine for the first five minutes and completely slows down after I open either the effects or colour panel. I don't even neccesarily need to apply any effects or colour changes, I only need to open a panel once and that's it - slow down.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Also worth noting; 

We have another Mac Mini, exactly the same specs that I used to work on, which when I last used it about a month a go it worked perfectly. I just had a look at Premiere's performance on that machine to try and identify if it was a problem with this specific current one I'm now using.  Exact same problem that I am experiencing on the current machine. I'm starting to wonder if this is an Adobe issue rather than a problem with our settings?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

I have now further tried offloading scratchdisks onto an external hard drive rather than the local with no improvements. It almost doesn't seem like a power problem as my CPU/GPU usage doesn't peak anywhere near a worrying level when using Premiere. It's  simply like the application glitches out and cannot fix itself when opening up any panel. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Decided to make a full purge of everything Adobe on the system and start fresh. Seeing as this randomly happened without any updates or patches I'm even speculating a corrupt file somewhere perhaps. Will post if this fixes

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Did not work. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Day three of trying to fix this issue. 

I have noticed that resetting the workspaces, temporarily fix the issue; but only for about 10 seconds and then we're back to square one. 

I deleted the workspace config file from the layout folder to try and reset all workspaces but that didn't really help. 

Judging by the fact that the problem keep arising from any new workspaces being opened I'm pretty certain this is bug or glitch with workspaces. 

Any help on where I should go next would me much appreciated. 


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Have you tried minimizing your entire workspace layout? Disable Essential Graphics, Lumetri Scopes, etc. I've had problems with Essential Graphics a couple years ago.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Having the same issue. My computer specs are

  • macOS Monterery Version 12.2
  • MacBook Pro (16-inch, 2019)
  • Processor: 2.4 GHz 8-Core Intel Core i9
  • Memory: 64 GB 2667 MHz DDR4
  • Graphics: AMD Radeon Pro 5600M 8GB

 

My current projects include footage from iPhone 12 Pro, Sony A7Siii, Son7 A1, Canon R5, Panasonic GH5.

I tried uninstalling 22.1.2 and installing Version 22.0.0 and I'm still having the same issue.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

UPDATE: I have another Mac (M1 13in Macbook Air, 16GB Ram)  that is still running Monterery Version 12.0.1, and Premiere is running fine on version 22.1.2.

 

My 16in Macbook Pro is still having issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

The same here... =(

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

UPDATE: 2.8.22

Adobe pushed out an updated for Permiere Version 22.2.0. I installed this update on the MacBook Pro (16-inch, 2019), and saw slightly better functionality. The issue I'm still having is with dragging a clip from the Project folder into the timeline. This is when I'm seeing the most lag. The response time is very slow and makes it still difficult to work with. It happens if I pull in footage or a .png. I'm also seeing lag while scrubbing through the timeline, zooming in our out on the timeline, and moving clips around on the timeline. In general the response time of Premiere Pro still feels slow.

 

 

I have not yet tested this on the M1 Macbook Air. Hoping for another patch to fix this soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

I will try this new version. One note for me, I'm experiencing the same exact issues on a new mac pro with a fresh install. Came with MacOS 12.1, then updated to MacOS 12.2. Have you tried falling back to MacOS 12.1? I have a 2019 iMac that was still on MacOS 12.1 and it's running Premiere 22.1.2 absolutely fine. I've tried the usual Adobe fixes... even brand new, simple projects begin to exhibit the laggy UI behavior. I'm a veteran Premiere user and under MacOS 12.2, Premiere CANNOT keep up- close to unusable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

Hi Gandem,

 

Thanks for the feedback. I have tried premier pro on MacOS 12.1 on my other laptop, unfortuanly I didn't have timemachine set up on my current macbook and am not seeing a way to fall back to the MacOS.... if you know how to do that without using Time Machine that would be very helpful. But I agree with your findings. Premiere pro 22.1.2 works great on MacOS 12.1, and updating to MacOS 12.2 Premiere is close to unusable. 

 

Silas

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

UPDATE: 2.15.22

 

I uninstalled and reinstalled Premiere 22.2 and Red Giant plugins, updated MacOS to 12.2.1, and have been seeing a lot better performance out of Premiere (knock on wood). Curious how Premiere is functioning for others right now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

So frustrated! Glad to know it isn't something on my end.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

I have updated to MacOS 12.2.1 and uninstalled Premiere 22.2.0 and then reinstalled it. Things are definitely working better for me as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Me too. driving me mad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Same issue here... impossible to work...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2022 Feb 05, 2022

Copy link to clipboard

Copied

Same problem. No fix still. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 05, 2022 Feb 05, 2022

Copy link to clipboard

Copied

I'm having the same problem accross 2 Mac Pro 7,1's and a 2019 i9 Macbook Pro all running MacOS 12.2 and 22.1.2 of Premiere.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 06, 2022 Feb 06, 2022

Copy link to clipboard

Copied

I can confirm that Premiere 21.1.1 and 21.1.2 are working fine with MacOS 12.1. The terrible lagging behavior accross all my devices is when running under MacOS 12.2.

Have we heard anything about this from Adobe? Is close to being unusable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

Is there any update on this please? I've been having the same issue with my Mac Mini M1 16GB - now running MacOS Monterey 12.3 - I've seen people have had issues running MacOS 12.2 with prem 22.2 and 22.1.2 so thought updating my OS would help - but it's choppy as hell and completely unusable. 

 

Any suggestions? It's getting to me now! This really needs to be fixed!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines