• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
24

"MME device internal error"

Explorer ,
Nov 15, 2017 Nov 15, 2017

Copy link to clipboard

Copied

Hello

I was going about my own business and editing a video when a dialog box saying "MME device internal error" popped up. My audio was no longer playing during video previews, and when I went to the Audio Devices tab in Preferences to try to change the output device, I received the same error message.

mme_internal.PNG

If anyone could tell me the fix ASAP, it would be much appreciated.

Thank you!

TOPICS
Audio , Error or problem

Views

188.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 15, 2017 Nov 15, 2017

Set input to none: that might do the trick.

Edit: screenshot added.

AnnBens_0-1647445209282.png

 

Votes

Translate

Translate
New Here ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

Thank You very much!!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2020 Mar 25, 2020

Copy link to clipboard

Copied

Thank you so much, it's helpfull :))

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2020 Apr 26, 2020

Copy link to clipboard

Copied

I have literally tried everything short of re-installing windows 10....I have un-installed and re-installed the realtek drivers and nahimic multiples times.....and after going the the Windows privacy settings like you suggested it worked perfect!!  Thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 12, 2020 Jul 12, 2020

Copy link to clipboard

Copied

I noticed a microphone icon in the tray so I switched it off not thinking about it, later found no sound in Prem Pro didn't even think about this. you've just saved me a few hours work troubleshooting thanks for sharing 🙂 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2020 Aug 03, 2020

Copy link to clipboard

Copied

this works for me! 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

omg, it worked! so easy! thank you very much!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

Thanks man

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2022 May 13, 2022

Copy link to clipboard

Copied

This worked for me!  What a relief - T H A N X !!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 22, 2018 Jul 22, 2018

Copy link to clipboard

Copied

None of this have helped me. I have tried everything resetting my Audio setting. But still, this keeps on happening.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2018 Aug 13, 2018

Copy link to clipboard

Copied

This didn't work for me either.  However, what did work is a silly, simple thing.  I had to plug in a cord into the microphone jack on my SoundblasterX AE-5 soundcard.  (I didn't have an actual microphone so I just used an 1/8" stereo plug.)  Apparently, it won't work if there is nothing plugged in, even if you are not using the mic input.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2019 Oct 03, 2019

Copy link to clipboard

Copied

Worked for me. Many thanks !

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

https://www.youtube.com/watch?v=oC2eWJwNo-o

Here is a video made based on the solution provided by adobe professional

Welcome To 3-Minutes-Fix In this video, we going to see how to fix MME device internal error in Premiere pro Steps : I have an audio issue inside premiere pro I have found this solution on the original adobe forum. First, user has to go to the edit menu and then click audio driver than in the ...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2019 Dec 27, 2019

Copy link to clipboard

Copied

I had the same problem - not being able to actually input audio to Premiere. I solved it by allowing access to microphone in Windows 10 settings. Search for "windows 10 allow microphone privacy".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2020 Jan 19, 2020

Copy link to clipboard

Copied

Setting input to none is not an acceptable answer. This is a professional editing suite, turning a feature off should never be an acceptable answer.

 

I am getting the same MME error after updates on 1/17/20 and now none of my Adobe Programs are able to record or play back through my MIDI or MIC (internal MIDI). I don't know where this error is sneaking in as the logs are errily devoid of anything useful. In case someone from Adobe actually checks this my configuration is below. Everything was workng as normal one moment then restarting the machine a few hours later none of the USB or MIDI input mics are able to be recognized as working. They work in other non-Adobe programs and the updated drivers are installed. I have been using this particular setup for at least 6 months and it happened all of a sudden across all adobe apps.Windows security cauises an iisue with my Photoshop so Threat detection is off and the apps are allowed through our firewalls as well as allowed access to the microphone. I tested with a USB mic, a MIDI to USB input controller with mic, and the machine internal mic. None of them work now. The MME error displays after switching to the device. NOW Here is a note, I reinstalled the MIDI drivers and the mic worked in Premeire and AE but then 5 mins later just stopped working again and showed the MME error

 

Switching from MME to ASIO for the MIDI controller allowed me to record again however it is less than ideal for our use case since the MME drivers allow us more input flexibility. The first time i switched to the ASIO drivers they worked for about 5 mins then threw an error. Now i have reinstalled and will see if it happens again

 

 

HP Spectre 360 Laptop

i7-6500 / 16GB DDR3 / Windows 10 Pro

Microphones: USB Samson GTrack and US-122L MIDI with Tascam Tm-78 

All apps at latest versions as of 1/18/20

 

 

Adobe CC (Premeire, Audition, Rush, After Effects is my everyday stack)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

It is a windows 10 issue, go to Start > Settings > Privacy > App permissions (left column) > Microphone > Allow apps to access your microphone = On

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

Why use MME in the first place? Seriously, it is the worst possible option available and the latency is outrageously bad too. Premiere's audio is designed to be used with ASIO (Audio Streaming Input/Output) not MME, and it additionally sounds as if the sound card here is a bog-standard chip on the motherboard, which is hardly an ideal situation.

ASIO4ALL is a workaround - there is no substitute really for a decent audio card, or if you are running on a laptop a decent quality interface with dedicated drivers for it's use. Ones I can recommend include the Universal Audio range, the Arturia AudioFuse (which works really well for all that it is a USB device that - like all these devices - really requires it's own, dedicated USB port with nothing else on it at all.

Honestly, please forget these chipset 'audio devices' as they are only really any good for internet & Zoom type stuff and not even slightly suitable for high end NLE use. They simply cannot cope and the quality of the DAC they use often leaves much to be desired.

Try any of these (depending on your needs)

1. Universal Audio

2. Arturia

3. RME Audio

I can personally attest to all 3 of these manufacturers, but please - all of you - dump the chipset audio!!

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

What worked for me was going into sound settings then click troubleshoot underneath the input. Something was not set to default somewhere and the troubleshooter fixed it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2020 Feb 24, 2020

Copy link to clipboard

Copied

The solve for this is not right if you intend to use an audio input. Others have mentioned it here, but to reiterate, this is a Windows 10 permissions issue. To solve it head to Start > Settings > Privacy > App permissions (left column) > Microphone > Allow apps to access your microphone = On

This setting effects ALL audio inputs, line-in, stereo-mix, mic etc. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 14, 2020 Mar 14, 2020

Copy link to clipboard

Copied

This worked for me... Thank You!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 16, 2020 May 16, 2020

Copy link to clipboard

Copied

The error does appear but when i click on it nothing happens and I don't know where to put none

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

Thank

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

I have been reading the various solutions and fixes to the MME Internal Device issue. ( which I am currently experiencing)

 

My question....

Does this issue also create  an irritating loud audible "bing bong" sound thru the speakers.

It sounds like a notification sound.

 

It is not coming from an online source.

 

SOLVED.

1. Turned off INPUT in Hardware Device Options

2. Bing Bong sound is System Sounds for Connect / Disconnect ie plugs in the sound card.  I set Systems Sound for these to NONE

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2023 Apr 14, 2023

Copy link to clipboard

Copied

you won't believe it.

I restarted my computer and everything was fine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2023 Dec 01, 2023

Copy link to clipboard

Copied

INSTANT FIX

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines