SRT import with right-to-left language (e.g. Hebrew, Arabic) - text is reversed

Contributor ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Hi. I'm creating subtitles in Premiere Pro 2021 by importing prepared SRT files and creating a subtitle track by dragging the SRT files onto the timeline.

The SRT files contain subtitles in several languages, among them are Hebrew and Arabic, which are oriented right-to-left. 

For the left-to-right languages everything works great.

But right-to-left languages are appearing with all characters in reverse order.

"This is not good" appears as "doog ton si sihT"

In Preferences > Graphics

I've set Text Engine to "South Asian and Middle Eastern"

I've set Default Paragraph Direction to "Right to Left"

(see image below)

I restarted Premiere and re-imported the SRT file.

These steps did not help.

Does anyone happen to know how to fix this issue?

 

7nGqDP7Kit.png

There was a time when Adobe software didn't support right-to-left languages (in Photoshop, Illustrator, etc) and the result was the same as what I'm seeing now in Premiere Pro subtitles. Back when this was happening in Photoshop and Illustrator, I recall having to use 3rd party software to reverse the character order of the text, so when pasted into the applicaitons, the text actually appears correctly. This work-around is not a good option for me this time. I really need some sort of solution that isn't too time-consuming.

Any help here would be highly appreciated. Thanks!

TOPICS
Effects and Titles , Error or problem

Views

6.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 18, 2021 Mar 18, 2021

Our engineer Trent had the correct answer:

Do you have South Asian and Middle Eastern set in your Caption Track Settings? Right-click on the Caption track header, choose Track Settings... and then under Styling Options > Text Engine, click button for South Asian and Middle Eastern. Then click Ok button.

Likes

Translate

Translate
Contributor ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Hi all,

This question was answered in a different thread here:

https://community.adobe.com/t5/premiere-pro/premiere-pro-2020-reverses-hebrew-text-when-i-use-title-...

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Our engineer Trent had the correct answer:

Do you have South Asian and Middle Eastern set in your Caption Track Settings? Right-click on the Caption track header, choose Track Settings... and then under Styling Options > Text Engine, click button for South Asian and Middle Eastern. Then click Ok button.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Just lost a couple of hours fighting with this same issue.

Thanks so much for the answer! It worked like a charm

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Thank you Kevin!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

Screenshot 2022-02-12 145318.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2022 Feb 20, 2022

Copy link to clipboard

Copied

were you able to fix that? i have the same issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Feb 20, 2022 Feb 20, 2022

Copy link to clipboard

Copied

There is nothing to fix since there is nothing judging by the screenshot ) Let the developers fix it, and we'll wait as always.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 20, 2022 Feb 20, 2022

Copy link to clipboard

Copied

I did not see these posts. Apparently, the real change happened with 22.1.1. See "Universal text engine" here:

https://helpx.adobe.com/premiere-pro/using/whats-new/2022-1.html

 

Now there is only a "left to right" setting, and the rest should be detected/set automatically.

 

I did not look for this setting recently, so I don't know if it was removed with 22.1.1 or later.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 15, 2022 Sep 15, 2022

Copy link to clipboard

Copied

I don't have Styling Options in the Caption Track Settings. I am on version 22.5.0

Screen Shot 2022-09-15 at 11.33.01 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 15, 2022 Sep 15, 2022

Copy link to clipboard

Copied

LATEST

I responded to your other post, with the same information I post above - See "Universal text engine" here:

https://helpx.adobe.com/premiere-pro/using/whats-new/2022-1.html

 

The method has changed. There are screenshots at that link that explain the new method.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

Very hepful! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 12, 2022 Feb 12, 2022

Copy link to clipboard

Copied

This had worked for me in 2021 and I never had to change anything again. However, it looks like they have removed these options in the 2022 version. Which means if I direct this Discussion Page to someone new, he/she might not be able to do it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines