Video playback choppy when using proxies

New Here ,
Mar 25, 2017 Mar 25, 2017

Copy link to clipboard

Copied

So, I did a shoot that I'm now working on in Premier Pro CC. I shot in 4k with a DJI Inspire one with the X3 camera, and transcoded it down to a 720p proxy. Oddly,  the footage is still really choppy when trying to play the footage and scrub through. I even have it set at 1/4 resolution inside Premier Pro. Also, I do have the proxy button enabled. Last week I was editing a video I shot in 1080p with the same drone and it would playback just fine, nice and smooth with no issues. Anyone know why it would run worse with a 720p proxy? It's so weird and super frustrating. I know my Macbook isn't the most powerful but if I can run 1080p with no problem I shouldn't have any issues with a 720p proxy. I have about 25 minutes of footage I need to scrub through and bring it down to about 5 minutes but it's taking forever. It's almost as if I'm still working directly with the 4k footage and not the proxy, but I don't know what I missed...

Latest version of Premier Pro CC

Codec H.264

23.976 FPS

Mid 2012 Macbook Pro OS Sierra version 10.12.3

2.9 GHz Intel Core i7

8 GB 1600 MHz DDR3

Intel HD Graphics 4000 1536 MB

Views

14.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 12, 2017 Apr 12, 2017
Hi adamo, Sorry that you have an issue with playback performance! Thank you for providing all the details. What's the preset that you've chosen while creating proxies? GoPro CineForm proxies would be better performance-wise. Is the Video Renderer set to OpenCL?Let us know.Thanks,Rameez

Likes

Translate

Translate
New Here ,
Mar 25, 2017 Mar 25, 2017

Copy link to clipboard

Copied

One other thing of note: When I start to play the footage from my timeline in my program monitor, it will start off smooth for a few seconds, but over time it just deteriorates and becomes more and more choppy. Eventually, it will get to the point where there are a couple seconds between each frame.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 12, 2017 Apr 12, 2017

Copy link to clipboard

Copied

Hi adamo,

Sorry that you have an issue with playback performance!

Thank you for providing all the details.

What's the preset that you've chosen while creating proxies?

GoPro CineForm proxies would be better performance-wise.

Is the Video Renderer set to OpenCL?

Let us know.

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2017 Apr 12, 2017

Copy link to clipboard

Copied

Hi Rameez,

I had tried H.264 and then ProRes, both were choppy. Have yet to try GoPro

CineForm, but I'd prefer not to create all new proxies yet again.

Last night I tried to project on a brand new Macbook Pro, and played back

in 4k. It was certainly a smoother experience than previously given the

faster computer, better graphcis card, etc.

However, though the video playback would start out smooth, it inevitably

would get choppy again before playing through the end of the sequence.

I'm at a loss, I've tried this project on 5 different computers, I've used

every renderer available - OpenCL, Metal, and Software only when 30+gb of

RAM was available. I've tried proxies in both ProRes and H264. At one point

I even moved all my media to a solid state drive, and my normal drive was

thunderbolt! I've also moved all the media to a new premiere project and

essentially started over. What could be causing this choppiness?

I'm just confused.

Thanks in advance for your help,

Tim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2017 Apr 12, 2017

Copy link to clipboard

Copied

Hey guys! Thanks for the responses. I did end up trying out the GoPro CineForm and it's smooth as butter now. Finally! I've been pulling my hair out with every video, but now I can get some work done!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 01, 2017 Jul 01, 2017

Copy link to clipboard

Copied

I had a very similar problem to Tim and Adamo on this thread and was able to remedy it by changing the program monitor resolution to 1/4. I'm using RAW files at 4800 x 2700 and made ProRes proxies at 1920 x 1080. I think what's going on her is that as you toggle from original files to proxies, it references the smaller files but it doesn't change the sequence settings so that they match the smaller resolution of the proxies. If you don't alter the screen resolution, then Premiere feels obligated to try and fill a 4800 x 2700 timeline setting by blowing up the proxies on the fly in an heroic effort to match the pixel count of the larger, original resolution. By putting it at 1/4, the unscaled proxies more closely match the requirements of the program screen. How's that for an (un)educated guess?

James.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 17, 2022 Apr 17, 2022

Copy link to clipboard

Copied

LATEST

Wow. This was the solution for me thank you @James_B_M ! 

I'm editing in a 1080 timeline. RAW footage is 4k. Proxies are ProRes 720 (i didn't choose this it was the preset for ProRes).

As soon as I changed my sequence Program Window to display at 1/2 resolution, my proxies played smooth as butter. Pretty mindblowing that Premiere doesn't automate this type of switch. If I'm switching to Proxy use, OF COURSE i'd want to playback at the native resolution. Oy. At least it's fixed, thank you James. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 12, 2017 Apr 12, 2017

Copy link to clipboard

Copied

I second the above suggestion to stick with the included Cineform proxy presets only.  Don't use the H.264 presets.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines