Why is Windows 10 version 1909 the minimum required OS version on the requirement page for Premiere?

Community Beginner ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

What differentiates Windows 10 version 1909 technically from an earlier version? Why did Adobe decide to explicitly require it (and above) to run the latest Premiere Pro (and AE, Media Encoder, etc.).

 

I'm interested in this because we run 1803 at work and this is not something I have control over, it is managed by IT. Even for v15, 1903 and above were required, so we've been non compliant for quite a while now.

 

I'm not getting any warning when Premiere is opening, but should I be worried about this non compliant OS version? What are we losing out on? Performance? Stability? Something more specific?

TOPICS
Freeze or hang , Performance

Views

85

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Enthusiast , Mar 14, 2022 Mar 14, 2022
I think that sounds reasonable. They also may just put for that the lowest you can go, since 1909 is I think the oldest version of Windows. They will probably change it in a couple of months to 20H2.

Likes

Translate

Translate
Enthusiast ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

Because Win 7 & 8 are not supported anymore. You can't write a minimum specification an OS that isn't supported anymore.

 

Your not really losing that much, the OS shouldn't matter too much. And it says the build number they require, but Windows 10 in general should still work fine, as well as Win 7 & 8.


~Jake

Certified in Premiere, After Effects & Photoshop

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

To be clear, only inquiring about the build for Windows 10. I'm aware that a different OS altogether is a different story, but why be so specific (specifying the minimum build)?

 

My theory is it's because Adobe's dev teams test the softwares on (up to) these builds and therefore cannot guarentee compatibility with earlier versions but if someone from Adobe knows of an other more specific reason I'd be interested to know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

This is taken from an Adobe webpage:

 

  • Windows 10 LTSC build 1803: This build of Windows does not include the Dolby codec. You need to upgrade the LTSC build to the full Windows license.

Not sure if this is the reason for needing 1909

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

I think that sounds reasonable. They also may just put for that the lowest you can go, since 1909 is I think the oldest version of Windows. They will probably change it in a couple of months to 20H2.

JqkeFX_1-1647281455580.png

 

 


~Jake

Certified in Premiere, After Effects & Photoshop

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

LATEST

You both make good points thanks for your replies. And with that I just realized we're using a Windows 10 build that is no longer supported since May 2021! That sure could explain why Adobe has removed it from its bare minimum build requirement page.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines