• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Zoom to mouse cursor in timeline??

Explorer ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

Just installed premiere cc 2017 on my SurfacePro 4 - everything works fine except one frustrating annoyance:

I got a mouse with a wheel. Normally when I do wheel+alt over the timeline, it zooms in/out, and the zoom 'center point' should be "anchored" around the cursor. That's how it works on my editing workstation, and that's how it's always worked as long as I remember on every computer I had.  But now - it still zooms, but it zooms to whatever random point it wants - not to playhead, not to cursor.  Incredibly annoying and doesn't let me do my work!

This feels like it should be some very dumb/little setting that I just can't find. Can someone point me in the right direction to fix this plz?

(To be clear - I'm NOT talking about zooming video or any editing technique - rather working with the timeline/zooming in to see better.  Also - vertical/horizontal scrolling is NOT what i'm looking for.)

Views

14.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , May 30, 2017 May 30, 2017

I have the same issue with Premiere Pro CC 2017 v11.1.1: cannot zoom-in to a playhead with ALT+scrolling mouse wheel...

Windows 10 (build 14393.1198). I use 150% scaling in display settings for my 2560x1440 monitor which does not actually matter as the same thing happens on default 100% scaling.

Very very frustrating!!!!!

There is another thread on this particular important issue:

zooming in on a timeline/ sequence

Likes

Translate

Translate
Explorer ,
May 27, 2017 May 27, 2017

Copy link to clipboard

Copied

Anyone anyone?  Please help, this issue is infuriating...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2017 May 30, 2017

Copy link to clipboard

Copied

I have the same issue with Premiere Pro CC 2017 v11.1.1: cannot zoom-in to a playhead with ALT+scrolling mouse wheel...

Windows 10 (build 14393.1198). I use 150% scaling in display settings for my 2560x1440 monitor which does not actually matter as the same thing happens on default 100% scaling.

Very very frustrating!!!!!

There is another thread on this particular important issue:

zooming in on a timeline/ sequence

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 03, 2017 Aug 03, 2017

Copy link to clipboard

Copied

I marked this answer as Correct because we should try to keep this discussion in one forum thread. It seems to be a Windows issue because I and others are not seeing this behavior on macOS (even using older versions of Premiere Pro).

Feature Request/Bug Report Form

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

LATEST

New version on Mac - doing the same.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 15, 2017 Aug 15, 2017

Copy link to clipboard

Copied

Indeed... please submit a wishform.

I reported this bug on Feb 12, 2016, as part of a video: Premiere Pro 2015.1 Feature requests - YouTube

This has ALWAYS been a problem, in all versions of Premiere, on all (Windows) computers I've tried.

Furthermore, these are just two items on my 200+ Premiere Problems spreadsheet.

ALL Taran's feature requests and bug reports for Adobe Premiere - Google Sheets

I'd appreciate it if you would look through that spreadsheet, and submit your own wishforms for any bugs or missing features that you have encountered. (try to keep it to one wishform per bug/feature.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2017 Aug 25, 2017

Copy link to clipboard

Copied

I solved the problem by changing the scaling in Display setting > Scale and Layout to 100% and restarting the PC. Hope it helps others.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 31, 2018 Dec 31, 2018

Copy link to clipboard

Copied

Where is the Display setting? Three bar menu, is it in program options?

I cannot zoom on the cursor in the timeline for the same reason.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 01, 2019 Jan 01, 2019

Copy link to clipboard

Copied

right click on the premiere taskbar icon.

Then right click AGAIN, on the "Adobe Premiere Pro" text that appears.

Click "properties."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 04, 2018 Jan 04, 2018

Copy link to clipboard

Copied

You've probably already figured this out by now but it's only a problem with hDPI displays. Some people have proposed changing the Windows display scaling to 100% instead of the default 200%. Yes, that solves it but makes windows basically unusable because everything is tiny.

Here's the fix I found, though. Navigate to the .exe file for Premiere Pro in your Program Files/Adobe folder. Right click on it and choose properties. Then click the "Compatibility" tab and then the checkmark box for "Override high DPI scaling..." and in the dropdown menu set it to "System."

(Side note: I had a different problem with scaling in After Effects and in that case I had to set it to "Application" instead of "System" to fix it. Try the other options if one doesn't work.)

Once I did that, the timeline zooming worked like it used to on my old computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 06, 2018 Mar 06, 2018

Copy link to clipboard

Copied

Just logged in here and found few answers to this old question!  Yes - a few people on here are right!  I worked it out with the help of some people on reddit some months ago already.

Essentially the problem was indeed scaling - or the 4k resolution.  The solution to this problem was either to adjust the scaling setting or to change my display resolution from 4k down to 1080x1920.  Important: I had to restart after changing the resolution.  And then premiere worked just fine!

Except on an SP4 - i was left with little space to work with on the small screen and with HD resolution.  But the surface is no good for editing anyways.

Thanks all for your suggestions above!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines