Duplicate text in captions imported from .srt file

Explorer ,
Jun 18, 2018

Copy link to clipboard

Copied

I managed to figure out how to get my captions imported from an .srt file. The problem is that, starting from the 2nd caption block, every block displays the last sentence from the previous block along with the next sentence. So it just looks off because the last sentence always gets repeated again in the next block.

I don't know if this is how it's suppose to work or if there's a setting that can be toggled off. I open up the .srt file to compare it with what's being displayed and the original file doesn't repeat the text so it looks like a Premiere issue. I had to go into each block and delete the first sentence to get around this problem, but I was really hoping there's a better solution.

Thanx

Adobe Community Professional
Correct answer by Stan Jones | Adobe Community Professional

I had some fun!

The hard way: Notepad++, macros, blah, blah. Sorta worked. Took it to Subtitle edit to renumber...

Easy way (finally found it when back in subtitle edit): Open YouTube .srt in subtitle edit. Tools -> Fix common errors. Retimed! In PR, the times do not overlap, and displays as single line. I did not check the sync, but the times are in the ball park.

Give this a try if you can, or send me your original .srt, and I'll convert it and send back for you to test. (I'll send you a PM.)

Views

5.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Duplicate text in captions imported from .srt file

Explorer ,
Jun 18, 2018

Copy link to clipboard

Copied

I managed to figure out how to get my captions imported from an .srt file. The problem is that, starting from the 2nd caption block, every block displays the last sentence from the previous block along with the next sentence. So it just looks off because the last sentence always gets repeated again in the next block.

I don't know if this is how it's suppose to work or if there's a setting that can be toggled off. I open up the .srt file to compare it with what's being displayed and the original file doesn't repeat the text so it looks like a Premiere issue. I had to go into each block and delete the first sentence to get around this problem, but I was really hoping there's a better solution.

Thanx

Adobe Community Professional
Correct answer by Stan Jones | Adobe Community Professional

I had some fun!

The hard way: Notepad++, macros, blah, blah. Sorta worked. Took it to Subtitle edit to renumber...

Easy way (finally found it when back in subtitle edit): Open YouTube .srt in subtitle edit. Tools -> Fix common errors. Retimed! In PR, the times do not overlap, and displays as single line. I did not check the sync, but the times are in the ball park.

Give this a try if you can, or send me your original .srt, and I'll convert it and send back for you to test. (I'll send you a PM.)

Views

5.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 18, 2018 1
Adobe Community Professional ,
Jun 18, 2018

Copy link to clipboard

Copied

This does not occur in the  srt's I have used recently. Please post the first 4 or 5 subtitles here, or link to the srt file so I can take a look.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2018 0
Explorer ,
Jun 18, 2018

Copy link to clipboard

Copied

The first pic is after I've imported it on to Premiere. All that I do is open up to see the captions.

The second pic is what the raw file looks like when I open in notepad. The only thing I do in Notepad is save it to UTF8 encoding. But I also tried it with the default encoding and got the same results.

The .srt file is being generated from YouTube.

Thank you very much for your quick reply and your help.captions1.PNGcaptions2.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2018 0
Adobe Community Professional ,
Jun 18, 2018

Copy link to clipboard

Copied

The time codes are overlapping. That file won't work correctly. YouTube did not export like that on my last test.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2018 0
Adobe Community Professional ,
Jun 19, 2018

Copy link to clipboard

Copied

First, I was wrong. YouTube exported exactly like that!

But the timecodes do overlap, because the youtube "style" is credits rolling on, rather than popping on. Premiere imports and repeats a line so it is "correct" as to what is on the screen at any one time. But obviously, NOT correct.

Still playing with this....

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2018 0
Explorer ,
Jun 19, 2018

Copy link to clipboard

Copied

Thanx for looking into this.

Yeah, I figured it might be doing a credits-rolling style thing. That's why I didn't know if this was the way it suppose to display or if there was a setting I could change to display it differently. Because everything else seems fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2018 0
Adobe Community Professional ,
Jun 19, 2018

Copy link to clipboard

Copied

I only see options in PR for rolling (2-4 lines) and pop in if they are closed captions, at least not open captions.

I'm playing with a way to convert the YouTube downloaded .srt so PR will read it correctly (as a pop in).

I think I can also do it with a script, but that takes time...

I wonder if someone in YouTube land has also sorted this?

Little time today, so not much progress!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2018 0
Explorer ,
Jun 19, 2018

Copy link to clipboard

Copied

OK, well once again thank you very much for looking into this.

I managed to get my project done by manually deleting the first line of each block. But it would sure be helpful if I didn't have to do it this way next time. I'll keep monitoring and doing research on YouTube to see if anyone has a solution ready.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2018 0
Adobe Community Professional ,
Jun 20, 2018

Copy link to clipboard

Copied

I had some fun!

The hard way: Notepad++, macros, blah, blah. Sorta worked. Took it to Subtitle edit to renumber...

Easy way (finally found it when back in subtitle edit): Open YouTube .srt in subtitle edit. Tools -> Fix common errors. Retimed! In PR, the times do not overlap, and displays as single line. I did not check the sync, but the times are in the ball park.

Give this a try if you can, or send me your original .srt, and I'll convert it and send back for you to test. (I'll send you a PM.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2018 1
Explorer ,
Jun 20, 2018

Copy link to clipboard

Copied

Thank you very much!! This totally worked. I did as you suggested and it works. The sync is a little off in some areas but not bad enough where it would be a concern.

I hadn't used Subtitle Edit. The only captioning tool that I've used is Subtitle Horse  . This is much better because it also does the encoding; I was doing it in plain Notepad. So now I'll just add this tool to my workflow.

Once again, thank you very much!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2018 0
Adobe Community Professional ,
Jun 21, 2018

Copy link to clipboard

Copied

Excellent!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2018 0
New Here ,
Jul 19, 2018

Copy link to clipboard

Copied

Thanks all...so, is it to be understood that these vertically scrolling (one line rolling up to show the next line simultaneously) captions, commonly found on YouTube videos, are not possible in Premiere Pro CC, at least not yet?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2018 0
Adobe Community Professional ,
Jul 19, 2018

Copy link to clipboard

Copied

Not as open captions. This thread was addressing them only as open captions.

It appears to work as closed captions. You select all the captions in the caption panel, then set them to "Roll Up (2 lines)" - up to 4 lines.

I have not tested the full workflow. But I was able to burn into an mp4.

I was using a youtube export that had them already set as 2 lines.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2018 1
New Here ,
Jul 19, 2018

Copy link to clipboard

Copied

Great, thanks Stan!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2018 0
New Here ,
Mar 29, 2019

Copy link to clipboard

Copied

Hi Everybody, Same problem but I do not understand how you do :

- Easy way (finally found it when back in subtitle edit): Open YouTube .srt in subtitle edit. Tools -> Fix common errors. Retimed! In PR, the times do not overlap, and displays as single line. I did not check the sync, but the times are in the ball park. ---> Subtitle edit is a Software. I am on macosx and I see it only for windows ---> I try by using my windows computer waiting for a solution on mac 😉

- Subtitle Horse: Online Subtitle/Captions Editor | subtitle-horse.com don't understand how to use it, I put the link to my video subtitles doesn't appear, I try to insert the srt on the import solution but it don't propose to upload it.

Thank you for your precious help  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2019 0
Adobe Community Professional ,
Mar 30, 2019

Copy link to clipboard

Copied

I don't think Subtitle Horse will work.

I don't know what to try for Mac. You might try Aegisub, but I did not find a way to search for the equivalent of "fix common errors."

Regarding my comment above "Easy way …." Subtitle Edit has a function that looks at a caption file (e.g. srt), and finds and fixes "common errors." Very useful.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 30, 2019 0
New Here ,
May 14, 2019

Copy link to clipboard

Copied

Hey to all!

The suggested answer is good, although not perfect, so I came up with a better and easier solution. I'm working on Mac OS X and had to use Subtitle Edit on my partner's laptop PC which worked ok but... while it removed the overlapping times, it also messed up the timing a little bit randomly and on a 30 minute talking head video this is a lot of work to readjust the timings.

So ... thinking outside the box - because in Premiere Pro the currently spoken caption is always displayed at the bottom - the simple solution is to apply opacity mask to that caption track which will hide the top line and the duplicate line problem is fixed with perfect timings coming straight from YouTube! It even helps to make the caption background shorter as it seems to stick out far beyond the top of the line by default.

I hope this helps you guys. Have fun!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 14, 2019 1
New Here ,
Jan 03, 2020

Copy link to clipboard

Copied

Hi All! Thanks for your inputs on this! As far as i understood, the solutions you suggest apply in the case that you have uploaded the video and subtitles? What about when I, as an user, watch a video and choose to auto-translate and this occurs in any language I pick. What can I do about this?

 

Thanks for any help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 03, 2020 0
Adobe Community Professional ,
Jan 05, 2020

Copy link to clipboard

Copied

momoheim,

 > What about when I, as an user, watch a video and choose to auto-translate and this occurs in any language I pick. What can I do about this?

You will need to address each file created separately. But that may be as simple as a "save as" to the file. PR also has new options since this 2018 thread ("import settings" button in the Captions Panel).

You may want to start a new thread with your specific issues.

Stan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2020 0
New Here ,
Mar 17, 2020

Copy link to clipboard

Copied

 Beautiful.  I have tried it before but now with your suggestion i notice that you just need to check the box named "fix overlapping times" and it did fix the imported .srt from youtube with just a certain delay in some lines but its fixed!

 PD: Remember to Apply selection in the next step.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 17, 2020 1
Adobe Community Professional ,
Mar 18, 2020

Copy link to clipboard

Copied

ElGuato, thanks for those 2 tips. Very important!

 

SE opens with that selected; I wonder if I made that change and forgot.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 18, 2020 1
Community Beginner ,
Mar 22, 2020

Copy link to clipboard

Copied

Hey guys, I read this whole thread since I've got the same problem.  

 

Where is this 'fix overlapping times' checkbox?  And could you clarify...is subtitle editor (SE) a separate program?  Or where are you making these changes.  I don't see it in premiere pro import settings. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2020 0