.srt import and editing not working in Premiere CC 2019

Explorer ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

Hello,

I have a big issue with .srt files. I used to import .srt and add them to a sequence, then I used to edit size etc.... It is ok in Premiere CC 2018 but, it seems that all edit settings are doing nothing to the text . To reproduce the issue you just have to open Premiere CC 2019, load a .srt file and place it on the timeline, and try to edit captions settings (font size, font etc...). In my case I can see modification in the preview thumbnail of each caption in the "Captions" tab but, nothing is visible on the monitor, the text remains the same (very small and... that's it ).

Can you help me with this bug ? Thank you !

Views

13.3K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

I am not having problems with this basic functionality in 2019. There has been an issue that I have see on occasion (and other users complain of it also occurring randomly), where the appearance in the program monitor is not in sync with changes made - but the changes are usually visible in the captions panel.

That is similar to what you describe, but I do not recall it happening from the beginning of editing.

First, more info: what OS, exact dot version of PR, a screenshot of your captions panel.

If you can post the srt you are importing, I can take a look.

Relatively new is the ability to change the import characteristics. Look in the Captions Panel in the lower left for "Import Settings." If you know you need to change the font style, size, etc for all your captions, this does the trick.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 11, 2019 Jan 11, 2019

Copy link to clipboard

Copied

Thank you for your feedback !!!! After some tests I finally find out how to make .srt works in Premiere, but.... for me that is a bug !

1 - Start Adobe Premiere CC 2019.
2 - Load the video on the timeline.3 - Import .srt files and add it to the timeline. From now I can't edit the .srt layout (only have the preview in the Captions tab).

4 - SAVE AS the project
5 - Close Adobe Premiere CC 2019, start the software again.

6 - Load the project and now you can edit captions layout.

If you import other .srt, edit won't be possible until you save the project and restart the app....

To sum up.... when you import .srt you have to save the project before any edit of the captions layout..... (sic)....

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 11, 2019 Jan 11, 2019

Copy link to clipboard

Copied

Glad you found a way. I do not have to take those steps to get a caption stream to edit. BUT, when I do occasionally get this bug, it is steps like yours that may get it working again.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2019 Mar 21, 2019

Copy link to clipboard

Copied

Thank you! I was having same issue and now using this method I can edit the captions. 🙂

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 11, 2019 Dec 11, 2019

Copy link to clipboard

Copied

Thank you very much! I was stuck for one hour until I read your post.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

This worked for me! Had the same issue and messed around with settings for literally hours..couldn't figure it out.

Once again, Premiere being unreliable. Classic. Thanks for finding a solution to this bug.

 

T

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

This has helped so much. Thank you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 30, 2020 Sep 30, 2020

Copy link to clipboard

Copied

Thank you! Works for me as well! 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2021 Feb 07, 2021

Copy link to clipboard

Copied

ONE YEAR LATER AND THIS TRICK STILL WORKS! Thank you for saving hours more of frustration over caption fonts not updating. WOOHOO!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

The Import Settings for captions looks like a great feature but is not affecting the import. SRT captions still appear very small, apparently set for 720x480. I'm working in ProResHQ, 1920x1080, 29.97 DF. Any suggestions? SCC files are sized correctly but they're just too ugly. Manually adjusting font and size is not an option on long shows.  Thanks for any tips.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

Please post a screenshot of the caption import settings you are using.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

caption settings.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

It is working as expected for me. Check the pixel size of the caption stream - several ways, but look in the caption window.

But I think your problem is that the default for font size is "18" - pixels! For testing in a 1920x1080 sequence, I am using 40-50.

Even if the import does not go as planned, just select all the captions and change. In 2019 (don't remember when it changed), shift click or right click -> select all works.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

Thanks for the suggestions, Stan. I've tried both but with no change to the captions. I changed the import settings to 50-point font but they imported at 18. I "selected all" within the caption window, changed to 50, but the captions on screen remain small. I'll try relaunching program and see if this makes a difference. Also, working in High Sierra, 10.13.6.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

I don't know if this matters but the .SRT file was created by rev.com.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

I can't look till later today. Odd.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

I have as a new project, closed and reopened, and the caption feature works correctly. Thank you, Stan.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

meant to write "saved as" a new project.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

Not the first time something like that has captions working again!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 31, 2019 Mar 31, 2019

Copy link to clipboard

Copied

Strangely, the captions returned to micro size when I changed workspace view, but they returned to 50-point font this time with the "select all" in the caption window. Very buggy, but it seems to have worked.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2019 Apr 06, 2019

Copy link to clipboard

Copied

The "Save As" trick worked for me.  THANK YOU!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 20, 2019 Apr 20, 2019

Copy link to clipboard

Copied

If anyone could shed some light in the following issue I'd be grateful..

Working in PP with the captions track editing, finessing timings, duration...
Realizing they are open captions, where closed captions are needed.
Cannot find way to convert open captions to closed captions.So as a workaround I export captions as srt from PP.
I Set import Settings to CEA 708.

Then I Import the previously exported captions.
They come in as closed captions. Nice!

However their length is severely chopped.
Not even half of the exported captions make it back in.
I tested exported captions and are full length, but for some reason, when I import them not even a minute comes in...
Any suggestions?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 20, 2019 Apr 20, 2019

Copy link to clipboard

Copied

Look at the exported file and examine the first caption that does not come in.

Maybe paste here.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 21, 2019 Apr 21, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/Stan+Jones  wrote

Look at the exported file and examine the first caption that does not come in.

Maybe paste here.

nothing different found in the format.
here is the first caption missing:

11

00:00:44,146 --> 00:00:47,249

by the surrounding circumstances

or influences

Pehaps the generated xml has issues?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines