• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Custom multi material switch problems with inputs not showing up such as normal

Community Beginner ,
Oct 03, 2022 Oct 03, 2022

Copy link to clipboard

Copied

Hi, I am looking for a way to create a custom, multi material switch, so I can attach more than two instanced materials to it.


I have experimented with the 'switch' and 'multi switch' nodes and am using the 'material switch' as a starting point.

 

So far, I have run into the problem where some of the inputs are not detected, for example I have a normal input in the node editor, but it does not show up when I load the node in a different package. I have attached the sbs file so people can have a look.

 

My newest version I have taken the inputs and blends from the 'multi switch color' and 'multi switch grayscale' nodes and duplicated them across all the outputs.

 

In total I only have 4 color and 4 grayscale inputs, while when looking at the graph of the node there are clearly 5 outputs for color and 7 outputs for grayscale.

Image 1.png

 

I have also some errors but I cannot find a lot of information about it, since the substance forums are not available anymore.

Image 2.jpg

It also makes me wonder why there is not already an existing multi material switch.

 

What am I missing / doing wrong? And how do I fix it?

 

Ps. It also does not help that when looking online for help, the substance forums have not been migrated, or atleast put into read only mode, and you are getting redirected to Community.adobe.com.

TOPICS
Bugs & Crashes , How to , Substance Graph

Views

392

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 04, 2022 Oct 04, 2022

If you look at the standard material switch node, you will see it has instance parameters which are booleans (True or False) to turn on/off each input.

Your graph is using the 'normal' Boolean input to switch the additional blend node - but that 'normal' boolean input is not set anywhere. If you add that boolean input parameter to the graph and set it to True then publish your sbsar , it will work (the same goes for the other inputs which have the additional blend nodes giving a default output).

...

Votes

Translate

Translate
Community Expert ,
Oct 03, 2022 Oct 03, 2022

Copy link to clipboard

Copied

Hi

Your graph seems to load and work as expected here in v12.2.1. I got no errors and the switching works with 5 inputs

 

2022-10-03_20-16-15.jpg

Dave

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 04, 2022 Oct 04, 2022

Copy link to clipboard

Copied

Hey Dave,

 

Did you set the material to metallic roughness to get the normal input to show up?

 

Materials -> Default -> switch from Adobe Standard Material to Metallic Roughness

 

Or did you batch expose just the opacity in the blend node in the normal branch?

 

One or both cause me to have a normal map.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 04, 2022 Oct 04, 2022

Copy link to clipboard

Copied

Hi

I did not alter the default material - just left it on Adobe Standard Material, nor did I alter any batch expose settings.

I just opened your graph then dragged the graph onto another graph, where all the expected inputs showed correctly, then I plugged some of the provided PBR materials into it.

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 04, 2022 Oct 04, 2022

Copy link to clipboard

Copied

That's..., interesting. That works for me too, however when I publish the file, and then load the node by pressing the spacebar and looking it up, older versions would not show the normal input.

Any clue why that would be?

 

I have added an earlier version in sbsar format, which is on the Adobe Standard Material, and does not have the normal input when I load it via my custom nodes library

Could you confirm this for me?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 04, 2022 Oct 04, 2022

Copy link to clipboard

Copied

If you look at the standard material switch node, you will see it has instance parameters which are booleans (True or False) to turn on/off each input.

Your graph is using the 'normal' Boolean input to switch the additional blend node - but that 'normal' boolean input is not set anywhere. If you add that boolean input parameter to the graph and set it to True then publish your sbsar , it will work (the same goes for the other inputs which have the additional blend nodes giving a default output).

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 05, 2022 Oct 05, 2022

Copy link to clipboard

Copied

LATEST

It took me a while to figure out what you were saying, but thanks a lot. This helps a lot.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines