Disable JavaScript, Safari, increase of speed!!!

Enthusiast ,
Jun 10, 2009

Copy link to clipboard

Copied

Mac OS 10.4.11

Safari 3.2.3

Corporate Firewall

At work, I've had problems with the new Forums since they started; they have been slooooow. If I'd click on a Post to read it, it would take 10 minutes to open (exactly 10 minutes, I timed it).

But, if I disable JavaScript in Safari, I have no speed issues anymore. The Forums are now fast. The Posts open pretty much instantly (well in about 3 seconds – that's still 597 seconds faster than before).

Here is how to disable it:

Safari > Preferences > Advanced (the last Tab) > Click on "Show Develop menu in menu bar (last checkbox) > close window

This will add a "Develop" menu in the menus at the top of the screen (between Bookmarks & Window)

Now go Develop > Disable JavaScript

And you're done.

BUT, if you want to Start a Discussion, once you're in the "Post New Thread" window, you have to re-enable JavaScript to be able to type the message of your Post.

So far, it's working for me.

Develop = Developer

Views

1.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Disable JavaScript, Safari, increase of speed!!!

Enthusiast ,
Jun 10, 2009

Copy link to clipboard

Copied

Mac OS 10.4.11

Safari 3.2.3

Corporate Firewall

At work, I've had problems with the new Forums since they started; they have been slooooow. If I'd click on a Post to read it, it would take 10 minutes to open (exactly 10 minutes, I timed it).

But, if I disable JavaScript in Safari, I have no speed issues anymore. The Forums are now fast. The Posts open pretty much instantly (well in about 3 seconds – that's still 597 seconds faster than before).

Here is how to disable it:

Safari > Preferences > Advanced (the last Tab) > Click on "Show Develop menu in menu bar (last checkbox) > close window

This will add a "Develop" menu in the menus at the top of the screen (between Bookmarks & Window)

Now go Develop > Disable JavaScript

And you're done.

BUT, if you want to Start a Discussion, once you're in the "Post New Thread" window, you have to re-enable JavaScript to be able to type the message of your Post.

So far, it's working for me.

Develop = Developer

Views

1.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 10, 2009 0
Guide ,
Jun 10, 2009

Copy link to clipboard

Copied

RenéG wrote:


BUT, if you want to Start a Discussion, once you're in the "Post New Thread" window, you have to re-enable JavaScript to be able to type the message of your Post.

…or if you want to reply to a post, too.

I disabled JavaScript in Firerfox, and the speed increase is remarkable.  Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2009 0
LEGEND ,
Jun 10, 2009

Copy link to clipboard

Copied

I thought everyone used the NoScript extension in Firefox as a matter of prudence!  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2009 0
Guide ,
Jun 11, 2009

Copy link to clipboard

Copied

John Joslin wrote:

I thought everyone used the NoScript extension in Firefox as a matter of prudence!  

After trying NoScript I can confirm that it works as advertised, but, holy smokes, it's "prudence" carried to unimagined extremes!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2009 0
LEGEND ,
Jun 11, 2009

Copy link to clipboard

Copied

Ramón G Castañeda wrote:

John Joslin wrote:

I thought everyone used the NoScript extension in Firefox as a matter of prudence!  

After trying NoScript I can confirm that it works as advertised, but, holy smokes, it's "prudence" carried to unimagined extremes!

It is really simple to "Allow" trusted sites on the first visit, whereafter the permission remains sticky.


It is very revealing what a multitude of invasive scripts something like your favourite newsspaper wants to run on your computer!


There is also an optional button installed for the toolbar, to quickly "Temporarily allow all this page".

I think it is the single most valuable add-on for FF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2009 0
Guide ,
Jun 12, 2009

Copy link to clipboard

Copied

Perhaps.  But I found myself wasting a lot of time allowing and unallowing stuff.  Not very practical.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2009 0
LEGEND ,
Jun 12, 2009

Copy link to clipboard

Copied

Ramón G Castañeda wrote:

Perhaps.  But I found myself wasting a lot of time allowing and unallowing stuff.  Not very practical.

At first you do have a lot to do, but once you get into the swing of things and have permanent permissions on your trusted sites, it's no effort.


Especially with the toobar button.

nsa.jpg

Anyway, I just wanted to let people know about it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 12, 2009 0