Premiere Pro using Integrated and not Dedicated Graphics Card

Explorer ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Hello all, I have a quick, but important question about Premiere Pro CC 2018. It seems that Premiere Pro is using my integrated graphics on my CPU rather than using my installed and working dedicated graphics card to render GPU accelerated effects and such. I am running a fresh install of Windows 10 with the latest updates. I also have a fully updated Creative Suite. Below I have listed my system specs and screenshots for reference to the issue. Notice that under GPU Engine in Task Manager, it lists GPU 0, my integrated graphics. I have also done some research of my own, and I have come across adding the "cuda_supported_cards.txt" into Premiere Pro's installation directory. I have done that, and I have tried both typing "GeForce GTX 1060" and "GeForce GTX 1060 6GB" into the document, but its the same story for both cases: it uses my integrated graphics. The file currently lists "GeForce GTX 1060".

Thank for any and all help,

Ryan

System:

7th Gen Intel i7-7700K Processor (No current overclock)

nVIDIA GeForce GTX 1060 6GB

256GB M.2 SSD

2TB 7200 RPM HDD

16GB of 2400MHz DDR4 Memory

Windows 10 Pro 64-bit

Screenshots (Idle, Premiere Pro loaded and open, not rendering):

idle.PNG

idle 2.PNG

Screenshots (Premiere running, Rendering previews for a project of mine):

render.PNG

render 2.PNG

render 3.PNG

render 4.PNG

render 5.PNG

Text Document:

cuda.PNG

cuda 2.PNG

[Moderator note: moved to best forum for technical issues.]

TOPICS
Hardware or GPU

Views

368.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 22, 2021 Feb 22, 2021
We created a video on how to optimize your GPU for Adobe apps here! Take it with a grain of salt, if you have an Intel GPU using QuickSync, you're best off using that GPU for H.264 and HEVC (H.265).  Caroline

Likes

Translate

Translate
replies 158 Replies 158
New Here ,
Mar 07, 2020 Mar 07, 2020

Copy link to clipboard

Copied

I have solved the problem so that it uses the correct GPU, first you need to right-click the start menu and go to Device Manager, From there select "Display adaptors".  Within "Display adaptors", it should show the two GPU's select the integrated graphics card and right-click it and select "Uninstall device".  The system will need to reboot but now Premiere Pro will only have your prefered graphics card to select from.  This has solved all the issues for me.  Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2020 Mar 07, 2020

Copy link to clipboard

Copied

This doesn't resolve this issue. This suggested resolution was suggested
many times many threads ago... this is an old solution that didn't work
then and doesn't work now.

Simeon Hendrix

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

weipingl75112065 ,

Very interesting. I really had given up on this issue a while ago, but now that you bring this up, I am once again intrigued. I ran the same test on my PC and got similar results.

Sniffer.PNG

Because of this, I am curious if other people in this thread would run this test, what their results would be. I think if that all come back similar, we have probably found a bug, just like you said. I think that is in the best interest of all of us.

So, to initiate the test, first open your command prompt. This can be done by pressing the Window's logo + R on your keyboard to open the run window. Then type "cmd" (without quotes) and hit enter.

Then, type:

cd premiere_install_location

i.e. cd C:\Program Files\Adobe\Adobe Premiere Pro CC 2018

After, type:

GPUSniffer

That should start it. You can look at my screenshot to see how I did it. Then, if people could take screenshots and post them here, I think we may have solid evidence of a bug.

However, and as far as I know, the only thing to do from there is to just submit a bug report to Adobe. I don't think we as users can really do much else.

Let's see what we can find (and thank you for keeping this thread alive),

Ryan Thomspon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Thanks for the reply.  I saw something interesting in our GPUSniffer results.

At first, I thought the bug is that Adobe Premiere Pro CC always use the first GPU it detects.  Then again, I don't think Adobe engineers would make such a low level mistake.

Now, the GPUSniffer doesn't indicate which GPU is the integrated one and which is the external/dedicated one.  And it's almost impossible for the code to detect all the models of GPUs.  There is a possibility that the code is using the Total Video Memory to decide which GPU to use.  Since integrated GPU shares the memory with the system, chances are that it has more Total Video Memory than the external/dedicated GPU as shown in our GPUSniffer results.  I can't prove this because I couldn't find a way to limit the memory for the integrated GPU.

In any case, I am sure it would be an easy fix if Adobe makes this a priority bug.

Screenshot_022518_093759_AM.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

If you think this is a bug please report as such:

Feature Request/Bug Report Form

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

I've filed a bug report.  Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2018 Apr 29, 2018

Copy link to clipboard

Copied

I'm fairly new to all this, but I seem to be having the same problem. Very similar specs as well. Has there been any updates to this problem?

Intel(R) Core(TM) i7-7700 CPU @3.60GHz

16 GB RAM

Nvidia GeForce GTX 1060 6GB (MSI)

1TB

Windows 10 Home

gpu during render.JPGCapture.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

I have filed one as well. I linked this forum on the report that I submitted.

Ryan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2018 Apr 27, 2018

Copy link to clipboard

Copied

Hello, someone against the crop solution? I have the same problem, I can not make my grafia card work in premier pro cc 2018 I leave a capture of the test in CMD, honestly I do not understand anything I hope someone can explain the results that I have obtained, thanks

cmd.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 29, 2018 Apr 29, 2018

Copy link to clipboard

Copied

red hard ,

The results that you have posted in the image of your post show that you are having the same issue as the rest of us. Yours is interesting because your sniffer did not even list that your CPU has integrated graphics. Either way, I appreciate your post, but all I can suggest is to submit a bug report. If you do file a bug report, I would paste a link to this forum in your report. The conclusion that I have come to is that this is just a bug that has gone under Adobe's radar.

--------

HE1NOUS ,

It does look as if you are having the same problem as the rest of us. As far as I know, there has not been any updates to this problem. Again, all we can do is file a bug report and HOPE that Adobe will spend some of their resources to fix this issue. But, we have to remember that exporting is a very CPU intensive process. However, based upon my knowledge, I believe that the GPU should be used more than what it currently is.

I wish you two the best of luck. Below is a link to Adobe's bug reporter. Again, I would paste a link to this forum in your report.

Feature Request/Bug Report Form

Ryan.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Hello I am having the exact same issues as you all.

Render times are much much faster if you leave the integrated gpu turned on.

i can deactivate my onboard graphics but when i do, it renders cpu only and leaves my gtx1060 unused.

idealy premiere would use my gtx1060 for rendering, and has previously done, like last year everything worked just fine!

Adobe should have a fix for this by now!!! otherwise everybody using gtx1060,1070,1080 has useless gpus that they can not use for premiere rendering...

and i agree that rendering is CPU intensive but when i do a heavy export like 4k timeline with four 4k clips in it playing at the same time with gaussian blur and lumetri color put on, two playing in reverse I even receive usage of my onboard graphics of like 86%. So it is not a cpu only computation. That it would be nice to use the power of our GTX cards again.

Additionally, timeline playback performance slowed down as well. when playing a timeline with a lot of effects, my gtx1060 doesnt get used at all, like 5% at max.

Adobe please come up with a fix!! Last year everything worked fine without any problems!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

To file a feature/bug report, use the new and nifty 'user voice' system ...

Adobe Bug /Feature Request form: https://adobe-video.uservoice.com/forums/911233-premiere-pro

These forums are primarily a user-to-user setup, with product support staff monitoring. In general, the development team staff don't spend time here except on their own dime.

However, some of the best brains at this sort of thing do "hang" here in the hardware forum ... Bill Gehrke​ and ECBowen​ among others ...

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

R Neil Haugen​ ,

Thank you for your reply. I have submitted a post there under GPUs. It is under my username, rmthompson902.

Here is is the link to my post.

P. Pro not using correct graphics card – Adobe video & audio apps

Ryan.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

I added a comment.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2018 May 18, 2018

Copy link to clipboard

Copied

You have to disable the OpenCL renderer for the Intel iGPU, you make this from Registry

Navigate to the following locations :

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors\

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Khronos\OpenCL\Vendors\

There you will find the Dword for the IntelOpenCL64.dll  driver .. you either modify the value to 1 Which means False (disabled) and not use it, or do like me and delete the entry (technically deny the iGPU to ever be used as an OpenCL device) and restart your PC!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2018 May 18, 2018

Copy link to clipboard

Copied

There are two of them within each Vendor folder (so 4 Dword files total) do i delete all 4?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 18, 2018 May 18, 2018

Copy link to clipboard

Copied

Just to be sure just put a 1 (disable) at each first, restart and see if everything is back to normal.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 18, 2018 May 18, 2018

Copy link to clipboard

Copied

Ohim and thomasa18025948,

I appreciate your idea of editing the registry keys, although it seems a little heavy-handed to me. Although if it works, go for it, right? I have two things to mention here, and the first is a little bit more information on how to edit these keys.


First, use the Windows Key on your keyboard with the "R" key to open the run prompt.

WinKey + R

Then, type the following command into the prompt (then hit enter) to open the registry editor.

regedit

Next, hit allow if the UAC prompt comes up.

Finally, navigate through the directories on the left-hand side to the path you desire.

Once, navigated to the key that you are looking for, right-click the key and proceed to click "Modify".

Here, change the value to what you desire, then click "OK" to save the edit. You will need to restart after making any edits.

For us, first navigate to the following path:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors\

Next, change the value of both of the REG_DWORDs to 1 by using the above modification steps.

Now, navigate to the next path.

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Khronos\OpenCL\Vendors\

Again, change the value of both of the REG_DWORDs to 1.

According to Ohim, this should disable the OpenCL renderer for the integrated graphics and make it useless to Premiere. This should hopefully force P. Pro to use the dedicated graphics when exporting. However, I will not be making these changes on my system for the reasons below. I will not know if it works for me and my system.


The second thing that I should mention is that after the recent updates to the Adobe Suite, I have noticed that my GTX 1060 6GB IS (FINALLY) being used, during export. I have included a screenshot below. I am not sure exactly what changed, but nothing on the hardware side of things changed for me. Only a Windows 10 update and some updates to P. Pro have been made.

MDV GPU Usage.PNG

If you happen to know why my integrated graphics are not being used and my 1060 is, please let me know. However, as I am the original author of this thread, I do not want to mark anything as the correct answer yet as this may be a case unique to me and my setup. Please let me know what the case is for you.

I apologize for the lengthy post, but I wish you the best of luck,

Ryan.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2018 Jun 06, 2018

Copy link to clipboard

Copied

I have followed all the steps you have mentioned. However after changed the registry value and reboot system  but still not using Dedicated GPU I also facing issue the video play back screen become flip and color faded. Please help to resolve cc 2018 issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 10, 2018 Jun 10, 2018

Copy link to clipboard

Copied

If you are having issues, I would most definitely consider reverting the changes that you made. It is still hit or miss whether my internal or external GPU is used, but there is nothing more that we can be doing at this point to my knowledge.

Ryan.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2018 Jul 09, 2018

Copy link to clipboard

Copied

Hello guys,

thanks for the info so far.  I have the same problem.  I worked through all the suggestions here, but still have the same issue with the renderer not using the dedicated GPU.  In there any news on this?

Tim

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 09, 2018 Jul 09, 2018

Copy link to clipboard

Copied

That's something one seems to have to sort out on the individual computer, and not something there's any setting in PrPro for.

Which would be handier.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2018 Jul 09, 2018

Copy link to clipboard

Copied

Thanks for the reply Neil.  This seems to be a general problem between NVIDA and Adobe as to how the GPU usage is assigned.  I have the same problem on a desktop PC and my Laptop.  Both having a Nvida 1080 grafik card and an internal one, as described in this thread.  Unfortunately even disabling the internal grafic card  through the BIOS or the RegEdit as described above does not work.  So at this point I just don`t know which switches I could tweak in my system to get this working.  What is frustrating about this, is that I am currently editing a 360 VR Clip, and all those nice new VR Effects don`t work, even so the GPU is there and it is enabled in the project settings.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 09, 2018 Jul 09, 2018

Copy link to clipboard

Copied

That's ... painful.

My on-board graphics on my Asus mobo for my desktop are disabled, and PrPro has never 'seen' them. But for some, as you, this doesn't seem to help.

What the ... ? ... is one supposed to do? I dunno ...

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2018 Nov 02, 2018

Copy link to clipboard

Copied

For clarity sake, which updates are you referring to in your post?  Were they just general updates to Premiere/Media Encoder 2018 or did you switch up to 2019? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines