The official community for ColdFusion.
Recently active
I was forced to upgrade from Coldfusion 2018 to Coldfusion 2021, update 16. For our database connection we are using the Oracle wallet to use ssl authentication. This was working fine in 2018. Now with the upgrade it stopped working. The error is this:java.sql.SQLNonTransientConnectionException: [DataDirect][Oracle JDBC Driver]Error during renegotiation of SSL socket. I found this article on the same error that occurred with a version of the datadirect drivers:https://community.progress.com/s/article/Unable-to-get-JDBC-connection-to-SSL-enabled-multitenant-Oracle-database-with-HostNameInCertificate-option My question is, I know the version shipped with coldfusion 2021 is 6.0, but what is the patch/build version? I want to compare it against what is in the progress datadirect article to see if that is the problem. I already tried updating to CF update 17 for 2021, and that mucked up our other database connection as well, so I uninstalled it
Dear all,I'm trying to solve the vulnerability in object, following the guide at Log4j vulnerability on ColdFusion (adobe.com), but there are step not clear to me (in red my doubts):ColdFusion (2018 release)ColdFusion 2018 ships with log4j 2.13.3 and/or 2.9.0, and log4j 1.2. The former is impacted by this vulnerability, while the latter (that is, v1.2) is not impacted. Stop the server. Navigate to the directory <cf_root>\<Instance_name>\bin.Open jvm.config file and add -Dlog4j2.formatMsgNoLookups=true argument in java.args section. Save the file.Done Copy the patched log4j-core-2.9.0.jar file with JNDILookUp class that you have removed.Removed? I didn't remove anything until now. And copy where?The new file can be downloaded from here. If you find log4j-core-2.9.0.jar, move the file to a temporary location. If not found, skip this step.If I find it... if not found... W
dailyStatus = "select * from MyTasks ";if(Len(custom.ORDER)){ dailyStatus = dailyStatus & custom.ORDER; } else if (isDefined("URL.OrderBy") AND Len(URL.OrderBy)){ dailyStatus = dailyStatus & " ORDER BY " & "?" & " " & "?"; arrayAppend(params,{value:URL.OrderBy,cfsqltype:"cf_sql_varchar"}); arrayAppend(params,{value:URL.Direction,cfsqltype:"cf_sql_varchar"}); } else{ dailyStatus = dailyStatus & "ORDER BY TimeRemaining, LastModifiedDate"; } qryList = QueryExecute(dailyStatus, params, {datasource = REQUEST.CFG.DS}); This doesn't seem to work , because I'm getting error, Error Executing Database
I have problems with the mod_jk.log file, it grows exponentially until it runs out of space on the hard driveWindows Server 2022ColdFuision 2023Apache 2.4.62 (64Bits).<Connector packetSize="65535" protocol="AJP/1.3" address="::1" port="8022" redirectPort="8455" secret="9c59d633-9c26-4560-bf94-85faf8a3f382" maxThreads="500" connectionTimeout="60000" tomcatAuthentication="false"/> File mod_jk.log:[Wed Nov 27 17:02:10 2024] [10736:5656] [debug] wc_get_worker_for_name::jk_worker.c (157): found a worker cfusion[Wed Nov 27 17:02:10 2024] [10736:5656] [debug] wc_get_name_for_type::jk_worker.c (341): Found worker type 'ajp13'[Wed Nov 27 17:02:10 2024] [10736:5656] [debug] ajp_get_endpoint::jk_ajp_common.c (3779): (cfusion) acquired connection pool slot=0 after 0 retries[Wed Nov 27 17:02:10 2024] [10736:5656] [debug] ajp_marshal_into_msgb::jk_ajp_common.c (763): (cfusion) ajp marshaling done[Wed Nov 27 17:02:10 2024] [10736:5656] [debug] ajp_service::jk_ajp_common.c (2809): processin
Hi Adobe Community,I run a website NBI Clearance Online that provides important resources and guides for users. Many of the resources are offered as downloadable PDF files.Recently, I noticed some users experiencing slow load times when accessing these PDFs. I use Adobe Acrobat Pro for creating and managing the documents. Could you share best practices for optimizing PDFs for web performance while maintaining high quality?Thank you in advance for your help!Best regards,
Hello,has anyone experienced this error before?We are getting this error after we patched the Oracle server to 19.23 -> 19.24. In both Coldfusion 2021u12 (java 11.0.7) and 2023u8 (java 17.0.11) in the datasources with "Oracle" client we get this error in CFadmin: Connection verification failed for data source: DATASOURCE_Ajava.sql.SQLException: [DataDirect][Oracle JDBC Driver]arraycopy: destination index -1 out of bounds for byte[128] The exceptions.log show more details: "Error","http-nio-8500-exec-9","07/23/24","09:36:08","user1","[DataDirect][Oracle JDBC Driver]arraycopy: destination index -1 out of bounds for byte[128]"java.sql.SQLException: [DataDirect][Oracle JDBC Driver]arraycopy: destination index -1 out of bounds for byte[128]at macromedia.jdbc.oracle.base.BaseExceptions.b(|Oracle|6.0.0.1051|:1102)at macromedia.jdbc.oracle.base.BaseExceptions.a(|Oracle|6.0.0.1051|:976)at macromedia.jdbc.oracle.base.BaseExceptions.b(|Oracle|6.0.0.1051|:1128)at macromedia.jdbc.
Good morning,We used CF2021 and we installed the lates update 17. Started having issues with our login system in one box losing the cfathentication session var.I created a test login to trace the issue in the same box, because in other box works fine. The security team applied some stigs to the box lately and not sure if that is afecting the browser.When user login the first time the cfauthentication is not showing.Here is the application.cfc<cfcomponent output="false" hint="I define the application settings and event handlers."> <cfscript> //Define the application settings. this.clientManagement = false; // define the cflogin storage this.loginStorage = "session"; this.name = listLast(getDirectoryFromPath(getCurrentTemplatePath()), "\"); this.applicationTimeout = createTimeSpan( 0, 0, 0, 10 ); this.sessionManagement = true; this.sessionTimeout = createTimeSpan( 0, 0, 5, 0 ); this.setClientCookies = true; this.secureJSONPrefix = ""; </cfscript>
Hello, I am trying to setup a datasource using the Sybase JDBC 3 driver that we have been using since Coldfusion 9 but I am getting an error message: "Connection verification failed for data sourcejava.sql.SQLException: The method com.sybase.jdbc3.jdbc.SybDatabaseMetaData.getJDBCMajorVersion() has not been completed and should not be called." Please help me on how to resolve this issue. Thanks!
Hello, I would like to know if we can use our serial number in Coldfusion 2023 to use it on an older version like Coldfusion 2021?
Is there a way to preserve leading zeroes in a field when displaying in excel other than adding a ' at the front of the field? I have an id field defined in sql server as varchar but when creating an xls document using cfspreadsheet excel is interpreting the field as numeric and dropping the leading zeroes. I cannot have the ' leading that field since it is imported into another system.
We are starting to play with REDIS for session storage in Coldfusion 2016. When I use a basic REDIS setup everything works fine. However, when I create a REDIS cluster we get a Moved 1456 error message. I have been trying to find something on this but have not found a solution.Thanks,Kane
Team, In my code I'm trying to dynamically replace the # with ##. Code is ,for(key in localStruct.AdditionalFieldsToUpdateStruct) { localStruct.AdditionalFieldsToUpdateStruct[key] = replace(localStruct.AdditionalFieldsToUpdateStruct[key],'##','####','all'); } But while displaying, one field shows # and other shows ##, Not able to find the reason why this happens, Can you please help? Code where the fields are displayed , <td class="formRow">#local.fields[FiName].Display# </td>
Hello! I am getting a Java error when attempting to use the iText library to add an image to a PDF. Orr front-line staff uses Topaz signature pads to capture signatures. These files are then saved as GIFs. Our back-end office opens these applications, which are PDFs with form fields. The iText library takes the images and places them on the PDF. Attached is the error I'm getting, and also a code snippet. This runs fine in our dev environment, which is identical to our production. I get this error on production. Both servers are running Coldfusion 2023 update 11. Same Java version 17.0.6, etc. I'm at a loss as to why it would work on one but not the other. I'm not sure what I should be looking for.
Hi everyone,I using CF Enterprise edition on windows server. i have created a instance using the dashboard and when i start that instance i see this error in the coldfusion-out.log file There is already a Contentinstance1 running in the contentinstance cluster and i am trying to launch a new instance called "contentinstance2" add it to the cluster I have created config for each site selecting the content instance cluster ( using the CF Web config tool )Just trying to as much information as possible , : )I am new to this and any help is much appreciated.thanks,Nov 19, 2024 04:36:27 AM Information [main] - No services directory was found under C:\CF2021\ContentInstance2\wwwroot\WEB-INF. Nov 19, 2024 04:36:27 AM Information [main] - No modules directory was found under C:\CF2021\ContentInstance2\wwwroot\WEB-INF.
Is there any way to turn off the "Session rotated sucessfully." logging when calling SessionRotate()? It really fills up the logs.
I'm running in this error with CFLDAP after we updated one of our SSL certificates in our keystore. We have a few domains using this ColdFusion server (running CF 11). We believe that it is trying to use the SSL certificate recently updated, instead of the correct one (for the site that needs to communicate to the LDAP server).Error Message: An error has occurred while trying to execute query :SASL bind failed: some.server.com:1636. One or more of the required attributes may be missing or incorrect or you do not have permissions to execute this operation on the server.code:<cfldap server = "myserver" port = "1636" secure = "CFSSL_CLIENT_AUTH" clientcert = "/my/keystore" clientcertpassword = "mypassword" action = "query" name = "results" start = "mystart" filter = "myfilter" attributes = "myattributes" timeout = "600000">Is there any way to specify the certificate alias with CFLAP?Does anyone know how it chooses which certificate to use? like alphabet
A quick post in case anyone else ever runs in to this memory issue. Our CF servers seemed to have a "memory leak", in that the memory being used (Windows) by the CF service would gradually grow until it was maxing out the entire server. Long-story-short, we found (with the folks over at xByte cloud hosting) in a thread dump that we had tens of thousands of hung (waiting) threads with the name: sdk-ScheduledExecutor Turns out, that thread is created by the AWS SDK for Java, which we are not using. Not surprisingly, though, ColdFusion does use a version of this SDK for their cloud services functionality. We use that extensively when interacting with S3. At first we thought there could be a bug in CF or in the SDK if it's spawning all these threads. But, when pouring over Adobe's docs we found the following little tidbit on this page: Oh! The getCloudService() function must be in a shared scope? In true Adobe fashion, none of t
Document history 04/10/2024: The following are the changes to the log file: The log files contain the name of the scope in which the variable exist. Files included using cfinclude tag will be logged. In the last security updates of ColdFusion (ColdFusion (2023 release) Update 7 and ColdFusion (2021 release) Update 13), Adobe released hotfixes that addressed scope injection vulnerabilities. See the tech notes for more information. New patch update Adobe has released a patch for ColdFusion (2023 release) and ColdFusion (2021 release) to help identify the unscoped variables in a log file, and take corrective actions. The patch applies to ColdFusion (2023 release) Update 6 and higher, and ColdFusion (2021 release) Update 12 and higher. Adobe recommends you to be on Update 6 or higher and Update 12 or higher. View the tech note for more information. Please send us your feedback.
The plugin in Visual Studio code doesn't read the older report. How would I go about upgrading it, or updating in its currrent version/format?
I just updated to update 14 and i know per the tech doc: https://helpx.adobe.com/coldfusion/kb/coldfusion-2021-update-14.html they replaced cfmx_compat algorithm as the default. They say to use a flag, which i did as i need things to stay the same until i update my code. Here is my question. They indicate the flag will be available until next version after CF2023. Fine. They seem to indicate the jvm flag will go away and no matter what the default will not be cfmx_compat anymore. But they indicate higher up in the doc that cfmx_compat is not going away, just its not the default--meaning we can still use it if we specify it. My question is about after CF2023: the way this is written, is it just the flag going away or will the entire algo leave also? If all that is happening is they are changing the default algo (even after 2023 thats okay). My fear is if they remove it all together that will be problematic for me. If they keep it but I have t
We run a mirror site for disaster recovery, but when I tried to test my Coldfusion server, it would not start the service. I started manually and it was complaining about the cached license being invalid and then it tried to connect Adobe (which it can't do because of firewalls). Anyway, I was wondering what impacts that Device ID because I see that they are different and I think that is related to why my license is considered invalid.
Someone asked a question about implementing JWT in ColdFusion. After I composed a reply, I discovered the question had disappeared. My reply follows, in the hope it will help someone. Search the community, for example, by putting JWT in the search field. Inspect the search-results to identify which ones pertain to ColdFusion. One search-result you may find useful is Sdsinc_pmascari's "Generating JWT Token for Apple API Requests". It includes references to other JWT resources of interest to the ColdFusion developer.
I am new to this, I have setup clusters and two instances in each cluster. one instance is up and running and the sites are also working fine. i am on window server and using IIS. sending traffic from cloudfront to the server ( http bindings)when i start the second instance in the cluster i am getting errors and the site is not available, when i check the log file i see these errors:exception.log file :"Error","FelixStartLevel","10/25/24","16:38:00","","The Runtime service is not available. This exception is usually caused by service startup failure. Check your server configuration."coldfusion.server.ServiceFactory$ServiceNotAvailableException: The Runtime service is not available.at coldfusion.server.ServiceFactory.getRuntimeService(ServiceFactory.java:633)at coldfusion.monitor.inmemory.module.InMemoryMonitoringServiceImpl.onMonitoringDisabled(InMemoryMonitoringServiceImpl.java:486)at coldfusion.monitor.inmemory.module.InMemoryMonitoringServiceImpl.disableMemoryMonitoring(InMemo
applied update 17 to some of our dev servers and was told that certain code no longer works - specifically when invoking the split command - the below code is something being actively worked on - my concern is that there might be other things it could affect - is this unusual? <cfif len(trim(manager)) gt 0><cfset mgr = manager.split(",")[1]/><cfset mgr = mgr.substring(3,len(mgr))/><cfset mgr_fname = mgr.split(' ')[1]/><cfset mgr_lname = mgr.split(' ')[2]/><cfelse><cfset mgr = ''/><cfset mgr_fname = ''/><cfset mgr_lname = ''/></cfif> error from log:Error","ajp-nio-127.0.0.1-8020-exec-9","10/24/24","11:00:00","HumanscaleHostSite","The split method was not found.Either there are no methods with the specified method name and argument types or the split method is overloaded with argument types that ColdFusion cannot decipher reliably. ColdFusion found 0 methods that match the provided arguments. If t
I am trying to start up a development Coldfusion 2023 server using Docker that can run PDFg. I found the file https://github.com/carehart/awesome-cf-compose/blob/master/cf-2021-with-addons/compose.yaml and updated the images to CF2023. My first attempts at starting these servers had both services start up. But the main coldfusion service contantly "Checking addons startup status". I also didn't see the addons server listed under the PDF Service tab. After some experimentation I moved the - installModules above the -configureExternalAddons. This may be needed because I had to update the list of modules to be "all" due to the way our prod and test servers are set up. With this change the coldfusion server started up and was able to verify the PDFg Server status. At this point I used Docker Desktop to stop my container so I could work on another project. When I came back to this project I used the Desktop to start the container. The coldfusion container started up and produ
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.