Questions
Recently active
Hello all.Facing an set up configuration issue here. We have Application Server inside firewall and we are going to have Web Server out on the DMZ and that web server needs to communicate requests to the CF server.I installed cfusion instance HTTP Port 8500 Remote Port 8010 host is local host, with no cluster. We will have other instances following one addition port for HTTP and Remote down the line.So now the issue is how to I run the connector. If I run the shipped {cfroot}/cfusion/runtime/bin/wsconfig.exe, it shows localhost as the App Server, good there, but the web server is to be IIS, but on another IP address NOT this server, so the OK button stays gray. One would think that you would need to run the connector on the Web Server, right? Well, I don't have CF installed on it nor do I plan on installing it on my web server, so how do I get the connector working on the Web Server. I have read a post about taking a wsconfig.jar and pulling out DLL
Hi,I am trying to locate information on where Cold Fusion 11 should be installed.Currently, CF 9 is installed on the C drive where IIS is and there are no issues.I have replaced CF 9 with CF 11, but I have installed CF 11 on the D drive and having issues.Should CF 11 be installed at the default location on the C drive?Thanks,Mike
good afternoonColdfusion administrator configured the Mail on Office365 correctly.When I use the cfmail tag on from it only accepts email defined in coldfusion administrator.In FROM I need is any email.How do I work?TksOnly sends email on cfmail if I put in from the same account that is in the ColdFusion Administrator.It works like this?
Hello List;I have the following problem: Configuration a datasources to MS SQL Backend with option encryption enforced (by SQL Server).I goggled in the internet for the configuration of the datasource and find multiple articles/advices:Configuration a datasource type other with jtds.jdbc.Driver and manual configuration of the connection string:1. Downloading the driver and copy to the cfusion/lib directory: Done, the driver was recognized by coldfusion after a restart of the service.2. Copying the ntlmauth.dll to the bin directory of jre/bin: Done3. Configuration of the jdbc URL: jdbc:jtds:sqlserver://xxxx.xxx.xxx.net:1433/db: Works, I don’t get a connection timeout4. User and PW: Works: I don’T get a login failure.5. Advanced settings: Connection String: Maybe here is something wrong: EncryptionMethod=SSL; TrustStore=Path\sqlstore.jks; TrustStorePassword=xxx; ValidateServerCertificate=true; HostNameInCertificate=xxx.xxx.xxx.net;Error Message (Coldfusion logs/stack trace):
We found an issue related to the FORM submission in CF11. If the action attribute is not specified in the cfform tag, it does not generate the action using the current URL(Query-string values containing specific text are getting truncated ) .For example :sample URL : http://test.com/admin/index.cfm?page=test&prod=12 , in the given URL having the value 'prod' , after submiting this form , this URL will be showed like this - http://test.com/admin/index.cfm? with out query string values. How can we resolve this issue in CF11 . Please advise.Thanks in advance
Hello,We just upgraded to the latest build for Coldfusion 11 and our cfcharts are failing. The build is as follows 11,0,03,292480.I am getting this error:Error casting an object of type java.lang.Boolean cannot be cast to java.lang.String to an incompatible type. This usually indicates a programming error in Java, although it could also mean you have tried to use a foreign object in a different way than it was designed.java.lang.Boolean cannot be cast to java.lang.StringThe error occurred in C:/inetpub/wwwroot/cmis/e_survey/usage.cfm: line 141 139 : <cfelseif ListFind("1,2",answers.s_qtypeid)> 140 : <cfchart style="usage.json" format="png" chartheight="400" chartwidth="400" showborder="yes"> 141 : <cfchartseries type="pie" query="answers" itemcolumn="row_optionname" valuecolumn="total" /> 142 : </cfchart> 143 : <cfelse> We have been required to put in the latest update due to the security vulnerability.Can someone help me on whether there is a newer vers
Hello,I read some questions here forum, considerations of the number of processors (virtual or not).My understanding:- Each license CF11 STD supports 02 CPUs- My virtual machine is configured with 4 vCPU's (no core's). In this case, I am considering for licensing "4 CPUs."My scenario:- Virtual machine with 04 vCPU.- This virtual machine, run a site in Coldfusion and another site in .NET.- I would like to license only 02 CPUs because my site in Coldfusion needs few processing resources.My question:1) If I buy 01 license Coldfusion 11 Standard (02 CPU´s), I can install on a server with 04 CPU´s and configure ColdFusion to use only 02 CPUs? Is this possible?Thank you very much.
Installed CF11 on RHEL and all the files in cfusion/bin are set to rw instead of rwx. I've tried both an upgrade install from CF9 and a fresh, clean install after removing CF9. No change. I've also tried both the prod an prod-secure profiles. How do I get around this? I see nothing related to this in documentation for the Linux installer.
As part of securing some of our machines for DoD use we have to maintain up to date Java versions. To do this we install the latest JDKs and use the Server Settings > Java and JVM > Java Virtual Machine Path to then tell CF to use it. We've been doing this since CF4 with no issues and when we moved to CF6+ we continued the process but also after doing this we then remove the jre folder from the runtime folder from within CF itself. Well I just setup and installed my first CF9 + Win 2008 R2 server and after doing this the Solr service fails to start. This then had me digging into its folder structure and it has its own jre folder within its folder structure as well. However using Sysinternals Process Monitor I can see the Solr service is NOT using the jre folder from within it's own structure but is actually going up and "trying" to use the runtime\jre folder which I've removed so it causes the service to fail. I can actually remove the solr\jre folde
I have a client running ColdFusion 9 on Server 2008 R2 (64-bit). The server hosts several sites using ColdFusion. Starting Friday, one of the sites in particular seems to crash. It will not serve up any ColdFusion pages, but HTML is fine (I have a "test.html" page in the site's root that just serves up basic text) . All the other ColdFusion sites on the server are fine when this one crashes.There are no errors or entries on the Windows logs nor the ColdFusion logs about the cause. Only a restart of the "ColdFusion 9 Application Server" service brings the site back, but it will often crash a very short time later (sometimes within minutes)The sites IIS log does not indicate it is getting hammered from outside (i.e., does not seem to be any form of DOS attack), and several manual virus and malwarebytes scans come up clean.We are at a loss, currently, and hoping someone here might have some ideas of what is going on and/or how to fix it?I look forward to hear
I am trying to pass a JSON string representation for the attribute "plotarea" in this way :<cfchartchartWidth="800"chartHeight="600"showLegend="yes"format="png"title="Commandes"plotarea='#{"margin-top":"dynamic"}#' >But I got following error :Error casting an object of type to an incompatible type. This usually indicates a programming error in Java, although it could also mean you have tried to use a foreign object in a different way than it was designed.Is there any documentation explaining how to use "JSON string representation" in cfchart attributes ?
We have need seeing a lot of this error in our log. 50 or > at the same second. Developers feel that is the reason the application is becoming unresponsive and that Clients are calling in about the same time reporting that they are unable to access application.We are running CF 10 S Update 15 was installed yesterday and problem happened again last night. We are running an ORACLE database and Window Server 2008 R2."Warning","ajp-bio-8012-exec-38","12/15/14","14:41:19","CFADMIN","Unexpected characters found in locale."over and over again.Any suggestions?I have seen one other post on topic and the end result was to not worry about it, but it is troubling all the same.
As I'm sure you know CF Builder 3 isn't quite perfect yet and the Adobe Bugbase has a not-so-great search interface so I thought I would share some issues I reported recently which have impacted my workflow with the product. Perhaps some of my fellow developers have also run into these annoyances. If you have, or if you feel like supporting these issues to get Adobe's developers to fix them, I encourage you to also leave a note on each bug to increase the likelihood that they get fixed in the next release. Feel free to also post links to bugs/feature requests you've submitted and perhaps the community will also support your bug reports as well. Below please find the name and link to each bug/feature request. To vote for the bug please click the "my vote" button at the bottom right corner of the page.Bug 1:Code Coloring Breaks When Comments Used Within Function with Named ArgumentsBug#3831825 - Code Coloring Breaks When Comments Used Within Function with Named Argument
ColdFusion 11 Details:Server Details Server Product ColdFusion Version 11,0,03,292480 Tomcat Version 7.0.54.0 Edition Developer Operating System Windows 8 OS Version 6.2 Update Level C:/ColdFusion11/cfusion/lib/updates/chf11000003.jar Adobe Driver Version 5.1.3 (Build 000094) Sample error:queryError [Macromedia][SQLServer JDBC Driver][SQLServer]Procedure or function 'ListClientDPReceiptFormat' expects parameter '@idCient', which was not supplied. where (param 1) = [type='IN', class='java.lang.Integer', value='4', sqltype='CF_SQL_INTEGER'] Stored Procedure: <CFSTOREDPROC procedure="ListClientDPReceiptFormat"> <CFPROCPARAM TYPE="IN" DBVARNAME="@idClient" VALUE="#Request.Client.Id#" CFSQLTYPE="CF_SQL_INTEGER"> <CFPROCRESULT NAME="qryDPReceiptFormats"> </CFSTOREDPROC>This stored procedure and others like it worked fine until CF 11 upda
Is anyone else having issues with cf 10 update 15 and oracle datasource ssl connection string? Update 15 breaks the connection string.
I am responsible for several CF 9 Servers for a large group of developers and I have been more and more frustrated by the LACK of information in the application.log file.Specifically - the lack of user_agent in the log.I know that I can set a server side error file - but frankly - I just don't have the time to rebuild the proverbial wheel and recreate a whole new application just to trap errors.The existing log system almost has all I need to initiate a development support ticket - but getting flooded with Bots and PCI Compliance testing is resulting in a lot of wasted time searching for real errors.Are there any downloadable or purchasable code out there that already does the trapping efficiently and effectively?
ColdFusion 11 Update 3 is available for early access — Adobe ColdFusion BlogThanks,Adobe ColdFusion Team
This one has me quite confused. I have a baby test routine:testrun.cfm<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>Untitled Document</title></head> <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script><cfset dataout = timeformat(now(), "mm:ss")><cfquery name="testrun" datasource="#application.ccidatasource#"> update bridge set testtime = <cfqueryparam cfsqltype="cf_sql_varchar" value="#dataout#"></cfquery><script type="text/javascript">$.getJSON("cciBridgeServices.cfc", { method: 'testThis', tes
I'm behind a proxy server and I have added the following arguments to the "Server Settings > Java and JVM" in the Administrator-Dhttp.proxyHost=proxyhostURL-Dhttp.proxyPort=proxyPortNumber-Dhttp.proxyUser=someUserName-Dhttp.proxyPassword=somePasswordI can check for updates, but cannot download them. Where cna I download them from on the Adobe site?
We are considering adding ORM to an existing project. We have not worked with ORM in production before and this has the potential to be one of our biggest projects in terms of usage. For this reason, I have hesitated to suggest it, but i think it could simplify some things for us, specifically with respect to code maintenance and re-use. This is also the second phase of development, so all the query logic so far is in place without ORM, although we do have queries separated into a separate service layer. We are looking to get some arguments for and against using ORM it in production.Are people using ORM in large production projects now? Any problems or considerations using ORM mixed with native CF query methodologies (cfquery, etc)? What are some things to consider with respect to scaling and performance (I have played around with options for lazy loading, batch loading, and secondary caching using ehcache)? What about maintenance and security?
This is just a community service announcement. If you have a twitter account and want updates on CF related bugs and other information you might want to check out @cfnotifications or the corresponding website http://cfn.cfuser.com. The information comes from the Adobe bugbase. The twitter feed and website are not officially supported or sponsored by Adobe.
I have a <select multiple> Tag that lists out cities. Is there anyway to have a button that would select all contents in that field?
I have a page that is tall enough that it scrolls vertically. When it finishes loading, the browser automatically scrolls to the bottom of the page where a cfgrid element lives. It happens in IE, Chrome and Firefox.I've narrowed the cause down to the JavaScript that the ColdFusion 11 server adds to the top of the page. If I disable scripts in the browser, the page doesn't automatically scroll to the bottom.Adding window.scrollTo(0,0) to the body onload doesn't work. Whatever JS is scrolling to the bottom happens after the onload event. I haven't tried jQuery's .ready() yet; hoping there is a fix.Has anyone else seen this and know of a fix or workaround?
Adobe is running a ColdFusion User survey to understand various aspects related to ColdFusion such as product satisfaction, product usage, platform usage, purchase process, access to training resources and issues related to hiring CF developers. Adobe is working with a third party research organization to host and analyze the results from this survey.Survey will approximately take 20 mins of your time, but the detail in the survey may provide valuable insights into making the product, that you care for, so much better and relevant.Here is the link for the survey.
Can anybody help!Payment processor Chargify updated their SSL from SHA-1 to a Comodo SHA-2 SSL. Well this has caused major problems on my end. CFHTTP now returns "Connection Failure" and nothing more.I have:Downloaded the new cert from Chargify.com in .cer format.Used the keytool to import it to CACERTS sucessfully (Java version 1.4.2_19 Which should work)Restarted Coldfusion and that didn't workAlso downloaded COMODOExtendedValidationSecureServerCA.cer and COMODOCertificationAuthority.cer and added both CACERTS file via keytool import.Restarted Coldfusion and that didn't work.I'm thinking if they would have used Thawte or Verisign, I wouldn't have this problem. Anybody have any suggestions??? I've been pulling my hair out for the last 8 hours trying to figure this out.
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.