• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

How to disable the blue highlight boxes around links?

Explorer ,
Apr 26, 2012 Apr 26, 2012

Copy link to clipboard

Copied

I've created a document in InDesign CS5, and when viewed on Adobe Reader 10.2 (on an iPad) all the table of contents links within the document, and all links to external websites have a blue highlight field around them. While I appreciate the fact that it makes it obvious where links are, it looks remarkably ugly to have huge blue highlights all over the document. There must be a way to turn these highlights off, right? Either from the source document within InDesign before the PDF is created, or from within Adobe Reader or Acrobat after the PDF is made? I have all the links within InDesign set to "Invisible Rectangle", and it looks great when viewed on older versions of Adobe Reader or in iBooks. Unfortunately, older versions of Adobe Reader don't support hyperlinks on tablets. So somebody using Reader 10.2, however, is now forced to view this document with ugly blue highlights. Is the only option to avoid the highlights to recommend everyone use iBooks to view the document, or is there a way in Reader 10.2 to disable these?

TOPICS
Edit and convert PDFs , Windows

Views

107.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Nov 20, 2018 Nov 20, 2018

This worked for me in Adobe Acrobat Pro DC:

1. Go to Tools

2. Click on Prepare Form

3. Click on More next to the hammer and wrench icon

4. Click on highlight existing fields

Likes

Translate

Translate
LEGEND ,
Apr 27, 2012 Apr 27, 2012

Copy link to clipboard

Copied

Something to try.

In InDesign, Open the hyperlinks panel, select all of the links, click the dropdown menu and choose "hyperlink options". Under "Appearance>Type" choose "invisible rectangle".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2012 Apr 27, 2012

Copy link to clipboard

Copied

Thanks, but I already have all the hyperlinks set to "Invisible Rectangle", and there are still blue highlight fields around the links in Reader 10.2. If I view the PDF in other programs (iBooks, older versions of Reader) the links appear without the blue highlights. All the research I've done on this seems to point to the blue highlight fields being a "feature" of Reader 10.2, but I can't imagine that Adobe would create a feature with such a visual impact on documents without offering the option to turn that feature off? In a lot of print, online, and interactive docs both text and images are used as links (icons, buttons, etc) and having an automatic blue highlight around them really takes away from the visual impact that graphics provide. There must be an option somewhere to disable or turn these off, but I haven't been able to find it yet. Any other suggestions/ideas?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2012 Dec 18, 2012

Copy link to clipboard

Copied

Dear cjhaystead, I have the same problem and can't find the solution. Dit you find it?

Thanks a lot in advance!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 18, 2012 Dec 18, 2012

Copy link to clipboard

Copied

Hi martienyland-

I have not found a solution to this problem. All I have been able to determine is that the blue fields are a "feature", but that there is no way to turn them off. I have seen other people searching for some way to turn this "feature" off, but to no avail from what I have been able to find. Hopefully in future releases there will be an option to disable this, or it will just be removed as it is ugly.

Sorry - if you're able to find anything, let the world know!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2012 Dec 18, 2012

Copy link to clipboard

Copied

Thank you for your response. Let's hope and pray that Adobe will give designers the possibility to choose.

I posted a message  at the forum page.

Best regards, Martien

[private data removed]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2015 Sep 14, 2015

Copy link to clipboard

Copied

3 years later... still appears to be an issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2015 Nov 02, 2015

Copy link to clipboard

Copied

I have a possible solution.

  1. Go to Edit > Preferences
  2. In the Preferences window, under Categories on the left, select "Forms" from the list
  3. Under the Highlight Color section on the right, uncheck the box "Show border hover color for fields"
  4. Click OK

This removed all these big blue boxes that were essentially completely covering up the PDF document I was trying to read. Hopefully this works for jhaystead‌, martienyland‌, Alex MEV‌.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2015 Dec 10, 2015

Copy link to clipboard

Copied

I thought this was going to be a great fix, but once you send it out, it uses the default preferences on other peoples reader. A big, blue, box.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2015 Dec 30, 2015

Copy link to clipboard

Copied

I used the free web based version of Adobe Acrobat DC. This worked for me.

  1. Go To Tools ---> Search for 'Select Objects'
  2. Go back to your pdf document
  3. The 'Select Object should show up in your Tool bar
  4. Click on 'Select Objects' ---> Click on the ugly blue box ---> Right click and select 'Properties' ---> Select 'Link Type' = Invisible Rectangle ---> Click 'ok'

Happy New Year


Sameer Pimpalkhute

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

It works!!! Thank you very much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 16, 2018 Jun 16, 2018

Copy link to clipboard

Copied

Thank you so much.

This solution worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

I'm still trying to solve this. Anyone have any info?

I tried above method but could not find 'select objects'

I am also unable to right click the blue boxes.

I am sending my pdf's out to various mobile users and need these to go away! The local setting under preference only works locally and is of no help to me as my mobile users don't have the option available to turn this off.

PLEASE HELP

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

I did finally find a solution to this on another thread.

Go to Tools - JavaScript - Document JavaScripts and create a new doc-level script. Remove any code that is generated by default and paste the below code:

app.runtimeHighlight = false;

You can enable it as a doc-level script in your file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

Kaley,

thanks so much! Unfortunately I did not notice this was for adobe reader, I am using adobe acrobat standard DC. I do not have the option in tools to go to javascript so I'm a bit lost as to where to input the command.

I'll continue to poke around to try to find the right place, if any one knows please let me know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

Darn, Sorry I am using Pro DC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

I dont see that option. I can go to tools but nothing about java. I also find nothing when I search for tools.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

PM me?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Amazing! Thank you so much, this worked. Legend

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2016 Nov 08, 2016

Copy link to clipboard

Copied

Frustrating, right?  Exported my file to a thumb drive to race off to the printer and.. what are those blue highlights... drat!!!!

GOOD NEWS:  I figured it out!

Here's what worked for me, at least...

Select the frame where the highlight is appearing.

Go to:  Object, Effects.

Even if no effect appears to be set, pick one of the effects so that it takes you to the next screen.

Look at the list to see if any of the boxes have checks (here I noticed an "outer glow" was selected...aha!).

If you see a checked effect, click on the box to remove the effect.

Then save and export your file.

Viola!  Blue highlights have disappeared!

In my case, the blue highlight on my monitor was showing me an effect that was set, but not visible

because it was on a white background.  So... even if you have blue highlights in your file, I'm guessing

they won't print (like the old blue editing pencils).  But don't hold me to that without testing. 

Still, when you want to share a PDF file, with NO highlights, then try this fix.  I hope it works for you too!

Good luck!!!!!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 07, 2016 Dec 07, 2016

Copy link to clipboard

Copied

In Adobe Reader go to;

- Preferences

- Select Forms

- Under Highlight Color deselect Show border hover color for fields

Adobe Preferences.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 19, 2016 Dec 19, 2016

Copy link to clipboard

Copied

To make forms invisible, but still usable/fillable in Adobe Acrobat DC (is pretty similar to Acrobat Reader):

Acrobat Pro menu > preferences > uncheck the option "Show hover border color for the fields" o change appearance changing the colors for forms (default is light blue) and compulsory forms (default is with a red border).

(see attachment: sorry, my InDesign is in Italian).

Moduli.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2016 Dec 19, 2016

Copy link to clipboard

Copied

No no nooooooooooo!

Please read the comments earlier - disabling it in the YOUR preferences does not work for everyone else.
As soon as you send the pdf to someone else who hasn't disabled this particular preference then the blue box will still show.
This box is particulary annoying when sending invites out. You've probably spent a long time perfecting a very nice design thats then spoiled by having ugly blue boxes all over it.

There needs to be a file/object specific function or button that controls the appearence of interactive areas that then is shown correctly on everyones device.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 20, 2016 Dec 20, 2016

Copy link to clipboard

Copied

It's possible to set this option using a script, but it will apply to all other files opened on that computer, not just to yours, so it's not the best idea... Although you can inform the user that they should do it for the best viewing experience.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2017 Mar 11, 2017

Copy link to clipboard

Copied

I have a similar problem with a fillable form created using AcrobatDC. All of the text fields on the form are covered with blue highlight. When you click on the text field, the text appears, but it gets covered up again when you go to another field. And none of the them print the text!

So the form is completely useless for sending out to users to collect information and have them send the PDF form back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines