Multi-Frame Rendering is here! (AKA The multithreading you’ve been asking for)

Adobe Employee ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Multi-frame Rendering is here for After Effects beta users. Right now, you will have access to Multi-Frame Rendering for export only. Keep your eye on this forum, as we will be rolling out new features until we launch.

 

Internally, we have been testing a representative sample of projects with a suite of hardware configurations, and we are excited to finally put this feature in your hands and get your feedback. Test your unique projects on your own hardware so we can ensure that our performance updates benefit all of our customers and meet speed and quality metrics before we launch.

 

Beta testing of Multi-Frame Rendering will last a little longer than some of our other features because we currently do not support Multi-Frame Rendering in Preview, Motion Graphics templates, Dynamic Link, Adobe Media Encoder and AERender Command Line Interface.

 

Check out the blog and FAQ post to learn the following:

  • What is Multi-Frame Rendering?
  • What factors influence performance?
  • Which effects have been optimized for Multi-Frame Rendering?

 

Start Testing!
We want to hear from you! Share your thoughts and ideas in this forum.

  • How much faster is Multi-Frame Rendering compared to Single-Frame Rendering with your comps on your machine?
  • Does our benchmark project perform at the expected speed on your system?
  • If you run into specific speed or quality issues with your project, share your project with us at mfrbeta@adobe.com.

 

Test Your Comps
Test your comps in Multi-Frame Render mode vs. Single-Frame Render

  • Use Ae Render Queue to export your comp in Multi-Frame mode.
  • Purge both the disk and memory cache, then
  • Use Ae Render Queue to export your project in Single-Frame mode. Note: Use the same output module for Single-Frame and Multi-Frame mode. Go to Preferences -> Memory and Performance -> Enable Multi-Frame Rendering (beta) and uncheck the box to use Single-Frame Rendering Mode

 

Leave a comment and the following information in this forum:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed (Use “Render Time” noted in your status bar)
  • Multi-Frame render speed

 

If you detect any problems with render speed or quality, submit your projects

  • Open your After Effects project
  • File -> Dependencies -> Collect Files -> Collect -> Save As (Name Your Folder)
  • After Effects will store your .aep file, footage, and text report (file log)
  • Zip up your project and send it to us at mfrbeta@adobe.com (or send a link to it hosted on your creative cloud storage if it’s too large to email).

 

Share the following information in your comment:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed (Use “Render Time” noted in your status bar)
  • Multi-Frame render speed
  • Mercury CPU or GPU Mode used

 

Test our benchmark project and see how your hardware compares
We would love to know how your hardware compares to the results we have gathered from our test suite:

Benchmark Render Speed Improvements.png

 

To test the benchmark project on your machine:

  • Download the benchmark project
  • Use Ae Render Queue to export the benchmark project in Multi-Frame mode.
  • Purge both the disk and memory cache, then
  • Go to Preferences -> Memory and Performance -> Enable Multi-Frame Rendering (beta) and uncheck the box to use Single-Frame Rendering Mode
  • Use Ae Render Queue to export the benchmark project in Single-Frame mode. Note: Use the same output module for Single-Frame and Multi-Frame mode.

 

Share the following information in this forum:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed
  • Multi-Frame render speed
TOPICS
Performance

Views

52.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 448 Replies 448
Explorer ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Can you try switching to a workspace, such as Minimal, where the various additional panels you have installed aren't active or shown? The times we've seen this appear to be related to custom or third-party plugins or script-UI based panels that are interferring with the MFR preview process. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Switching to Minimal doesn't help in my test case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

eyy jenkyy lad, thanks for the concern: minimal workspace doesnt do the trick for me am afraid. here's two captures of what's happening, [1st video uses no 3rd party plugins]:

https://drive.google.com/file/d/1AgjInBP03tKSR-6jfxfF4Z96sA9Qc-sS/view?usp=sharing

https://drive.google.com/file/d/1tcIBqjrn1RlfLFJIiOuyM0E0YwG3zn_9/view?usp=sharing

 

when MFR is turned off, the problem seems to mostly resolve with occasional slight stutters. In AE 18.4.1 playback of rendered video is always perfectly smooth.

 

I don't think  ir can be isolated to a specific point in a project, because, as you see from the video it comes and goes completely randomly. It seems to worsen with more complex projects.

 

I should also mention, it's been this way for every build including the beta for me.

 

I noticed me and Juan both have GTX 1080 's [mine's a ti], maybe it's the GPU?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

Hi ntimes9,

 

Thank you for including screen captures with your report! Slow playback after caching is complete frequently indicates some of the frames got swapped to disk by the operating system. This would be consistent with with the known issue of After Effects not fully obeying the memory limit set in preferences. We are close to having a fix for this available in beta releases. In the mean time you can try reducing the amount of memory available to After Effects in Preferences -> Memory & Performance.

 

Thanks,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

Hi @jason_bartell,

 

Even though this was addressed to ntimes, I assumed it would also apply to my case. I don't think the problem is related to OS swapping. I configured my OS to remove both page file and swap file completely. After reboot, I still saw the same slow playback on footage that indicated itself as rendered.

noswap.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

Hi Juan,

 

Thank you for the detail. I suspect the issue you are encountering is different given that you have disabled the page file. We'll try to reproduce this in house.

 

Thanks,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 09, 2022 Feb 09, 2022

Copy link to clipboard

Copied

Very thankful for your help Jason, sorry to say it didn't work for me --> limited AE to 8GB of 64GB RAM in v22.2 and the Beta, but same issues.

 

To clarify, when AE is loaded with MFR OFF the playback of the SAME preview section that was just played jerkily with MFR ON is totally smooth, and that's WITHOUT purging disk cache.

 

Here's one of my complex* projects that plays jerkily, much obliged if you'd take a look: https://drive.google.com/file/d/1IZEdLCfhanY8typZ86JoT9wXUuEcOamP/view?usp=sharing ...if it plays smoothly at first try clicking around playing different parts or purging and reloading AE -- I've found it will always eventually slow down.

 

*If I delete enough layers/nested compositions it will play perfectly: playback jerkiness is directly proportional to project complexity.

 

Cheers!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

Hiya, quick follow up --> it's not specific to my computer,  I tried my same 3D high resolution complex projects [no plugins, mercury software renderer only, minimal workspace] on my laptop [win 10 / i7 8750H / GTX 1070] and playback of cached preview is still jerky. Simpler lower res projects with a few layers playback normally.

 

IMPORTANT: just turning off MFR and replaying the preview doesn't fix playback, you need to turn off MFR and restart AE... then the playback is smooth... NO disk cache purge required. Hopefully that information is useful.

 

Unfortunately all I deal in is complex animation so I'll never get to use MFR in it's current state, which is ironic since apparently it better speeds up render time of higher complexity projects. So basically if you can't help me I give up, heheh!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 05, 2022 Feb 05, 2022

Copy link to clipboard

Copied

Here's one of my projects [sorry it's large]: https://drive.google.com/file/d/15pdaQ1ao7JXZqPnete1nzIeV2jkunV-K/view?usp=sharing

 

The preview playback is intermittently smooth and jerky [try clicking around on the timeline and playing like I did in the sample video], though if I delete enough layers / nested comps it plays smoothly, so this issue is directly related to project complexity and nothing else.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 05, 2022 Feb 05, 2022

Copy link to clipboard

Copied

Can you let it keep rendering for 10-15 minutes after it says it's fully rendered? When I tried it, the preview became smooth. Not to say this isn't still a legitimate bug but it might help Adobe find the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 11, 2022 Feb 11, 2022

Copy link to clipboard

Copied

Hi ntimes9,

 

Thank you for the example projects! I downloaded both of these and we'll try to reproduce the playback issue in house.

 

Thanks,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 13, 2022 Feb 13, 2022

Copy link to clipboard

Copied

Thank you sir! -- though please understand this is not specific to my project; this issue has been observed by me, Juan [and maybe Jenkmeister?] on your official Pulse project: https://drive.google.com/file/d/1xIZFCuzm5PWqmyW0-gSaH_8aiIfXtcBn/view?usp=sharing

 

Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

I am also having performance problems previewing a project that go away when MFR is turned off. Specifically with MFR turned on, the timeline will appear to have rendered completely but during preview it hits a patch and starts slowing down. The FPS then goes way down - as you can see in the screenshot below, it's barely going 1 FPS. I've tried different things:

- Emptying the media cache and DB
- Trying all the different preview resolutions
- Switching between CUDA, Software, and OpenCL

 

My PC: Windows 10 / i7-8700 @3.20GHz (6 cores) / 32 GB RAM / NVIDIA GeForce GTX 1080 (w/latest driver) / 2T NVMe

 

IMHO, a failure mode where the timeline appears to have rendered successfully (according to the green line) and yet the preview fails to perform in realtime is something that Adobe should address right away. I will not enable MFR until Adobe at least fixes that.

 

The bug does seem to be project specific, however. I don't see this issue with the Pulse app.

 

nrt2.jpg

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Is this a project you are able to share with us so we can see if we can reproduce the frame rate issue you are seeing? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Was this addressed to me? If so, sure. I'm trying to pare it down to a minimal reproducible test case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Sorry, yes to you. The forums software moved this to a new page so it lost its connection to your original message. Feel free to post it here or if you need it to remain private, email it to mfrbeta@adobe.com and we will be able to access it there. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Bug exposing project is here. With MFR on, even after fully rendered the preview consistently starts slowing down at around 14:00 (in point of Clock). Unfortunately, I was not able to pare it down any further without losing the bug. Hopefully, someone will be able to reproduce it. Let me know if anyone does.

 

These are my computer specs:

 

Windows 10 / i7-8700 @3.20GHz (6 cores) / 32 GB RAM / NVIDIA GeForce GTX 1080 (w/latest driver) / 2T NVMe

 

Update: I now find that, if you wait long enough (several minutes, even for quarter resolution), the composition will preview in realtime. So it must have continued the render process even after the green line indicated fully rendered. But the total render time still is painfully slow compared to single frame rendering.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Thank you for pulling that project together. We'll take a look and let you know what we find!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

BTW, in case anyone is curious, this project does render the output file faster with MFR than without it:

 

With: 7:32

Without: 11:32

(Lossless AVI)

 

So I'd like to use MFR for rendering output, but the problem with rendering for previews is too big of a concern.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Hi @jenkmeister, was anyone able to reproduce the "slow preview on rendered footage" bug? I think @ntimes9 may have a point when he observed the similarity in both of our PC configurations was the GTX 1080 card. Do you have a test machine with that GPU?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

I was able to reproduce this bug on the Pulse benchmark project as you can see in the video (slowdown starts at 6:12).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Yes, we are able to reproduce the issue and are working on fixes. That said, a few things you could try to help us gather a bit more data:

 

1. After you have previewed the comp and then you see the slowback happening: Pause the playback, switch to a different comp and then switch back to the slow comp. Does the green cache bar change in what's shown? One issue we've reproduced is AE is running out of memory and is purging rendered frames but the cache marks aren't correctly updated to show that. 

2. A few replies above is a "I now find that, if you wait long enough (several minutes, even for quarter resolution), the composition will preview in realtime." - That's likely the Cache Frames While Idle functionality kicking in and re-rendering the frames that may have been purged. That theory can be tested by turning off that feature from the Composition -> Preview -> Cache Frames While Idle option. 

3. Check to see if your disk cache is turned on. When frames get purged they should be pushed into the disk cache and then recalled quickly as needed. However if the disk cache is disabled, that's more likely to cause the purging described in #1. 

 

Thanks

Sean

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

Thanks for the response. I can tell you right off the bat the disk cache is definitely turned on and I am purging both it and the DB before each test. I will work on 1 & 2 and get back to you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 10, 2022 Feb 10, 2022

Copy link to clipboard

Copied

@jenkmeister  - here are my observations:

 

1. The green bar does get shorter when I switch to another comp and come back. So it seems to be losing rendered frames. My memory usage seems pretty high at the time so your conjecture may be correct.

2. This conjecture seems not to be borne out. I turn off "Cache Frames While Idle" and see the preview slowdown on rendered footage. However, it seems to recover after a few minutes and play correctly even though speculative preview has been turned off.

 

Wayne

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources