AI (illustrator) layers not showing up in AE (after effects) CC 2014

Explorer ,
May 01, 2015 May 01, 2015

Copy link to clipboard

Copied

I've just come across this issue for the first time. I've imported AI files into AE many times before and had no issues like this one.


After importing the layered AI doc into AE, only one layer will show up. Attached is a video I recorded of what happens. If you can make sense of it, please let me know.
Note: I can save out eps as separate files and use those in AE no problem.

I'm working on a macbook pro retina and just did a fresh format about 2 weeks ago so everything is up to date. I've tried restarting AE and my computer. Also recreating a new AI file with different dimensions.

I blocked out the files on my computer in respect to my clients (in case you're confused).



TOPICS
Error or problem

Views

73.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , May 04, 2015 May 04, 2015
I figured it out... you can't have more than one artboard in your illustrator file. I didn't know that but it makes sense now that I've come across the answer.

Likes

Translate

Translate
Explorer ,
May 01, 2015 May 01, 2015

Copy link to clipboard

Copied

Sorry for the low res. I had compressed it before I realized it was an embedded link from youtube.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 01, 2015 May 01, 2015

Copy link to clipboard

Copied

the error message at the end says "After Effects warning. Could not create outlines. Empty or unsupported content."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 02, 2015 May 02, 2015

Copy link to clipboard

Copied

My experience is that Illustrator folks DO NOT create layers.  They think that a groups and stuff like that constitute layers... and they don't.  There's a "make a new layer" switch in Illustrator that goes mostly ignored.  So check that you've actually made layers first.

Next, make sure the document color mode is RGB and not CMYK.

And then in AE, import the illustrator document as a composition.  If happiness doesn't ensue, you have other issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2015 May 04, 2015

Copy link to clipboard

Copied

Thanks for your reply, but unfortunately that's not it.

I've tried: having all the assets on separate layers, making sure the doc was in RGB, renaming the illustrator file, saving it back to different versions of AI, loading into a different AE file, and so on. I have a feeling it has something to do with the paint bucket tool. I've outlined/expanded my graphics just incase, so it shouldn't be.


OH HEY! I've seen a lot of your posts on creative cow as well in the last few years. You're kind of like a AE community celebrity to me haha.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 04, 2015 May 04, 2015

Copy link to clipboard

Copied

Couldn't create outlines..... are you building a design out of text characters, perhaps?    It's easily solved by using the convert to outlines command in Illustrator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2015 May 04, 2015

Copy link to clipboard

Copied

sorry, that's what I meant. I've forced everything to vector. There's nothing "live" about the graphics. I've also double checked that the layers aren't checked off as templates.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 04, 2015 May 04, 2015

Copy link to clipboard

Copied

I figured it out... you can't have more than one artboard in your illustrator file. I didn't know that but it makes sense now that I've come across the answer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 04, 2018 Jul 04, 2018

Copy link to clipboard

Copied

I deleted one artboard but I still get same error? Help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2016 Jan 18, 2016

Copy link to clipboard

Copied

man, you helped me so much!!!

thank you for writing that answer...

saved me a lot of nerves and stress

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 13, 2016 Sep 13, 2016

Copy link to clipboard

Copied

you can't have more than one artboard in your illustrator file.

this statement is actually not accurate. you can work with 2 artboards when importing an illustrator file to After Effects and sometimes you really should. different sized artboards are great for the design process in Ai, but when you want to prepare your files for Ae. you should work within your final output dimensions. for example a common output is HD (1920x1080) so you would to work with an artboard at that size, and if you got objects bleeding to the pasteboard - you want another artboard that is bigger than HD and contains the partly cropped object. for this reason there are video templates in Ai and they have 2 Artboards and not one so that object that are on the pasteboard (or partly on the pasteboard) won't be cropped in Ae.

let's see for example the HDTV1080 Preset.

it comes with 2 artboards and this is a good thing:

it's an HD artboard on top of a very big 14400x14400 artboard. as stated in the tutorial later in this post, this is said to be a magic size for this trick to work and not crop layers, but I have found that any artboard that is larger then the HD artboard and contains the cropped elements this is good

when I import it to Ae, it will not be cropped

this is actually very useful. but what am I explaining this when you actually have the lovely Trish Meyer to explain it to you in this free video from Lynda: After Effects Hidden Gems

more about preparing your work from Ai to Ae in here: Preparing and importing still images in After Effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 27, 2017 Feb 27, 2017

Copy link to clipboard

Copied

Thanks for posting the 'Preparing and importing still images' guide, the solution for this issue for me was this:

To ensure that Illustrator files appear correctly in After Effects, select Create PDF Compatible File in the Illustrator Options dialog box.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2018 Mar 15, 2018

Copy link to clipboard

Copied

Thanks man..You saved me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 01, 2020 Oct 01, 2020

Copy link to clipboard

Copied

Selecting 'Create PDF Compatible File' in the Illustrator Options dialog box totally worked for me!
I had tried several things but this was the one. Thanks a lot!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

Thank you, this helped me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

you saved my life

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2020 Feb 01, 2020

Copy link to clipboard

Copied

Man I found it !

Had a similar problem, I was working on an illustrator file with an image in one of my layers.

No matter what I did, nothing showed up in AE for this image, even though other vector layers were ok.

I also have to mention that this problem only occured on PC, on Mac everything ran fine.

I tried everything suggested in this forum and looked for answers on the net, nothing worked for me.

But while trying different settings on AI, I let AE opened with this problematic imported file.

I turns out that the not showing image imported from AI finally appeared, but took 15 minutes to do so, no loading bar to hint me.

I figured out it had something to do with the image settings inside AI. 

What you have to watch is the image size. Even if you're image appears in a small portion of your artboard, illustrator manages links to your assets, as AE and InDesign do, and use the original size of the asset.

Open your Window >  Links panel, and select your faulty image.

Turns out mine was 4947x9178, 363dpi ! Even if I worked in a 1080x1920 artboard !

So huge that AE struggles to show it (on PC, strange things that my weak mac air has no problem.) !

The solution is to reduce the image size to something more manageable.

Select your image, then Object > Rasterize

Color Mode RGB

Resolution : 72 dpi (we're working for videos, not print !)

Click ok, save your document, and now everything should work fine !

(Also check other suggestions if it doesn't work ! )

Cheers !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Make sure your CAPLOCK not checked, or artwork not show up

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

Hi jonathan, thank you for your attention !

I know this caplock thing, the problem wasn't here! 😉

Wish I could send the problematic file as an example!

Best

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

thank you! this solution worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

I am facing the same issue, thank you for sharing your experiment and the solution for it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

I have tried all the methods but all in vein. After a long time I got this. You should check this.

How To Seperate Objects to Their Own Layers | Illustrator Tutorial - YouTube

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

LATEST

Always make sure you when you save the AI files, you choose save as PDF option. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines