How to stop AE from auto-renaming my layers?

Community Beginner ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Hi there!

I am having this issue since the latest AE update (18.4.0). When I bring in a linked file - ie. .mp4 or .jpg, and create a duplicate of it or splipt it, it automatically renames the layers. i.e filename.mp5 filename.mp6, filename.mp7, or finename.jpg 2, and so on...

This is becoming problematic because in previous versions, these layers used to be named [filename.mp3] in square brackets, and I was able to hold option and drag another file to substitute the link. The layer name then used to update to the new linked file like this: [anotherfilename.mp3] still within square brackets. Now, howver, when I replace the link file, the name remains as the new wonderful name AE chose for me, like "filename.jpg 4" because the square brackets are no longer there. It is getting very hard to keep track of what is what! 

This is happening to precomps too. As soon as I duplicate a precomp, and click away, the precomp names in the layer panel are updating in sequential numbers... 

Screen Shot 2021-08-04 at 11.40.23 am.png

This autonaming feature has been in AE forever, but only used to apply to shape layers, adjustment layers, nulls and solids... Why is it permeating to linked files and precomps? Is it a bug?

If Adobe introduced this "feature" to "make things easier", it isn't, and I want the option to turn it off.

The only workaround I've seen so far is as soon as i see the layer names being updated, quickly hitting command+Z and hope they layers dont update the next time I create a duplicate. This is a nightmare!

Any help will be appreciated!

On Macbook pro (OS 11.5)  

TOPICS
Error or problem , How to , User interface or workspaces

Views

704

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Aug 23, 2021 Aug 23, 2021
Oh man, I thought I was losing my mind! Thank you! The fix is in the DUIK panel, click the brain icon in the lower right then click on the magic wand to disable live-fix.

Likes

Translate

Translate
Adobe Community Professional ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

AE can show Layer Name or Source Name.

 

Try clicking on "Layer Name" in the Timeline panel to toggle to Source Name.

 

AE Layer Name showing in the Timeline panelAE Layer Name showing in the Timeline panel

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Thank you Warren!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

this however doest solve the autonaming situation. Has this been introduced recently? It didn't use to happen:

any duplicates used to remain with the [square brackets]... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2021 Aug 22, 2021

Copy link to clipboard

Copied

I get what you mean.
I have my own preference for naming layers and files. Thus his new introduced feature annoys me so much.
Sadly there's no way to disable it. Hope they will give an option for user to turn on/ off in the next update.Capture.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Thank you @jacksonchoong 

To me it is very frustrating, but I was starting to think no one else has this problem since I haven't found anything else related to this issue... It surely must be troublesome to people who create templates?? or pretty much anyone who duplicates/splits layers!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

The brackets should appear when the Layer Name matches the Source Name.  If the Layer Name does not match the Source Name, no brackets will show and the incremental numbering will happen when duplicates are made.

 

To restore a changed Layer Name to match the Source Name, change the Layer Name to nothing (that is, start a Layer Name change by pressing Return, delete the text entry, then complete the change by pressing Return again with nothing typed in).  This should restore a matching Layer Name as well as the brackets.  Manually entering the Source Name as the Layer Name should also result in seeing the brackets.

 

As far as whether this behavior is different in prior versions of After Effects or not, I think it was different prior to Expressions being introduced (a pretty long time ago) and I think it changed once to better avoid duplicate names causing errors shortly after that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Hey Warren,

I don't think you understand the problem I'm trying to describe...

Autonaming of SOME types of layes has been around since the beginning of After Effects, yes. These layer types were solids, nulls, shape and adjustment layers... I recognise that and I'm not arguing that point because the nature of those layers is different from precomps or linked media.  This however did NOT happen to precompositions or imported media. With these types of layers you are able to select another source from your project panel and Opt+drag the file to the limeline and change the content of that layer. The name of said layer changes to the new relinked media ONLY IF the name is within square brackets. Since AE is now changing the name of precomps and linked media layers, this behaviour doesnt apply anymore. 

Let me show you another example from a file I created 6 years ago (I'm not new to AE - so I can tell that this has been introduced recently)

Screen Shot 2021-08-24 at 8.34.48 am.png

And this is what happens after a few seconds after I open it and start working on the file:

Screen Shot 2021-08-24 at 8.35.04 am.png

 

So according to you, I am supposed to manually go and change the name of each precomp by pressing enter so the square brackets show again?

This is mental...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

This happens to me too and it drives me CRAZY! It is really disorienting to work on a layer only to have it's name changed when I look away. I really want a way to disable this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Are you running Duik?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Uh oh, don't tell me it's DUIK's fault, because yes I am.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Okay, I will not tell you.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Oh man, I thought I was losing my mind! Thank you!

 

The fix is in the DUIK panel, click the brain icon in the lower right then click on the magic wand to disable live-fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

thank you @Emory Allen 

this certainly fixed it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

LATEST

Ohhh man! You saved my life! I was extremely annoyed by this and couldnt find any solution. And it was more frustrating because my collueges were not having this issue.

Thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

Thank you so much Warren!

you found the culprit!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines