• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Keyframes are going nuts in after effects and premiere

New Here ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

No idea what is going on. I have my keyframes set to linear and it should be the most simple thing in the world to get them to move from one point to the other smoothly. But the programs are freaking out and speeding them up and bobbing up and down and I have no idea what is wrong. I literally have it as simple as a position change in the y axis, so I should just have the object move up and down in one smooth flow, but it bobs all over the place, even starts to go left to right even though I have not touched the x axis. Please help. I am also using CS6

TOPICS
Dynamic link , Error or problem

Views

487

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

There is a difference between temporal interpolation and spatial interpolation. When you get a layer moving then you stop it, then you set another keyframe a couple of frames later and start it moving again the velocity of the incoming motion will continue after the second keyframe then the layer will bounce back into position. When it leaves that position after the third keyframe it may start moving in the opposite direction before it moves forward again on its way to the fourth keyframe. This is called Ping Pong. If you select the layer and have keyframes visible you should be able to see the bezier handles in the timeline that shows you the motion path. You can fix this problem with the Pen tool or by clicking on a keyframe and changing the Spatial Interpolation to Linear. There is also a setting in the Preferences/General tab to change the default behavior. Linear is not the default because it usually doesn't look very good. Once you get the hang of it, and once you learn how to use hold keyframes, this problem goes away.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2022 Dec 01, 2022

Copy link to clipboard

Copied

That was really helpful! For the first time I look up a problem I am having in premiere and see a clear and detailed answer that solves it. Much appreciate it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2023 Mar 27, 2023

Copy link to clipboard

Copied

LATEST

Rick my man! Thank you so much, I had no idea why I was having the Ping pong effect with my keyframes and you are one of the few people who actually explained in great detail! 
I love you man!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines