• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Red Giant's Supercomp says 'Unable to execute script at line 1."

New Here ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Hi, I'm having difficulty using Red Giant's Supercomp plugin with After Effects on my MBP.

 

I'm getting the following message and it won't launch:

 

'Unable to execute script at line 1. After Effects error: Unable to call "applyPreset" because of parameter 1. Path is not valid. Path: "/Volumes/Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore/Red Giant VFX/Supercomp_AE.plugin/Contents/Resources/SupercompEM.ffx*

 

 

I have confirmed that SupercompEM.ffx exists and the path is correct.

I've tried the following to address this issue:

  • Clean installation of Adobe software, including After Effects.
  • Launching After Effects with all plugins and scripts except Supercomp disabled.
  • Checked permissions and access on my Mac.
  • Attempted using older versions of the software.
  • Uncheking "Enable Home Screen"

 

 

Interestingly, I have transferred the settings from this MBP to a Mac mini, and Supercomp launches without any issues on the Mac mini.

The conditions should be the same, so I'm wondering why this problem is occurring.

 

Thank you!

TOPICS
Performance

Views

236

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Oct 11, 2023 Oct 11, 2023

If you create a new project and try to apply that preset from the Animation Menu, does it work? 

 

What version of AE are you using? What version of MacOS are you using on the MBP vs. the Mac Mini?

Votes

Translate

Translate
Adobe Employee ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

If you create a new project and try to apply that preset from the Animation Menu, does it work? 

 

What version of AE are you using? What version of MacOS are you using on the MBP vs. the Mac Mini?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Forgot to mention that.

 

Both MBP and Mac mini are running on AE 23.6 and booting up with Rosetta 2.

And their OS are Ventura 13.5.1.

 

I've never used Animation Presets before, so I saved a random one and applied it, and it worked as intended.

But Supercomp doesn't.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Are you able to update to the version of SuperComp that works natively on M1/M2 machines so you don't have to use Rosetta? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

I didn't know it was M1 native. I thought it was still unsupported, so I was using Rosetta.

When I switched to M1, it did indeed boot on the Mac Mini. It's still the same on the MacBook Pro.

 

By the way, I also updated After Effects to version 2024.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

LATEST

The good news is that Supercomp (and all of Red Giant's tools) have been updated for Apple Silicon - in fact, Real Lens Flares works better on M1/M2 than on most other hardware.

 

The bad news is that it looks like you're still having an issue.

 

I'd recommend filing a support ticket at support.maxon.net so they can look a bit more deeply into your issue. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines