• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Your system has run out of application memory on M2 Max 64gb

Explorer ,
Sep 24, 2023 Sep 24, 2023

Copy link to clipboard

Copied

Running AE on a brand new MacBook Pro M2 Max with 64gb of RAM and I cannot render my comps without the computer crashing with a out of memory warning. 

This happens during renders but it has also happened while working on a timeline. 

Tech support opened AE with a terminal console and I was able to see this message repeated constantly:  <prefetch> <5> RequestPrefetchedFrame frame not in async list!

 

As this message keeps popping and popping in the console, memory usage keeps increasing without getting cleared. It happens while looking at a frame and not touching anything (while AE pre-renders frames, and it gets worse when rendering up to the point where RAM usage gets at 250% and computer crashes. 

My comps are 4K, using Trapcode Particular and Trapcode Form. 

Had two sessions with tech support where they tried every trick in the book to no avail. 


For the moment, my only solution is to render very short parts and stay in front the whole time to clear the memory using Memory Clean 3 every 15 seconds or so. Otherwise AE will crash the computer even for a short render. 

 

My deadline is creeping and I really need a solution. 

 

 

TOPICS
Crash , Performance

Views

715

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Sep 25, 2023 Sep 25, 2023

To stop the pre-rendering of frames, which might help getting to your deadline, go to the Composition Menu -> Preview -> Caches Frames When Idle and turn that off. 

 

The prefetch message isn't causing any memory issues or stability issues, it's just a warning for us for a performance reason. 

 

If RAM is going past your machine limit, I might suggest seeing if the problem continues if the Trapcode effects are disabled. Those effects have had issues leaking memory that AE can't monitor. 

Votes

Translate

Translate
Adobe Employee ,
Sep 25, 2023 Sep 25, 2023

Copy link to clipboard

Copied

To stop the pre-rendering of frames, which might help getting to your deadline, go to the Composition Menu -> Preview -> Caches Frames When Idle and turn that off. 

 

The prefetch message isn't causing any memory issues or stability issues, it's just a warning for us for a performance reason. 

 

If RAM is going past your machine limit, I might suggest seeing if the problem continues if the Trapcode effects are disabled. Those effects have had issues leaking memory that AE can't monitor. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 25, 2023 Sep 25, 2023

Copy link to clipboard

Copied

Turning off Cache Frames When Idle did help a lot. Thank you.

 

As for the memory issue, I highly suspect Trapcode, since this project is made of multiple layers of Particular + Form, with 3D obj emitters, video sprites, lots of camera movements, and I only have that problem with this project. And I cannot pre-render anything because it's a stereoscopic 3D project, so the depths must be computed during render to generate left and righ eye perspectives.

 

It's surprising that the host application cannot limit the damages done by a rogue third-party plug-in. Even more surprising that a plug-in suite that costs more than the host application is unable to manage memory properly. I shall now move my cry for help over to Red Giant Maxon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 23, 2024 May 23, 2024

Copy link to clipboard

Copied

Are you still having the issue? Let us know.

I am moving this thread from Bugs to Discussions for now.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 23, 2024 May 23, 2024

Copy link to clipboard

Copied

LATEST

I installed a tool called Memory Clean 3 that monitors and clears memory as it fills up. That avoided the computer to hang and restart.

I haven't worked on a project as memory-intensive as that one since, so it's hard to tell for me if it was resolved in an update from Apple, Adobe or Maxon, but it isn't an issue for me at the moment.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines