Blinking makes eye disappear completely

New Here ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Not sure what is going on, but when I blink, the entire eye disappears, but the blink artwork does not display. I have 4 other characters set up the same way, and they are fine.

TOPICS
Puppet movement , Rigging

Views

59

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Can you share a screenshot of the rigging hierarchy? Also check the correct blink tags are on the left and right eyes (and not on other layers). Blinks hide all siblings, so the most common mistake is to get their nesting position wrong in the hierarchy, causing them to hide more than expected. If left and right eyes are siblings for example, I have no idea what would happen (both hide all siblings, so both blink layers would become invisible?)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Screen Shot 2022-03-02 at 1.45.55 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

The basic structure seems fine. I notice the profiles (Left/Right/Front). I wonder if they are kicking in somehow. To eliminate the profiles, I would delete the "Left" and "Right" and see if that makes a difference - to eliminate profiles as an issue. (Delete in CH, try it, then click "undo".)

 

Next I would look at the Behaviors for Face and Eye Gaze to expand the Handles and Views sections. Are they binding to the correct layers? E.g. is there a stray blink tag on an unepected layer? The bindings might help spot that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

I just double checked eerything you said...and everything is labeled correctly. I have 4 other characters set up exactly the same, and they are fine. Its not a profile issue. The Behaviors are fine...every handle is correctly labeled. Everything is on the correct layer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

Actually just fixed it. I had to add the Face Behavior to the Left/Right Blink to the puppet hierarchy. Which is weird, because the 4 other puppets work fine with out adding it in. So, the bigger question is why does it work for some, and not for others?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 02, 2022 Mar 02, 2022

Copy link to clipboard

Copied

LATEST

It might be to do with profiles. Some behaviors look for "Views" then find the first layer in the view with the tag (then stop). I am wondering if it something like that. But I get bitten by it every so often and never tracked it down exactly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines