Dynamic link not upadting Character Animator project file in After Effects

Engaged ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Hey there,

I have a lipsync character that is imported into AE. Works fine, until I need to update the audio file. CA sees it and updates fine, but AE won't. Even if I go to replace that imported asset with the same file, nothing. So, I have to save out of CA a new project file and then go in and replace all my imports with new file. Is there a way to update Dynamic Link to a latest version?? Why won't AE see the updated project file from CA?

Views

884

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Engaged , Nov 02, 2018 Nov 02, 2018

OK so I realized that if I want to have AE see the updated CA file I need to CTR-E the source file from the Project window in AE. I can't just go and open the file natively. I also change the name of the of the timeline file as that seems to also play havoc with this issue, for some reason AE caches the original timeline reference and does not update... from what I am experiencing.

Likes

Translate

Translate
LEGEND ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

I don't use dynamic link much, so this is a guess. I am wondering if updating the audio file does not change the project itself, so AE does not notice the change. Do you recompute the lip sync from the new audio file for example? That would make a change within the timeline which AE should notice. Do you change the filename? I am trying to think of ways to make the CH project look different in a way that will trigger the dynamic link to say "project updated". I don't think yo need to start a new project file each time - I think there will be other ways to make AE notice the change.

Also, is there a refresh button in AE somewhere? To flush caches? In CH there is the two arrows at the bottom of the scene window for example. Have you tried clicking that? Maybe it will tell AE to refresh as well.

But if you can repeat it, it does sound worth reporting in the Bugs/Features area (links at top of forum) so the CH team are aware of it. They may improve it in a future release.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

THANK YOU SO MUCH!! That is what the prob was. I assumed it updated the lip sync automatically, so maybe that's a feature request for next version. THANKS AGAIN!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Spoke too soon. It worked once, then I did another tweak to audio file, recomputed and it plays fine in CA, but this time AE won't take the update, even with restarting AE and purging all. Grrrrrrrrrrrrrrrrrrrrr

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Bizarre. Sometimes it pays to wait a moment before entering AE, but I really don’t have an explanation. I think there are caches in AE you can flush, but I don’t know for sure. If you work it out please post your final solution here for others to learn from (me included!!!).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 02, 2018 Nov 02, 2018

Copy link to clipboard

Copied

OK so I realized that if I want to have AE see the updated CA file I need to CTR-E the source file from the Project window in AE. I can't just go and open the file natively. I also change the name of the of the timeline file as that seems to also play havoc with this issue, for some reason AE caches the original timeline reference and does not update... from what I am experiencing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 02, 2018 Nov 02, 2018

Copy link to clipboard

Copied

The way I normally set up a dynamic link is I open CH and AE side by side, then drag a scene icon from CH into the AE project area. That establishes a dynamic link. Then CH changes just appear in AE automatically.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 26, 2019 Jan 26, 2019

Copy link to clipboard

Copied

LATEST

thank you !

i had same problem time to time but with CTRL-E it does perfectly work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines