Adobe CC apps and MacOS Catalina (What's broken? What's not?)

Community Beginner ,
Jun 07, 2019 Jun 07, 2019

Copy link to clipboard

Copied

Has anyone installed the Beta 1 of MacOS 10.15 (Catalina) and tried to use Creative Cloud applications?

If so, which Creative Cloud applications/features work and which ones do not?

Please note: this is not a question about Adobe Creative Cloud support of MacOS 10.15 Catalina (which is distinctly different from whether or not applications or features work).

This is also not a criticism of the Adobe teams; even with early access to new versions of MacOS (which the Adobe dev teams may not have), compatibility updates take a long time.

TOPICS
Creative Cloud

Views

80.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 04, 2019 Nov 04, 2019
Thank you, everyone, for your interest in 64-bit support for Adobe applications that are included with a Creative Cloud membership.  Since this discussion was last active additional information has become available. Please see https://helpx.adobe.com/x-productkb/global/fix-macos-64-bit-compatibility-errors.html for important information both before and after upgrading to macOS 10.15 and later.

Likes

Translate

Translate
Community Beginner ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Unfortunately, I can't get any Adobe Apps to work on my MacBook Pro 15 (late 2013) 10.15 Beta

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

That's very unusual. You'll need to provide a lot more specific details. By "and Adobe Apps" can you least each specific app you have tried? And by can't get any to "work", you mean, you click on say Photoshop and literarilly nothing happens? Or it bounces endlessly in the dock, or it opens but but then crashes without warning immedaitely, or it opens but then an error appears (what is the exact error) or the app(s) open but some functionality does not work as expected, if so what specific functionality is not working? And you will most likely want to open "Console" app and see what errors show up in the logs there exactly as you are opening the desired Adobe app.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

I tried to open Photoshop first. The title box opens and the rainbow spins for a LONG time. I had to 'force quit'. I did the same for Illustrator and Lightroom. Nothing but spinning wheels.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Console App is for a PC. I use a Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

I'm aware you use a Mac (since this conversation is about Catalina) as do I. I have no idea what apps are on PC, but as noted, you should use the "Console.app" on your Mac which stores all the logs for your Mac. Simply open spotlight and type, Console.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Console in spotlight is empty

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Sounds like your Mac maybe having a lot of issues. But like with any app, you can simply find in the application folder. :-).  In Finder sidebar select Applications, open the Utilities folder and select the Console app.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Did not find what you asked. Nothing is working now. MAJOR MALFUNCTION WITH CATALINA !!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Have you tried a clean install of Catalina? Formatting your drive and starting again?

Adobe have not released any updates to their apps yet which support Catalina, so this is to be expected. Catalina is in beta at the moment and as such it's full of bugs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

If your install is currently missing core system applications such as Console app, then you have much larger problems that you will want to focus on before considering apps such as Adobe. If you really are missing core apps such as Console and you didn't delete them, them, which I've never heard of ever happening, then you should definitely do a clean install. To note this "major malfunction appears" to currently be limited to you, rather than specific to Catalina as have seen no reference in any of the core apps such as Console disappearing after installation in the Apple Developer forums. What apps do show up in your Utilities folder referenced above?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

I have installed Catalina on a test laptop - it had CS6 adobe apps - the uninstaller of which would not work as would none of the apps themselves - the installed for Adobe Creative Cloud apps seems to work but they all stall at various points - with the Desktop installer at 43% - I guess its harder to understand when something partially works... I assume that this will get sorted out in the next upgrades on both sides of that fence. Lets hope that the Apple Adobe CC environment works a little more in sympathy than is the case now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

oceanc58702764  wrote

I have installed Catalina on a test laptop - it had CS6 adobe apps

Why would anyone attempt to run CS6 on Catalina?   CS6 installers do not work on Sierra much less Mojave. 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 03, 2019 Jul 03, 2019

Copy link to clipboard

Copied

Because they were there, I was simply objectively stating what was my direct experience to corroborate others experiences with mine - I dislike the "Why would you..." attitude of your remark - how is that at all helpful.

Im more interested in the fact that the installers for Adobe CC run but then stall at some midpoint - consistantly the same midpoint at each run -

I take it from other comments that if the CC apps were incumbent in the mac when the beta was loaded then they run ok mostly - however I am more interested in finding out if this stalling behaviour is endemic specifically to the beta version of Catalina or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 03, 2019 Jul 03, 2019

Copy link to clipboard

Copied

oceanc74368700  wrote

I dislike the "Why would you..." attitude of your remark - how is that at all helpful.

Sorry you don't like my remark.  But by now everyone knows (or should know) that  Catalina doesn't support 32-bit apps.  Some legacy Creative Suite programs install as  64-bit but many others don't particularly the helper apps & plugins.  And given that Adobe will never update Creative Suite to be compatible with Catalina,  I suppose my remark should have been "so what were you expecting?"

32-Bit Apps 'Not Optimized for Your Mac' to Stop Working on macOS Catalina - MacRumors

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2019 Jun 29, 2019

Copy link to clipboard

Copied

The apps seem to be running just fine. But neither nor Lightroom seem to have access to external drives. I can start lightroom with a catalog located on an external drive but there is no access to the original photos located on an external drive. Same with Photoshop.

It's a very early Beta so I don't find it scary.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 29, 2019 Jun 29, 2019

Copy link to clipboard

Copied

I called Apple and returned to Mohave. Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 04, 2019 Jul 04, 2019

Copy link to clipboard

Copied

I have run into the fact that Bridge opens and spins.  It will not sync and open correctly.  I have only been able to force quit it, but totally not available to use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2019 Jul 05, 2019

Copy link to clipboard

Copied

Disable all plug-ins. If that works you may enable case by case the plug-ins until you found the culprit.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 06, 2019 Jul 06, 2019

Copy link to clipboard

Copied

2017 macbook pro, macOS 10.15 beta 3 (19A501i), lightroom cc and photoshop.

starting lightroom classic gives:

Lightroom can not write to the following directories:

until the problem is resolved syncing from lightroom

may not function correctly.

/System/Volumes/Data

If you hit ok to continue It kinda works.  importing, exporting, editing, all seem to work.  Opening a file in photoshop does work, but it does not return the edited file to the lightroom library, one must synchronize the folder you were working in to locate the file and put it back in to the lightroom cc catalog.

Curiously /System/Volumes/Data is part of the 'new' 10,15 file structure, I wonder why Lightroom CC is even looking there. There is a file named .adobeTemp at that location, but it is 755

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2019 Jul 07, 2019

Copy link to clipboard

Copied

The issue you're reporting stems from the simple fact that any "older" application that stored or synced any information, links, data, etc. within or co-mingled with the MacOS System files cannot any longer access (or write) to that volume. MacOS Catalina runs in a dedicated, read-only system volume; user data and files in another – transparently linked by a new logical link called a "firmlink". Check out this illustration and link: https://www.macobserver.com/tips/quick-tip/reference-all-about-macos-catalina-system-files/

The Catalina System volume is secured as "read-only" and user files like applications cannot write to that volume.

apfs_concepts.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2019 Jul 08, 2019

Copy link to clipboard

Copied

TNX

So Adobe is not following the Apple HUD guidelines and they are writing files outside of the User space?  Say it ain't so 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2019 Jul 17, 2019

Copy link to clipboard

Copied

I am having issues saving files within Photoshop. Using most up-to-date CC and Catalina versions


These issues are not constant, but frequent and troubling enough to give a complete headache/breakdown;

1. It seems to only save in the folder that is first selected when the 'save to' dialog window opens. And though you can select alternate folders, its will always revert to saving to the original folder without notice.

2. When choosing to save a different format it won't automatically change the file extension name. e.g. after choosing to save as JPEG from the format dropdown, the file name will remain 'example.PSD'

3. Not saving at all. This one is a *REAL* headache. Though the system appears to save, and even though the photoshop artwork tab will even change to the new saved file name, the file can not be found on my system.

I have only really been experiencing major issues with Photoshop. Though my system (MacBook Pro 2015) has become increasingly sluggish since the update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2019 Jul 17, 2019

Copy link to clipboard

Copied

I upgraded to Beta 4 (10.15 Beta (19A512f))  this morning, and lightroom and photoshop seem to be working better.  Just my 2 cents.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 17, 2019 Jul 17, 2019

Copy link to clipboard

Copied

Can you confirm if the permissions issue in Lightroom is fixed in beta 4? And if you are referring to Lightroom or Lightroom Classic or both? I assume the permissions issue (other than using the temporary hack noted above won't be fixed until Adobe pushes an update rather than it being fixed via an Apple update. Would be great to hear if beta 4 does however?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2019 Jul 17, 2019

Copy link to clipboard

Copied

I do not believe that lightroom classic has changed in the past week or so.  That leaves the only change on my laptop was the Beta 4 version upgrade I performed this morning.

Lightroom no longer gives me the error about not being able to access /System/Volumes/Data.

The macOS upgrade removed the tempAdobe directory that was located in /System/Volumes/Data

Editing from lightroom to photoshop and back to lightroom now works again without problem.

BUT, I am only an hour into this macOS upgrade, I may run into other oddities.....

Ciao

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines