• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
10

EbookExport.InDesignPlugin error when opening a file

Community Beginner ,
Feb 05, 2024 Feb 05, 2024

Copy link to clipboard

Copied

Hello,

 

When opening a file I get this error asking me to upgrade "EbookExport.InDesignPlugin" to it's latest version version. I can't find whatever this is the plugins pannel, nor do I remember installing it in the first place. This happened when using different system in an office. Was fine on the home system. Both systems are with up-to-date versions of InDesign. Both Mac sylicon.

 

Fairly urgent matter so any input would be greatly apreciated.

 

Thank you, please help!

 

Screenshot 2024-02-06 at 9.26.24 am.png

TOPICS
Bug , EPUB

Views

1.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Feb 20, 2024 Feb 20, 2024

We have been able to reproduce the issue in house and currently investigating the issue. 

 

Regards

Sanyam Talwar

Votes

Translate

Translate
Community Expert ,
Feb 05, 2024 Feb 05, 2024

Copy link to clipboard

Copied

You seem to already have a finger on the answer — it would seem that this file was created with/depends on this plugin, and you're trying to open it on a system that doesn't have it. One solution would be to locate the maker of the plugin and get an updated version; another would be to load the file anyway and remove all calls to the plugin's feature. (To be fair, I have no idea how to do the latter, but I know there are ways around such hurdles.)

 

Unfortunately, 'EbookExport' is the next thing to a generic name, and a search comes up with several, primarily for DokuWiki. The only thing I can find is the long-outdated Kindle export plugin for ID, which was abandoned in beta stage a decade ago. That...might be it. I don't know if it can even be made to install on current software, but I think Adobe still has it for download.

 

Was there a third solution you were hoping for?


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2024 Feb 05, 2024

Copy link to clipboard

Copied

Thank you for you reply! I suspect you are on the money, perahps an outdated plugin that has been attached to my InDesign for some time and is now causing a problem. Was doing an e-book years ago.

 

In the short term, a colleague working externaly was able to save it as a .IDML which was a good work around.

 

Will try to locate and delete said plug-in when I'm back on that system.

 

Thanks again!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 06, 2024 Feb 06, 2024

Copy link to clipboard

Copied

So I checked to see if there were any plugins installed, and no. There doesn't seem to be.

 

Anything I might be missing?

 

Screenshot 2024-02-07 at 10.23.20 am.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 06, 2024 Feb 06, 2024

Copy link to clipboard

Copied

I think the problem is the file was created on a system that had the plugin, and now will not load (properly) without finding the support it needs. I don't know if there's any good solution but trying to find the plugin — problematic, with that generic name — or, if there is a system out there on which it opens, perhaps export to PDF as a starting point to rebuilding it.

 

There is a newer post with what seems to be the same problem; not sure if you're representing the same org/document here.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 06, 2024 Feb 06, 2024

Copy link to clipboard

Copied

Thanks, I am back on the system at home on which the files were created, and can't see evidence of any plugin, which is weird. Files open fine. Another point of difference is the system that had issues opening it, is on a governement network which can throw up some pretty random problems at times. For now, saving as an .IDML to work between both seems to be a temporary fix. Perhaps the next InDesign update will resolve.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

Hi,

Sorry to hear about the trouble. Can you please share a few more details like:

-The version of InDesign in which the file was created.

-The version of InDesign in which you're trying to open the file.
-Are you getting the error on multiple files or specific file? If it's happening with a specific file, will it be possible for you to share with me through DM?


Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

Hi Rishabh,

 

Thanks for getting back to me.

– Both machines are on the latest version of InDesign, 19.00.

– This is happening on multiple files, created on my 'off-site' machine. Can't open on my 'on-site' machine

– These files are being shared via OneDrive for additional context

– I will DM you a copy

 

Thanks!

 

Nick

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

Hello Rishabh, is adobe working on this issue? 

Seems that 19.0 & 19.1 versions can't open files saved with 19.2 version and show the missing plugin error.

I thought that files created with 19.x versions were always compatible with all subversions within same major releasenumber (19 in this case). This problem is especially horror when using indesign server, as here release come later then desktop versions and this inherits new issues for planning updates.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

It appears there's indeed a bug in compatibility between these versions, another user reported a similar situation here (not that this info helps solving the issue):

https://community.adobe.com/t5/indesign-discussions/is-there-a-way-to-force-19-2-update-to-show/m-p/...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

@Rishabh_Tiwari 

I was able to fairly easily to reproduce this issue. I've used InDesign 19.1 to test this, but will probably be same with version 19.0.1

 

Not sure if there are any other ways to reproduce this issue.

 

  • Use either InDesign 19.0.1 or 19.1 and create a simple document with one text frame and one image frame. Not sure if both are needed but that's how i've created my test document.
  • Save the document as an IDML file.
  • Check used plugins and normally EBookExport shouldn't be listed at all
  • Upgrade InDesign to version 19.2
  • Open the saved IDML file created in 19.0.1 or 19.1
  • Save the opened IDML file as an INDD file
  • Check used plugins (Opt-Cmd About InDesign on Mac) and sure enough EBookExport is used in the saved document, resulting in the issue that this document will no longer be able to be opened in InDesign 19.1 or 19.0.1

 

The issue was also reported in a thread we created here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

I am having this same issue with multiple users across our organization. All the computers (both Mac and PC) that created the files do not have any plugins installed. Random files created by these machines throw up the EPub plugin error when opened by other users. All users are on v19.1. This issue is slowly propogating to more and more users this week. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

We are running into the exact same issue with multiple users across our company as well. We get the same ePub plugin error when opened by another user. Everyone on v19.1. This is becoming a serious issue for several projects.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

An Update – it appears this issue in our organization was caused when some people installed Indesign CC 2204 after January 31st (v19.2). Any file they open and save using that version will get this error when opened by anyone else. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

v19.1, not v19.2...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

I stand corrected again by my IT depratment, it is indeed v19.2 – which was rolled out to our organization although not released in CC yet.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

will the problem go away if you revert back to 19.1?

 

leor_0-1707414511103.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

Yes, so far it seems to go away if we revert to 19.1 – although we need to resave any corrupted files as IDML files from within v19.2 so we can then have access to them in 19.1 –– but wanted to make sure you're aware of this bug for 19.2 so it doesn't effect anyone else. Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

We are having the issue with all users on 19.1
19.2 has not been rolled out to our org. yet. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

Are you sure? Could it be that a few users have the unnoticed update and that condenses the problem to one major cause?


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

Yes, I've asked all the affected users to report their version # to me. That was one of the first things I had them check.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

Uh-oh. This is not good news.

 

Is it possible your IT department rolled out something... advance? Unauthorized for release where you are? Thus having other incompatibilies? (I don't have 19.2 yet, here, either, so...)


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

My organization is also having this problem. After reading delectrolux’s comments in this discussion, we found that one user had automatic updates turned on and had been updated to version 19.2 (so strange, since that isn’t available in Creative Cloud). After that user made updates to our files, the rest of our production and design teams could no longer open the documents and received the same “Cannot Open File” error message listing EBookExport.InDesignPlugin.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2024 Feb 08, 2024

Copy link to clipboard

Copied

For whatever it's worth, I am on version 19.0, the most up--to-date version according to my Adobe CC.

 

I'm not sure if they stagger these releases, but this is the most current available on our Govmt / education plan in Australia. 

 

Screenshot 2024-02-09 at 9.06.20 am.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

I have been in contact with an Adobe rep regarding this ongoing issue with that aim of sending them a sample file. Thing is, they don't allow attachments in the online messaging tool and my workplace blocks Dropbox etc. for security reasons. I have let them know this and hopefully will get them a sample file with the issue this week or respond with a solution. Lot's of people seem to be affected.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines