• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

How do I get text to wrap around both an image and its caption?

Explorer ,
Jul 19, 2019 Jul 19, 2019

Copy link to clipboard

Copied

Greetings, Wise Ones ---

I can't figure out how to add a caption to an image without messing up the text wrap.

Here's a screenshot of what I get when I insert an image. So far, so good...

Here's what happens when I add a caption to the image. (Note the extra spacing that got added). Image and caption are grouped. I've also tried locking them, but that doesn't make any difference. Any ideas on how I can fix this?

Also, even when I group an image and caption, they sometimes upgroup on their own. Very annoying!

All advice much appreciated!

Cheers,

Marie

Views

2.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jul 20, 2019 Jul 20, 2019

First, turn OFF Text wrap for the individual items, then group and then turn on Text wrap for the group.

And a tip: your text is not aligned to the baseline grid, fix that and make sure the bottom of your image and/or group is also aligned to the basline grid, this will prevent big gaps below.

Votes

Translate

Translate
Community Expert ,
Jul 19, 2019 Jul 19, 2019

Copy link to clipboard

Copied

Hi Mariel

Group them and put text wrap on the group.

~ Jane

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 19, 2019 Jul 19, 2019

Copy link to clipboard

Copied

Thanks, Jane! I’ve tried that, but it doesn’t always work. I can’t figure out why. Gremlins, maybe. Or maybe I’ve been doing the steps in the wrong order.

Cheers,

Marie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 19, 2019 Jul 19, 2019

Copy link to clipboard

Copied

Make sure you have the full group selected.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 20, 2019 Jul 20, 2019

Copy link to clipboard

Copied

Thanks, Bob! I think that might be part of my problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 19, 2019 Jul 19, 2019

Copy link to clipboard

Copied

Hi Mariel,

Check your Layers panel and confirm your Group is selected. You will see a colored square by the selected object.

_Untitled.png

Image courtesy of davescm​ in Something for the weekend - Part 80 - Underneath the arches.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 20, 2019 Jul 20, 2019

Copy link to clipboard

Copied

First, turn OFF Text wrap for the individual items, then group and then turn on Text wrap for the group.

And a tip: your text is not aligned to the baseline grid, fix that and make sure the bottom of your image and/or group is also aligned to the basline grid, this will prevent big gaps below.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 20, 2019 Jul 20, 2019

Copy link to clipboard

Copied

Thanks, Frans! I think I might have been wrapping before grouping.


Marie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 22, 2019 Jul 22, 2019

Copy link to clipboard

Copied

Hi mariel80612222 ,

I'd prefer a set up where the text wrap is applied to an extra rectangle that is not part of the group.

Why?

It gives me the opportunity to change the values of the wrap very fast by just changing the dimensions of the rectangle.

From my German InDesign:

TextWrap-ImageFrame-plus-CaptionFrame.PNG

Regards,
Uwe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 23, 2019 Jul 23, 2019

Copy link to clipboard

Copied

Thanks, Uwe. That’s a great tip!

Marie

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

LATEST

Hey! Another way to handle this is to "Ignore text wrap" on your little caption text. So make the caption text in a text frame, select it and open Object > Text Frame Options and check the little box that says "Ignore text wrap."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines