• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

Hyphen problems with Trade Gothic Next from Adobe fonts

New Here ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

I've started using Trade Gothic Next from Adobe fonts and when I type a hyphen, it gives me an en dash. It also generates en dashes for all end-of-line hyphenated words. I can go into glyphs to change them from en dashes to hyphens but that would mean going through all my body copy in Trade Gothic Next for all uses of the en dash. That's crazy! I don't have this problem with other Adobe fonts I'm using. What's going on?

TOPICS
Bug , Print , Type

Views

268

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

I can't replicate the issue with InDesign 2023 (18.1) on a Mac running Ventura (13.2.1)Capture d’écran 2023-02-24 à 18.15.29.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

I just loaded Trade Gothic Next on my MacBook Pro running Ventura 13.2.1

 

I'm not having that problem. The hyphen, en dash and em dash look perfectly fine:

 

Screenshot 2023-02-24 at 9.15.10 AM.png

 

Test whether this happens in one file or all your files.

 

If one file, there could be corruption: Try saving the file as an IDML file (File > Save As > InDesign CS4 or Later [IDML]. Then reopen the IDML file.

 

If more than one file try restoring your InDesign preferences and caches:

 

https://www.rockymountaintraining.com/adobe-indesign-rebuilding-preferences-cache/

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2023 Mar 06, 2023

Copy link to clipboard

Copied

LATEST

Thanks Steve,

You were right. There must have been some sort of corruption. I created new file and the problem went away. I now have proper hyphens, en-dashes, and em-dashes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines