• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

It's 2024 and text still not flowing within the textbox

New Here ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

Hello,

 

I have been trying to solve an issue with the textbox in InDesign for the past 2 hours. Despite watching various guidelines and videos, I'm still experiencing a problem where the whole paragraph disappears whenever the text exceeds the textbox's border. I'm also unable to adjust the size of the textbox while keeping all the text as intended. For example, when I make the textbox narrower, the entire paragraph disappears instead of pushing the text downwards.

 

As a user, I find this aspect of InDesign challenging. Could you please provide an effective solution to resolve this issue? It would be helpful if the textbox flow could be set to behave similarly to PowerPoint by default in future instances.

 

Thank you in advance.

 

Operations:
Desktop Windows (latest version)
InDesign (latest version) 

TOPICS
Feature request , How to , Type

Views

441

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

At a guess the problem is not to do with the text frame but that the Keep Options selected in the paragraph settings are "Keep Lines Together / All Lines in Paragraph". (It's under the fly-out menu at the top right of the Paragraph panel.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Thank you for your concise reply, unfortunately the text still disappears when I 'narrow down' the textframe with settings as the screenshot shows below.

Screenshot 2024.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2024 Jul 08, 2024

Copy link to clipboard

Copied

LATEST

Edit: I can't believe I just tried to respond to this one without scrolling down; there's no need for me to repost the advice that has already been posted.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

Can you post a screenshot? 
I'm not sure what you mean. Are you talking about Overset Text? Or it might be a (non intended) page break. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

Latest version is meaningless. If you're going to supply that information we need full version and build numbers. We also need screenshots and what exactly you're expecting. Powerpoint shrinks the text, InDesign will not and should not do that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

@QSHK 

Could it be that the described behaviour of InDesign is due to unsuitable settings on your part? Or a lack of knowledge about how to use the programme? 

 

Please upload a screenshot showing the hidden characters, the text editor open and the character and paragraph styles panel open, and/or a sample file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

As noted, the problem is almost certainly with your Keep Options for that paragraph style:

JamesGiffordNitroPress_0-1720197823735.png

 

What this has to to with it being 2024, or implying that this is some kind of longstanding bug, is not helpful.


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Thank you for showing the panel where I could adjust the settings, unfortunately the text still disappears when I 'narrow down' the textframe with settings as the screenshot shows below.

Screenshot 2024.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Create a simple document with one or more text boxes exhibiting this behavior, and upload it here as part of a post.

 

[ETA: I am pretty sure the above screenshot was not part of the post when I replied. The problem is instantly obvious from it, as it nearly always is when a poster insists all those settings are correct and overlooks the oddly-presented settings at fault here.]


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

The new file does not have this issue. I guess it's the old file's settings then?

All text disappears if I continued to type in the below shown text frame.

Screenshot 2024 (2).png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Your file may have been corrupted. It happens. In the future, try to replicate odd problems like this in a new file, or at least a second one. If only one file has the behavior, it's probably corrupted and needs to be fixed. If it happens in all files, it's a feature/technique problem instead.


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Highly likely, as the original file was passed on. I will now go to find out how to fix a corrupted file... Thanks for your help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Any time a file is acting up, export it to IDML, then open that file and save it as INDD again, under a new name. That fixes a vast number of glitches.


┋┊ InDesign to Kindle (& EPUB): A Professional Guide, v3.0 ┊ (Amazon) ┊┋

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

Great tip. Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

The settings in your screengrab above are exactly what will cause the text to disappear. They are telling InDesign to never allow less than a complete paragraph in a text frame. Untick "Keep Lines Together" and the text will fill the frame.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2024 Jul 07, 2024

Copy link to clipboard

Copied

I think the behaviour I'm looking for is "to resize text frame without scaling the text" or something similar

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2024 Jul 08, 2024

Copy link to clipboard

Copied

I'm sorry, but what your screen grab shows is EXACTLY the problem. You have "Keep Line Together" with "All Lines in Paragraph" checked. This is preventing your paragraph from splitting AT ALL, so will force it to the next text frame, and so on, when it doesn't fit. Either Uncheck "Keep Lines Together", or if you wnat the usual widow.orphan control, select "Keep Lines Together" >"At Start/End of Paragarph" The default 2 lines is a normal default.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2024 Jul 08, 2024

Copy link to clipboard

Copied

This paragraph is disappearing because you have told Paragraph Style 2 to keep all lines in one paragraph together and if they all can't all fit in your frame, they all go to the next frame. (Or are overset, if you don't have a next frame.).

 

As per Brad @ Roaring Mouse: either disable keep lines together or keep it on and enable at start/end of paragraph. Pick the one you prefer and then you can come back to mark his answer as correct.

 

~Barb

 

2024-07-08_13-32-09.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2024 Jul 08, 2024

Copy link to clipboard

Copied

If you are after the frame to actually become larger as more text enters, that's a textbox property. See this page for more details: https://helpx.adobe.com/indesign/using/text-frame-fitting.html

 

There is a third party plug-in called autofit from typefi that might be more what you're after to enhance InDesign's own auto-text features: https://www.typefi.com/autofit/

If the answer wasn't in my post, perhaps it might be on my blog at colecandoo!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines