• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
14

The InDesign Application Frame gets stuck outside the screen area/behind menu bar

Explorer ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

Every so often, since working on my current iMac (2017), my Application Frame in InDesign gets stuck on my second 32" Benq monitor. The top bar area sits just behind the menu bar. Once it's there, it's there. The accessibility to reposition the frame is now not possible. Even switching the Application Bar, the background frame is still stuck and cannot be moved.

Screenshot 2019-02-19 at 09.50.38.png

Surely, there must be a limit from stopping the Application Frame from running off behind the menu and off the top of the screen, or at least allow an interactive method in a dropdown menu to reset the Application Frame back within the frame of the monitor.

For the moment, the only way I have found to resolve this would be to 'Delete InDesign Preference file' (Shift+Control+Option+Command) on start-up and reapply my personal settings and workspaces.

After resetting, this crucial part of the frame is now visible.

Screenshot 2019-02-19 at 10.10.31.png

I'm running MacOS Mojave Version 10.14.3, on an iMac 27-inch 4.2Ghz Intel Core i7 running a second 32" Benq screen.
Currently affecting InDesign version 14.0.1 but it also occurred with previous versions too.

Views

46.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 11, 2019 Nov 11, 2019

ANSWER FOUND: It appears it only affects users with two screens. If your displays are sitting side by side, ensure the second screen in the 'Display Arrangement' in System Preferences >> Displays, does not sit higher than the main screen - even though the second screen may sit higher on the desk. Keeping the second screen aligned or lower will avoid 'losing' part of a panel off screen.

Votes

Translate

Translate
Community Expert ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

Have you tried resetting your current workspace? Window > Workspace > Reset [current workspace] or use the Workspace menu at the upper right of your screen.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 19, 2019 Feb 19, 2019

Copy link to clipboard

Copied

Yes. It's not the Workspace. It only affects the Application Frame. Over the many months, as and when it happens, and if I have time, I try to investigate all options but nothing works apart from deleting the preference file. It's more annoying than anything else. This is more to highlight there is a glitch with the Application Frame if it doesn't sit quite right on the second monitor.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Thank you! This has been driving me nuts.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2024 Jan 05, 2024

Copy link to clipboard

Copied

This worked for me! TY 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2019 Nov 11, 2019

Copy link to clipboard

Copied

ANSWER FOUND: It appears it only affects users with two screens. If your displays are sitting side by side, ensure the second screen in the 'Display Arrangement' in System Preferences >> Displays, does not sit higher than the main screen - even though the second screen may sit higher on the desk. Keeping the second screen aligned or lower will avoid 'losing' part of a panel off screen.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

I don't have 2 screens and it is doing it to me. If I have InDesign in full screen mode, it's fine, but I'm needing to have 2 windows open, one in InDesign and one picture window open so I can copy type from a picture into InDesign. I can make the window smaller from the side, but not the top, and the bottom is way off the bottom of the screen where I can' grab it to resize the window. I can't even see the application frame under the window panel to uncheck it. Has that moved with the latest version? I've restarted and reset the workspace which only lost my panels. Very frustrating!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 19, 2021 Dec 19, 2021

Copy link to clipboard

Copied


@mag-man wrote:

…ensure the second screen in the 'Display Arrangement' in System Preferences >> Displays, does not sit higher than the main screen - even though the second screen may sit higher on the desk.


 

This worked for me. Thanks, @mag-man 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

I have two screens but my "arrangment" in prefs is top and bottom, not side by side. 

It seems there is a "GAP" between them and sometimes the IND window gets sucked up into it, so i cant see the top of the window. i have to go into arrangment again and change it, to fix. Seems silly. Isnt there a simple key command to move window to center or fill monitor?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

I only have one screen, and have only ever had one screen, and the application window freezes in postion, and stiill does so after an Adobe up-date. Ive tried the solutions above but none work. If I persist trying to move the window everntiually it does after the 6th or 7th mouse click.  My answer has been to keep the window small, so I can refer to other things on the screen, am fortunate I have alarge screen. I wish Adobe would sort it out it is clearly a clitch.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

Issue is also applicable on After Effects CC 2022. Moving secondary screen a bit down WORKS! Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 14, 2024 May 14, 2024

Copy link to clipboard

Copied

Please vote on the bug fix request for this silly bug that's existed for far too long. 

 

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/48433358-two-monitors-u...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2022 Jun 20, 2022

Copy link to clipboard

Copied

I know this post is over 2 years old but it was the answer for me when I was having the same problem today. Such a weird glitch with such an easy fix when you know how. Thank you very much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

This worked!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

What a crazy solution - but it worked!!! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2023 Aug 10, 2023

Copy link to clipboard

Copied

Same issue with three monitors (includes my laptop scree).  Followed the instructions on this thread and it worked.  I rearranged my top two full monitors side by side to my laptop monitor in the Display/Arrange settings and was able to see the top of the interface.  I've been trying to fix this for a couple of years and couldn't find any on YouTube.  Thanks everyone.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 26, 2023 Jun 26, 2023

Copy link to clipboard

Copied

This answer is a temporary fix, and not a solution. InDesign (Adobe) needs to accommodate the users with two screens. Not the other way around. I have a Macbook and 2 monitors. It is not possible to arrange my screens so InDesign works. Photoshop avoids the issue by making it a bit more difficult to move the window to another monitor. Photoshop makes you aware you are moving your window. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2023 Jun 30, 2023

Copy link to clipboard

Copied

Hi @susanmoulton , You can script the bounds of the active layout window relative to the main monitor. I use this to set the position of the active layout window, or the application frame if it is active, to position the window at 90% of the screen’s available width and height:

 

//the horizonatal and vertical percentage of the screen to fill, change as needed
var hScale = .9
var vScale = .9
var x = 50;
var y = 0;
var sw = $.screens[0].right;
var sh = $.screens[0].bottom;
var w = Math.round ((sw*hScale)-x);
var h = Math.round ((sh*vScale)-y);
app.activeWindow.bounds = [sh-(y+h), x, sh-y, x+w]

 

 

Before:

Screen Shot.png

 

After

 

Screen Shot 1.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 11, 2023 Jul 11, 2023

Copy link to clipboard

Copied

Again, This is not a fix. This is a workaround and I am not going to run a script. It is much easier to hide my menu, move the window down, and show the menu again. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 11, 2023 Jul 11, 2023

Copy link to clipboard

Copied

Hi @susanmoulton , If by fix you mean a bug fix then you are right my script example does not fix any bugs. For bug fixes you need to post here:

https://indesign.uservoice.com/

 

The script simply shows how the active layout window can be positioned to any bounds relative to the main monitor. Scripting is like any other InDesign feature—you can choose to use it or not—but he window position could be set via key command attached to a script, or a single click, rather than 3 mouse moves.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

2024 version and it still has this bug. This is so annoying. Just make it work like Photoshop. Or is this just some quirky thing specific to InDesign. It would be nice to know the status of this bug fix. Does anyone know where I can find bug being worked on? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 14, 2024 May 14, 2024

Copy link to clipboard

Copied

I submitted a bugfix because it's insane that this is still a problem. Please vote on it. 

 

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/48433358-two-monitors-u...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2023 Jun 30, 2023

Copy link to clipboard

Copied

Ran into this issue just today, and found that my screens were a fraction off. That fixed the problem. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2023 Aug 22, 2023

Copy link to clipboard

Copied

It's insane we have to do that to make it usable. But big thanks to mag-man for figuring this out, it drove me nuts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2023 Aug 31, 2023

Copy link to clipboard

Copied

Hey, it has been almost 4 years since your comment, BTW I want to thank you because I've been searching for the solution abbout 3 months and it was turning me really mad...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines