• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
1

Luminar Neo not showing up as External Editor after installation

Community Beginner ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Latest version of LR Classic (12.2?). Installed Luminar Neo and AI (both) and tried to get them setup as External Editors. The .plugin and .lrplugin files get created but somehow LR is not "seeing" them so they don't show up in the menus. Previous plugins (Luminar 4 and Flex) are showing in the menus. MacOS Ventura latest version (13.2?). Granted LR and Luminar "Full disk access".

TOPICS
macOS

Views

934

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 02, 2023 Mar 02, 2023

Copy link to clipboard

Copied

Thanks johan, those are the menu choices that are not showing up in Adobe LR classic. The installation completes without an error, but the menu commands are not there. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Further down the pages is a section about what to do if you do not see the menus. Did you check that?

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Thanks for your replies, I appreciate it. 

I think you mean:

Note: If Luminar Neo is missing from the Photo > Edit in the menu, open Lightroom preferences. Select the Presets tab and UNCHECK the option for Store presets with this catalog.

 

I don't have that checked. I wonder if i should try to check it and uncheck it, worried about what it might do!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Also, in LR in that same dialog, when I click "Show Lightroom Develop Settings", nothing pops up. Seems to be a clue but I don't know what it means

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

My Develop Presets are stored:

Library >> Application Support >> Adobe >> CameraRaw >> Settings
I don't remember why they are in CameraRaw settings, but maybe Luminar is confused by that?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

This has nothing to do with develop settings. These are external editor settings. Have you tried setting them up as external editors manually? Don't try to setup the plugin as editor, select the application.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

You know I have been staring at it so long, I somehow didn't think I could set it up manually, but that did in fact work. Thanks for pointing me in the right direction. Original problem not solved, but this works!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Actually it did not quite work. When it works propery, it should open Neo and let you edit and then have an "Apply" button to save the changes. There is no Apply button. 

I have given up on this issue. I am just manually exporting them and manually re-importing back into Lightroom.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

LATEST

If you setup the application as external editor, then you should use 'Save' (not 'Save as') from the application File menu.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Not a holder of Neo, but I do have Luminar 4.

Installation of plug-ins for the Skylum typically not a direct result if install. Did you launch Neo, then up in the menu, click on the install plug-ins button?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 03, 2023 Mar 03, 2023

Copy link to clipboard

Copied

Yes, I tried that a few times. I have given up. It is some interaction of Luminar, Lightroom Classic, and MacOS Ventura.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines