• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Print module does not work correctly macOS Ventura

Community Beginner ,
Nov 23, 2022 Nov 23, 2022

Copy link to clipboard

Copied

Hello, I work on a Mac Studio, macOS 13.0.1 and LR version 12.0.1, unfortunately I can't print on our fine art papers. All saved presets are not loaded properly. When I apply one preset, wrong paper sizes are selected, wrong ICC profiles. Prints only works if I set everything manually for each picture. If I reset everything and create a new preset, the settings don't take effect on the next print. I've had this error since I did the macOS update and LR update. I urgently ask for help why LR does not use the pressure specifications correctly. greetings Andreas

TOPICS
macOS

Views

3.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 23, 2022 Nov 23, 2022

Copy link to clipboard

Copied

Looks like the Apple has changed the Print dialog in Mac OS 13 -- see if this post helps:

https://community.adobe.com/t5/lightroom-classic-bugs/p-problem-with-zoom-to-fill-in-lightroom-print...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2022 Nov 24, 2022

Copy link to clipboard

Copied

Thanks for the link, but the problem seems somehow to be related to LR. If I open my printer defaults with another program, the settings match, if I open my printer defaults with LR, the defaults are not correct, the settings are somehow reset or set incorrectly?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 23, 2022 Nov 23, 2022

Copy link to clipboard

Copied

On this end, latest LR and macOS 13.0.1, something is really wrong with color management as seen below with the Epson 3880. I've got Application (not Printer) managing color, and selected a profile as seen, but the driver setup is wrong. It should be automatically set for ColorSync not what is shown below (Epson Color Controls). Not an issue in Photoshop, it runs fine. Printing this way makes an awful (incorrect) print:

ColorSync.jpg

Now I simply select to print to the Epson P800, it is OK:

P800.jpg

 

When printing in LR, you do not want to use Presets in the printed driver! That's all part of the Template and setup you make in LR so keep Presets to Default. 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 23, 2022 Nov 23, 2022

Copy link to clipboard

Copied

I'm starting to hate Ventura. 

Disregard the last message. I quit LR, and opened it again, and now the CS ratio button is grayed out, thankfully. 

I built a new user template, and hopefully, this will stick. But I'd warn folks, at least using Epson printers to ensure this ratio button is correctly invoked; I have no idea if it might default back and produce another butt-ugly print. 

With the radio button correctly sent, LR and Photoshop produce identical prints as they should. 

But the bit about not using a preset in the driver still applies. Keep it at "None" and with the radio button correctly set now, it prints correctly.

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2022 Nov 24, 2022

Copy link to clipboard

Copied

Thanks for the answers, I also use an Epson printer and unfortunately have to create specifications in the printer setting because I save different paper formats and use the rear paper feed as well as the print quality here. Defaults in LR can be saved well, but LR does not take the defaults from the printersettings, If I select the printerdefaults, the settings do not match. It's verry annoying but maybe I'll find a way that I'll be happy to share with you guys.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

Hello, yes I got Ventura with my Mac Studio and was stupid enough not to downgrade. 

I have the same problem - color matching is greyed out in LR showing that Epson controls colors. But the printer (P900) says "Off (No Color Adjustment)".  So LR and the printer seems to be in some kind of disagreement...   

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

Can you post a screen capture of this P900 print dialog? 

With Application Manages Color, the ColorSync radio button should be grayed out. Is that you you're seeing? 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

Hello, thank you for taking care. Please see the screen shot from LR V12.1 and printer driver V12.65. I´m trying to recall when this occured, but I´m pretty sure that Ventura is the culprit here.. Considering starting logging all changes so it is easier to do this kind of "crash investingations"

 

Maybe this is new behavior in Ventura. Please educate in that case ...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

In your screen capture, the grayed out radio button is what I'd expect to see with Printer Manages color (Epson) while with Application Manages Color, ColorSync should be grayed out. At least that's what I see on my P800 under Ventura. At least when I got it to work as expected, See:

https://forum.luminous-landscape.com/index.php?topic=141759.0;topicseen

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2023 Jan 21, 2023

Copy link to clipboard

Copied

My problem is that it is greyed out with wrong radio button selected. Is shoud be ColorSynk. This is at least what is selected on my older Intel Mac with Mojave installed. Any hints on how to make that happen? Tried to carefully read the link that you have provided, but I´m still stucked.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 21, 2023 Jan 21, 2023

Copy link to clipboard

Copied

I think that I solved my issues. I unstalled ALL Epson software. Rebooted. Reinstalled the printer driver. Now the ColorSynk is selected.

 

Thank you for all suppport! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 21, 2023 Jan 21, 2023

Copy link to clipboard

Copied

My experience with the P800 and 3880 is I have to check everything each time I print with Ventura. The settings don't always stick as they should. 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2023 Feb 13, 2023

Copy link to clipboard

Copied

OK.. I don't see more recent post, but here it is in early February and there are still problems with Print module in LR Classic CC and Mac OS 13.2 Ventura.  I loaded the new driver on my Macbook Pro M1 Max and can now print but only on luster, gloss or plain paper.  None of the ICC profiles for fine art paper such as Exhibition Fiber, Watercolor, Hot Press Natural, etc are accessible.  Also, the color synch button is still greyed out.  Has anyone elase here determined  how to overcome these issues?  I would really appreciate some help here.  I love printing from LR Clasic, but for now, its a real pain.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 19, 2023 Feb 19, 2023

Copy link to clipboard

Copied

I have similar problems using a Canon printer. Was OK with MOjave, and I have the same mess (verntura 13.2, latest LR classic+PS). Printing now is a Russian Roulette game. Even if Colorsync is selected (but options grayed out so you can't select anytihng), sometimes PS chose the wrong option and let the printer manage colors......

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 21, 2023 Feb 21, 2023

Copy link to clipboard

Copied

Posted a workaround that at least allows you to set defaults for the printer using CUPS. The colorsync mess still remains:

 

https://community.adobe.com/t5/lightroom-classic-discussions/color-sync-choice-greyed-out-in-ventura...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2023 Mar 18, 2023

Copy link to clipboard

Copied

Just a follow up: I'm also (and still) facing the same issue. In my case with a Canon Pro 10. I have wasted tons of paper and ink trying to figure out how to get this fixed. I pretty much ignore all template settings and set them again whenever I have to print something. Still sometimes the prints work (use the correct color profile), sometimes they don't (are way too bright and have a magenta tint)

Everything worked fine on Mojave.

So annoying!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 18, 2023 Mar 18, 2023

Copy link to clipboard

Copied

It's Ventura. 

See:

https://forum.luminous-landscape.com/index.php?topic=142243.0

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2023 Apr 08, 2023

Copy link to clipboard

Copied

I'm also having these same issues with Ventura 13.2.1 and my old Epson R1900.  About six months ago I foolishly updated my Mac Mini M1 and MacBook Pro (Intel) to Ventura before I tried to do any photo printing. Big Mistake! 

Of course I assume it was me doing something wrong since all my photo printing previously was done on my old Windows 10 PC with no issues.  Lots of other bugs and problems with Windows, but not with photo prining.  Go figure, I assume that because publishing and visual arts pros prefer. Mac that I would never have problems like this! I guess I was very wrong!  Going by what I'm reading, I assumed I would not have has these issues with Big Sur -- or Monterey. Anyway aside from presets not sticking, my prints lack contrast and deep blacks and don't look like my soft proofs on my calibrated montitors.  I'm wasted a lot of paper and ink fooling around with this problem. I descided to fire up my old Windows PC and print the same test photo and it looks great, just like what I see on my monitor.  As for the greyed out area in print setup, once the radio button for colorsyce was selected, but it never happened again.  I assume it should be selected? 

So additionally I should say I'm having these problems with  LR CC and with On1 Photo Raw 2023 and have been using Epson Ultra Premius Luster pater

Here's the killer IMO, I contacted apple support about these problems with the print module in Ventura after I heard they had released version 13.3.  The support person had not heard of these bugs and so he conferred with a "developer" who aso had no heard of them!  And that 13.3 had not made any updates to the print module. How can this be. No one has complained to Apple about this? Sounds like all the updates they make are just wiz-bang/wicki-wacki!  Apple is sounding more and more just like Microsoft to me!  I though I was escaping that migrating to Apple! 🙂

BTW when I contacted Epson about these problems they just wanted to see screenshots of things like my nozzle checks etc. :-).  They were just as clueless!

So, is there a way to get through to Apple about these bugs? 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 08, 2023 Apr 08, 2023

Copy link to clipboard

Copied

Update to Ventura 13.3.  Apple was supposed to have fixed this in the update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2023 Apr 08, 2023

Copy link to clipboard

Copied

Has anyone tried 13.3 yet. I have not.  As I mentioned, Apple support told me no update was made to the print module with 13.3.  I understand there are a number of security updates, so I suppose that would be a good reason to update. If I do the update, I'll report back.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2023 Apr 08, 2023

Copy link to clipboard

Copied

Ok, I updated to 13.3.1 and it seems to have the exact same bugs.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 08, 2023 Apr 08, 2023

Copy link to clipboard

Copied

@Kelly Dazet, Print's Page Setup was crashing LR 12 on Mac OS 13.  Adobe employee Rikk Flohr posted that Mac OS 13.3 fixed the crashes, and several people reported that Page Setup no longer crashes LR:

https://community.adobe.com/t5/lightroom-classic-bugs/p-print-module-page-set-up-crashes-lightroom-c... 

 

Your symptoms are different. You could try the Epson troubleshooting steps recommended by @TheDigitalDog:

https://community.adobe.com/t5/lightroom-classic-bugs/p-print-module-page-set-up-crashes-lightroom-c...

 

I think for a problem like this, customer support from any of the big companies (Apple, Epson, Adobe) is often a waste of time.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2023 Apr 20, 2023

Copy link to clipboard

Copied

I have a new Macbook pro, Photoshop, and Epson R2880.  Everything, including profiles, worked fine until I let the computer update two days ago.  It's now Ventura 13.3.1 and I have the same problems described by others.  I'll assume I was using 13.3 before the update so I wish I could get tha back.  I've managed to get some decent prints with 13.3.1 today but not without a lot of fussing that I did not have to do before I updated.  How can I get back to 13.3?  BD

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 20, 2023 Apr 20, 2023

Copy link to clipboard

Copied

Rolling back to 13.1 is not a fix (nor easy/doable). The printing bugs have been around, albeit intermittently, since the first version of Ventura. 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines