Shift+arrow keys deselects instead of adding next image to selection

New Here ,
Jul 04, 2022 Jul 04, 2022

Copy link to clipboard

Copied

Issue: Shift+arrow keys deselects instead of adding next or previous image to selection in grid view.

  • Lightroom Classic Version Number: 11.4.1 
  • OS Version Number: MacOS 12.4
  • 2021 mbp 16", Eizo monitor, Wacom pen connected.
  • Same issue happens on 2015 mbp 15" on Catalina.


Steps to reproduce:

  1. Browse images in grid view.
  2. Hold shift and press left or right arrow key, to select multiple images.

Expected result: Adding next or previous image to selection, happens most of the time.
Actual result: Deselects all images. Happens ≈ 1/3 of times with shift+left arrow key, and 1/10 of times with right arrow key. Same result with both left and right shift keys. Same result  happens with shift + up or down arrow key as well.

 

The undo - redo queue doesnt register anything. If I browse using the arrow keys from image 1 and to the right (2, 3, 4...) and I want to add the next image to the selection with shift+arrow key, it deselects everything and show "Undo go to next photo" as next undo step. When pressing undo it selects the previously selected image (If image 4 is highlighted, and I want to add image 5, when pressing undo it selects previously highlight image, image 3). If the previous undo step was changing from Develop to Grid view or something similar, this becomes a very frustrating process of un-doing and re-doing to keep the workflow at a high speed.

 

 

TOPICS
macOS

Views

72

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

Can you provide more details about your hardware? Is this a laptop or desktop with extended, separate keyboard? If a separate keyboard is it wifi, battery operated, hardwired? It will be helpful to eliminate the keyboard as a culprit. When testing to recreate on my laptop the shift + arrow works as expected. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 28, 2022 Jul 28, 2022

Copy link to clipboard

Copied

I have the same issue. In the library module, the glitch can be replicated by pressing the right arrow, left arrow, then shift + right arrow. Then it will correct itself, but the reverse (left arrow, right arrow, then shift + left arrow) will do the same glitch. It will no longer select images and instead jump to the very end (or beginning) of the library.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

I'm seeing this same problem as well. Lightroom Classic 11.5 on Windows 11. Pressing Shift + Right is not deterministic and sometimes jumps to the end of the grid instead of selecting the next photo.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

LATEST

I'm running Lightroom Classic 11.5 on Windows 11 and I'm finding the arrow keys in the grid view to be incredibly buggy. I'm doing a lot of pruning work today, so I'm using Shift, arrow keys, and Delete hundreds/thousands of times, and I'm running into a lot of bad behavior. The problem with using Shift + arrow keys has been documented by others too:

 

https://community.adobe.com/t5/lightroom-classic-discussions/shift-arrow-keys-deselects-instead-of-a...

 

If you do a lot of Shift + selecting in the grid view, you'll eventually run into this problem too, whereby the selection fails, and you're suddenly moved to the very first or very last photo, depending on whether you were just pressing Left or Right. Furthermore, if you delete a selection of photos in the grid, then try to navigate with the Up or Down arrow keys, you may find that they don't work either. To fix this, I have to go into Loupe view, then back out to the grid, and then Up and Down work correctly again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines