Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


unable to download Lightroom older version

New Here ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Hello, I have High Sierra v 10.13.6 and I'm not able to download Lightroom as it's not compatible with my operating system. At the moment a new update for my Mac isn't available so I tried to download an older version on this page https://helpx.adobe.com/lightroom-classic/system-requirements/2019.html

 

There are no download buttons on the page, I checked with all the older versions available. If I click the download button on the top of the screen it takes me back to the new version and it says it's not compatible.

Anyone able to help, please?

TOPICS
macOS

Views

26

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

LATEST

Have you tried installing an older version from the Creative Cloud app?

MNiessenPhoto_0-1636707876222.png

If you can install LrC 10, you should be able to do it that way. For older versions, though, I unfortunately don't know the answer.

Hope that helps,

Michael

_____________

Michael Niessen - Photographer, photo-editor, educator

Photo-editing (Ps/Lr/LrC) and photography workshops & one-on-one training (off- and online)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines