Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Cannot save because the document is bigger than 2 gigabytes

5 Votes
Explorer ,
May 13, 2014 May 13, 2014

Copy link to clipboard

Copied

I have a fairly small psd file (1920x1080) containing just a couple of layers (25) mostly embedded linked psd files (small - between 70kb and 400kb each).

Now Photoshop (CC latest fwiw) sais, it can't save the document because it's bigger than 2 gigabytes. The document info sais Doc: 7,91M/50,9M...

Now what?

iMac 24GB RAM, Mavericks (latest), PS CC (latest)

Bug Fixed
TOPICS
macOS

Views

770

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
27 Comments
LEGEND ,
May 13, 2014 May 13, 2014

Copy link to clipboard

Copied

Something in your document is much larger than you think, and it overflows the 2 Gig limit for PSD when saving.

You can save to PSB that handles larger files - but the file is still going to be large.

You need to figure out what in your document is so large (possibly a layer mask, or a transformed smart object that goes WAY outside the document bounds).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 13, 2014 May 13, 2014

Copy link to clipboard

Copied

It was my background rectangle (live shape 1920 x 1440px - seems not extremely huge to me ;)). After deleting the layer and dropping a new live shape in, things worked again.
A better error-message would be helpful, though.

thx

andy

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 13, 2014 May 13, 2014

Copy link to clipboard

Copied

Something about it had to be much larger -- did you confuse inches with pixels somewhere?

And the message means what it says - the file size exceeded the 2 GB limit for PSD files. There could be hundreds of possible causes of that, and no way to list them all in the message.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 13, 2014 May 13, 2014

Copy link to clipboard

Copied

Hi Chris,

thanks for trying 😉 - but no, I re-verified - there was nothing wrong with the rect (if I could have saved it, I would have sent it for investigation anyway). I dragged everything to a new window - same problem; so PS was unhappy with something. I then deleted one layer after the other (unfortunately top-down, so the background rect was the last ;/)

The canvas (window) was setup to be 1920x1440px in size and I created/dragged the rect to exactly that size.

I don't know, if this is helpful, but there was one thing which I found mysterious:
- as I said, the window was 1920x1440px
- the rectangle was set to exactly that size, but at the right and bottom edges there was 1px missing and the window background shined through. When I moved the rect to fill out the whole window, the rect was 1921x1441px. And I verified a couple of times, the rect's origin was at 0x0px.
IIRC I had a similar problem a while ago, but dunno about the details anymore.

Maybe the problem was a coincidence of a couple of different things, but the Mac was freshly rebooted and only PS was running (as application).

I don't know if any of the above makes sense or is helpful in any way, but it may be related to the way I use SmartObjects (or linked documents), because that was what I was working on. (btw. I think I still have a former version of the doc, where the SmartObjects lost their references in a weird way: When updating one of the SmartObjects, only *some* of the other objects were updated (in my case 3 from 20) - I'll look tomorrow, if I still find this version).

Anyway - thanks for responding!

Best

Andy

Btw. since I'm doing UI all the time, everything in my settings is set to px - since 22 or 23 years (that's when I started using PS 1.0) 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2014 Dec 08, 2014

Copy link to clipboard

Copied

I have same problem. File contains some small bitmap layers + simple vector smartobject. When I save to PSB, filesize is 83MB.

Win 7 64bit, latest PS CC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 11, 2015 May 11, 2015

Copy link to clipboard

Copied

Hey all!

I had the same problem a couple of minutes ago and the only solution I found was to apply all the masks and then save.

Hope this helps someone out!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 12, 2015 May 12, 2015

Copy link to clipboard

Copied

That means that you had a transformed mask that was huge, and were saving in PSD format instead of PSB.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 07, 2015 Jun 07, 2015

Copy link to clipboard

Copied

Try cropping the design... you may have file going over the canvas.. See 1st comment Chris Cox...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 14, 2016 May 14, 2016

Copy link to clipboard

Copied

The error message says to check 'saving and exporting' files, but the search function does not identify this topic

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 18, 2016 May 18, 2016

Copy link to clipboard

Copied

good It is definitely better to favor great internet Xender PC interconnection for downloading it this software on Bluestacks. nice.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

I had this problem on a piece of art I'm painting and it's 18,000 X 12,000 pixels. Yes, HUGE! The problem is if you have ANYTHING outside of the base rectangle/artboard the "beyond 2 gigs" message came up. I place a layer filling it completely with color, then I clicked on that layer and any layer that had anything outside the rectangle. By using the cursor and "pushing" the "bunch" of layers up, down or to the side I could see what was outside the rectangle. To delete the unwanted stuff I used the selection tool to select that layer of color I filled, hit invert and delete the effected layer, repeat for each layer. Now, you need to repeat the whole process from the selected layer again and again as you "push" your layer 'bunch' around and around so you can delete all outside the rectangle. Once finished, I moved my layer bunch back to the rectangle and now it will save! Can you picture that? Should I make a video?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

Choose Save As, then select Large Document Format from the Format pop-up in the save dialog. It will allow you to save a file greater than 2GB

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 30, 2018 Mar 30, 2018

Copy link to clipboard

Copied

I believe this is a bug, I have the same problem since upgrading to the 2018 version of PS

I regularly have elements of my image outside the document canvas as I work in pattern so I’m doing repeats. My documents are usually quite large 7200x7200 or larger but the files are rarely bigger than a few hundred MB, I’ve been using Photoshop in a similar way for around 20 years and with similar document sizes for at least the last 8 years. Only since upgrading to the 2018 version of PS have I had this problem and it happens quite regularly. The document size reported in the PS UI is always less than 2GB, the only way to get it to save when this problem occurs is to remove everything outside the canvas and merger all the layers, even then it sometimes still won’t save. As others have mentioned, the problem seems to stem from having things outside the canvas which was never a problem in the past.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 30, 2018 Mar 30, 2018

Copy link to clipboard

Copied

Can you save one of your files that you think should be smaller than 2GB (save as a PSB) so we can examine it for clues? (Post it to CC files or dropbox and provide a URL to download)

Often files are larger than you might imagine for valid reasons/

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 14, 2018 Apr 14, 2018

Copy link to clipboard

Copied

The same thing happened to me and I figured out I was editing the image in 16bit but didn't change it to 8bit before trying to save it. This happened to me because, I had recently changed my settings in Lightroom to export into Photoshop in 16bit instead of 8 bit.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 14, 2018 Apr 14, 2018

Copy link to clipboard

Copied

In Photoshop, go to Image -> Mode -> 8bit then you save it. I hope this helps you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 08, 2018 Jun 08, 2018

Copy link to clipboard

Copied

I had the same issue. 
File in 8 bit. 
8.5 MB when saved in .psb
No masks
No hidden or large objects
What worked for me was during the save process, unticking the Maximize Compatibility box in the Photoshop Format Options pop up modal. 
Hope that helps. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 26, 2018 Jun 26, 2018

Copy link to clipboard

Copied

Hi thanks for this info... I've spent hours trying to save some files for an exhibition I'm working on and I've managed to lose everything twice! I've just seen this on the forum, but my 8bit is greyed out... any solutions to that please.... really struggling to save anything... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 19, 2018 Sep 19, 2018

Copy link to clipboard

Copied

For me, even in PSB it's still give me this message 😞

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 19, 2018 Sep 19, 2018

Copy link to clipboard

Copied

What program are you using? Are you trying to use Elements? I don't see that you have a Creative Cloud membership.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 28, 2018 Dec 28, 2018

Copy link to clipboard

Copied

Same issue, 3x3 inch cmyk image. psb saves at 20mb, turned off maximize compatibility and it saves fine as a psd. gotta be broken.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 25, 2019 Feb 25, 2019

Copy link to clipboard

Copied

I agree. I only had this error start coming up in CC 2019.

Besides, why should it matter what size my file is? If I want to save a 5 GB file or more, I should be allowed to. I often work with very complex Photoshop files, which I would like to be non-destructive (not flattened, not rasterized), because I am often required to make changes to them during the design and approval stage.

Once all final approvals are made, a much smaller, flattened file saved.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 25, 2019 Feb 25, 2019

Copy link to clipboard

Copied

Select "Large Document Format" to save a PSB. This will allow you to save layered Photoshop documents that are larger than 2GB.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 17, 2019 Apr 17, 2019

Copy link to clipboard

Copied

how do you import it in AE then? AE won't accept PSB...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 18, 2019 Apr 18, 2019

Copy link to clipboard

Copied

You may need to reduce the number of layers and resolution for your file to work in After Effects. Not all products can handle the pixel dimensions or the file sizes that PSB affords.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines