P: Cursor stuttering & screen flickering in Photoshop on high refresh rate G-sync monitors

9 Votes
Guide ,
Jul 15, 2020 Jul 15, 2020

Copy link to clipboard

Copied

If you're a nvidia gsync user and experiencing mouse stuttering in Ps (and all Adobe apps), try turning off gsync to see if that resolves the issue. 
Basically what happens is that any activity in an Adobe app will result in 2-3 seconds of micro-cursor stuttering (looks like frame rate dropping) and the occasional 3-4 seconds of cursor freeze. Disabling gsync fixes the issue. This behavior appears only in Adobe apps and none other.

 

 

{Thread title edited by moderator}

Bug Unresolved
TOPICS
Windows

Views

10.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 5 Correct answers

Explorer , May 10, 2022 May 10, 2022
I turnet G-Sync off and the problem was solved. Thx

Votes

Translate

Translate
Adobe Community Professional , May 10, 2022 May 10, 2022
First, try disabling GPU in the Lightroom Preferences (Performance tab). Any better? If not, recalibrate and build a new ICC display profile, the old one might be corrupted. If you are using software/hardware for this task, be sure the software is set to build a matrix not LUT profile, Version 2 not Version 4 profile. If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if...

Votes

Translate

Translate
Adobe Employee , Jan 11, 2022 Jan 11, 2022
Adobe Community Professional , Jan 11, 2022 Jan 11, 2022
Make sure you go to PS prefs and turn on HDR display suppor under Technology Previewst. 

Votes

Translate

Translate
Adobe Community Professional , Sep 15, 2021 Sep 15, 2021
Hello, IIRC, in the past some customers reported fixing some display issues by deactivating G-Sync in their drivers. I would also  try to check "Deactivate Native Canvas" in the menu Edit/Preferences/Technology preview (Pc) or Photoshop/Preferences/Technology preview (Mac) . This is not a fix, but rather a way to check if the issue appears only with the new technology, and should be reported to the Ps team.

Votes

Translate

Translate
replies 109 Replies 109
109 Comments
Adobe Employee ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

Do you have G-Sync enabled? https://community.adobe.com/t5/camera-raw-bugs/p-cursor-stuttering-amp-screen-flickering-in-photosho...


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
New Here ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

I have the same problem with the latest nvidia driver and photoshop version.

Rtx 2080 + DELL S2716DG

 

Disabling gsync just for photoshop doesn't solve the issue, the only way I can have a smooth experience is by disabling gsync completly from nvidiacp. Same problem for Lightroom and Classic.

 

 

Votes

Translate

Translate

Report

Report
New Here ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
New Here ,
Jan 23, 2022 Jan 23, 2022

Copy link to clipboard

Copied

This method seems to work for some people, in my case it just makes things worse. With this settings I get black screen flashes every time I perform some action in Photoshop.

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

Same here, with this method i have worst symptoms ( Black screen flickering/flashing).

The only option that works for now is to disable G-sync permanently 

Votes

Translate

Translate

Report

Report
New Here ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

Hi Jeffrey, how is it possible that after so many reports, for several years now, Adobe and Nvidia have not gotten together to solve this? The collective hours of your clients waster around this issue certenaily should mean something to prioritize this bug. Disabling g-sync specifically for Photoshop, just ended up with my screen flashing black everytime I move my mouse on photoshop and it triggers any render on it (mouse over, tooltip, etc).

Adobe has been the first and only software I have encountered with this kind of problem with g-sync, that highly suggested that something has been done that does not follow the guidelines of the drivers. How much longer will we, paying customers, have to wait for this issue to be addressed?

Votes

Translate

Translate

Report

Report
New Here ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

So true.... totally agree with you...

 

I'm running my monitor with G-Sync turned off permanently because apparently that's the only fix at the moment...

 

ADOBE AND NVIDIA PLEASE FIX THIS!!!

 

Votes

Translate

Translate

Report

Report
New Here ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Same problem with Ae. In ae even disable the gsync not work it.  

 

My refresh rate is 165hz. When i make it 60 hz, problem is gone with all adobe app. Plesae fix it. 

Votes

Translate

Translate

Report

Report
New Here ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Same here with an 2080 on GSYNC enabled. All tricks within the NVIDIA Control Panel didn't work for me at all. Only solution is to completely turn off GSYNC, this is becoming ridiculus. This thread nearly celebrates his second birthday without a real solution!

Votes

Translate

Translate

Report

Report
New Here ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

I have a 165hz monitor and gsync, this solution is the only one that has worked for me. they should fix it.

Votes

Translate

Translate

Report

Report
New Here ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Just to keep the post alive. Same here, just switched to a 3060ti from an old RX 570 here me thinking everything would run as smooth as butter, but oh boy oh boy PS my main tool at work runs like absolute garbage.

 

Clean windows install, cero software other than Nvidia Studio Drivers and Photoshop, SAME issue, not even disabling Gsync works, the flicker goes away but the program still runs so slow even just panning and zooming in/out is extremely diatracting and impossible to worl with.

 

This didn't use to happen with my old GPU. I don't see this being fixed any time soon so I might have to switch back to the old GPU. Hige bummer. 

 

Sad thing is, not everyone has a spare Radeon GPU laying around especially with the current hardware shortages and inflation.

 

Can't believe Adobe having their income and man power can't figure out how to make this arcaic 25 y/o piece of software work.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. 

Also see: https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
New Here ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

I think you misunderstood my issue, i SWAPED gpus, I also tried turning off gpu acceleration on photoshop, and as I mentioned my drivers are all the msot recent in a clean install of windows. The link you shared already read all through it, all of the faws, optimization tips and every official help guide from adobe I have read, nothing works.

That's why i took out the Nvidia gpu and put in my old AMD gpu, that's the only thing that works. Please read carefully before repliying.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

What I didn't misunderstand is, that issues with GPUs are based upon issues with their drivers, mostly under Windows. You can blame Photoshop if that makes you feel better. But the facts are if you disable GPU and an issue goes away, the bug is with the GPU. This is why this option exists and yes, you lose that issue and everything that relies on the GPU slows down. 

More and more functionality is moving to GPU, so expect this to continue. 

Fact: just because an older GPU works, doesn't mean the newer one isn't affected by a driver bug. But again, it is easy to test this with the options Adobe provides for GPU. 


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
New Here ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Again: I did try disabling the GPU in Photoshop and that did not solve the issue.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

And that indicates it's not a GPU bug, nothing more.

Did you follow the correct answer recommendations fully?


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
New Here ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

With all respect sir, I think you are wrong and or contradicting yourself. If it's not an issue with the GPU or the driver why is swaping it to a Radeon GPU fixing such issue?  Also you said "What I didn't misunderstand is, that issues with GPUs are based upon issues with their drivers" you let me understand that you agree that drivers for this components can be the source of the issue and to that I completelety agree.

Also like I mentioned. I read everything, all guides, official FAQs, all answers to this and other posts, nothing same issue and the only thing that solves it is swaping to a different GPU.

Also small theory here: My CPU has no integrated graphics so even if I disable all GPU features in photoshop my PC still depends on the GPU to a certain degree to proyecto the image onto my display so maybe that's why it still bugs out.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Why don't you start a new post explaining your exact problem with system and hardware details. There is an issue reported here from way back in 2019 and a solution. Others found that it works. You have kind of hyjacked an old thread with three posts (your first here). You have an issue? Report it and maybe someone will be able to assist you.

You can post your new issues and theories then and there. 


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Turning off gsync 'as a solution' is the same as telling someone to lower their resolution to 1080p because photoshop doesn't render correctly at 4k. That's not a solution.

This is a matter of how certain adobe products are implemented and how the take advantage (or don't) of certain features that drivers expose from their graphics cards. GSync being one of those features.

 

This is an old thread, yes, but it's still without official response on when they plan to implement/fix gsync compatibility, a feature that has been available for NINE YEARS in windows/nvidia.

 

Do they require collaboration between nvidia, microsoft and adobe to fix this? Sure, they should make that happen, they're the software owner.

 

Radio silence is not a good look and turning off a monitor feature that works (almost) flawlessly with all other software is not a solution.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

You're spinning your wheels here with such an old post. Here's how to get results above and beyond resurrecting 3-year-old post that fixed other's issues! 

https://community.adobe.com/t5/photoshop-ecosystem-bugs/how-do-i-write-a-bug-report/idi-p/12373403

Problem Description:

Steps to Reproduce:
1.
2.
3.
4.

Actual Result:

Expected Result:

Any Workarounds:

 

More here: 

https://www.lightroomqueen.com/send-bug-report-feature-request-adobe/


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Hi, I just upgraded to PS 2022 and I started having some visual bugs and also, my program is lagging sometimes, for example when I zoom in. One of the visual bugs I have is when I undo a brush stroke, the place fades where the brush mark was. Other bugs are that some places of my workspace are changing colors as I move the canvas. My GPU is updated and working properly and I also tried deleting my PS settings and preferences, but didn' help.Screenshot (71).pngScreenshot (72).png

 

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Hi, you should check system requirements for the latest version this may be one of reasons or if you have a good computer then wait for the next update of all bugs in the notice of the Adobe team...regards

Ali Sajjad / Graphic Design Trainer / Freelancer / Adobe Certified Professional

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Hi @Valeriu, here are a couple things to try:

 

Go to Preferences > Performance... and uncheck Multithreaded Compositing - and restart Photoshop. Does the problem persist? 

 

Go to Preferences > Performance... click Advanced Settings... and uncheck "GPU Compositing" - then restart Photoshop. Does the problem still occur? 

 

Thank you,

-- Cory

Votes

Translate

Translate

Report

Report
Explorer ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

I tried, the problem still occurs.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

First, try disabling GPU in the Lightroom Preferences (Performance tab). Any better?

If not, recalibrate and build a new ICC display profile, the old one might be corrupted.

If you are using software/hardware for this task, be sure the software is set to build a matrix not LUT profile, Version 2 not Version 4 profile.

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if this is the latest OS version, you may need to roll back a release. 

Also see: https://helpx.adobe.com/photoshop/kb/acr-gpu-faq.html


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Votes

Translate

Translate

Report

Report