Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Weird Vertical Lines when using Smart Sharpen and "Use Graphic Processor" Turned on Monterey

9 Votes
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

jacksonl41895023_0-1635943480408.png

 

Getting random weird vertical lines on Apple m1 pro with Photoshop 23.0 and 22.5.2

 

Goes away when "Use Graphic Processor" or "open CL" turned off, but operation becomes extremely slow.

 

Can anyone Please help?

 

Bug Started
TOPICS
macOS

Views

483

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 11, 2021 Nov 11, 2021
We're investingating this issue. It's a Monterey specific GPU driver issue.
Status Started

Votes

Translate

Translate
26 Comments
Community Beginner ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

When using 'Smart Sharpen' option on ver. 23 on my MB Pro (Apple chip / Monterey OS), I now get 2 vertical lines on any image I try to 'smart sharpen'.   one line is near center and one off to the right.    No other sharpening mode creates this error.  Anyone else see this?  Screen shot attached.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

have the same problem with MB Pro with Monterey OS.   The issue doesn't happen with unsharp mask.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

Getting the same thing -- two odd vertical lines only when trying to use Smart Sharpen. Does not happend with unsharp Mask. Photoshop 23.0.0 pm MacBook Pro M1 Max running Monterey 12.0.1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Same problem here, but if you view your image in "Fit on Screen" you see 2 or 3 vertical lines; if you view it in 100%, you see many more lines, I counted as many as 9 in one of my images. All lines aprear to be 1 pixel in width in 100% view. Plus the whole image shifts one pixel from right to left in my case. Click on and off the Preview button, you can see this problem like an animation. Any setting changes on the Smart Sharpen window won't change the width and locations of the lines.

 

No problem if you "Smart Sharpen" on Lab color channel.

 

MacBook Pro M1 Pro MacOS Monterey 12.0.1

Photoshop 23.0.0

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Same issue. This is a catastrophic bug for me right now, breaking our production workflow. Photoshop for M1 has other issues as well, weird graphical problems, thumbnails in layer panel not updating. The app is simply not ready for M1 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

It's as if adobe is not paying any attention to the M1 chip.  Considering how many users have M1 chips you'd think adobe would test the software properly before releasing.    

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

I am having the same issue with random vertical lines appearing after using Sharpen tool.  Mac O/S Monterey 12.0.1 with Photoshop 2022 ver. 23.0.0.  Very frustrating as lines are very subtle so I didn't notice them until I finished editing many photos.  Please help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

Exactly what happens to me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2021 Nov 07, 2021

Copy link to clipboard

Copied

My client had to tell me about it!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

same here.  m1 13".   vertical lines on DNG and jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

When I use smart sharpen on images imported from Canon DPP I am seeing two verticle lines appear on the part of the image that I am sharpening.

When I undo the smart sharpen the lines disappear.

Any ideas???

Tim 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Hi try to reset your photoshop preferences and check it or try on other picture it is working on my side...regards

Ali Sajjad

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

Are you on macOS Monterey?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 11, 2021 Nov 11, 2021

Copy link to clipboard

Copied

We're investingating this issue. It's a Monterey specific GPU driver issue.


Senior Product Manager - Customer Advocacy - Digital Imaging
Bug Started

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

I have the same problem. I was puzzled until I found this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Can you please try this as a workaround: Go to Preferences > Performance... then choose "Advanced Settings" and uncheck "Use OpenCL" then restart Photoshop. Does the problem go away?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

Yes it goes away but slows down processing.   Not a fix.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2021 Nov 14, 2021

Copy link to clipboard

Copied

As reported in my OG Post, turning this off fixes the lines, but performance is much much slower.. unacceptably slow

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Thanks for confirming. Photoshop is working on moving everything from OpenGL/OpenCL to native GPU (Metal and DX12). Smart Sharpen still uses OpenCL.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

I went to appy a smartsharpen to an image with lens bur and it is causing a glitch that shifts a column of a few pixels ruining the image. it does this a few times across the image.

M1 mac 8gb ram PS 23.1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Yeah. Its so sad. Adobe is such a mess ever since Adobe cloud. Every new release introduces new bugs. I can't even tell how many hours my company lost in money. Some of the employees get graphical bugs when zooming in and out. This is just not a professional option anymore. Every release breaks something and now not even shapening works. So damn sad and we have to pay for it. When we used to pay 1k for the master collection at lest the software worked. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

FWIW I just ran Smart Sharpen on an image in Monterey on an M1 MacBook Pro and no vertical line. But if this is still happening I am sure Adobe will fix it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2021 Nov 25, 2021

Copy link to clipboard

Copied

A quick update. I just ran Smart Sharpen on another photo and ended up with the vertical line again. I switched to Unsharp Mask. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2021 Nov 28, 2021

Copy link to clipboard

Copied

I just ran smart sharpen on M1 macbook pro/Monterey and lines appeared.  When might this be fixed? I am on a tight deadline and this is maddening.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2021 Nov 28, 2021

Copy link to clipboard

Copied

Same. M1 macmini latest photoshop update and Monterey. Vertical lines still there. I wonder how many people this affects that misses to see the lines and delivers to clients...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines