• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

CS4 + 10.6.5 - Delete Photoshop Settings file?

New Here ,
Nov 15, 2010 Nov 15, 2010

Copy link to clipboard

Copied

I'm having major issues when starting Photoshop CS4 on an iMac running OS X 10.6.5.  My keyboard almost becomes "stuck" and invokes strange actions.  I am using Spaces and using the Option key + arrow key to move between Spaces.

Tried opening up Fireworks immediately after closing Photoshop and it works properly without any issues.

Any ideas?

Views

53.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
replies 132 Replies 132
New Here ,
Nov 27, 2010 Nov 27, 2010

Copy link to clipboard

Copied

I can also reliably reproduce the bug with Things, as described above: as soon as I use the "quick entry with autofill" combo. Every time. The normal quick entry never triggers the bug.

So, here are a few things I've noticed:

- It's not the only way to trigger it on my Mac: I never used this combo before I read this topic (I actually had to change it's keyboard shortcut to use it because of a keyboard shortcut collision with another app, so I'm 100% sure I didn't use it by mistake.) I normally only use the standard quick entry that doesn't trigger the bug. Oh and I noticed this issue way before 10.6.5 too.

- Using the "fix-upper" worked, until I used quick entry with autofill in Things again. Still it's good to have this fix when we're in the middle of some work, instead of having to log out. Thank you for making it available to us!

- The main difference between the quick entries is that the "quick entry with autofill" uses OS X Services to get any selected text in the frontmost app and some other informations, as described in Cultured Code's wiki: http://culturedcode.com/things/wiki/index.php/Quick_Entry_and_Autofill

No idea if it has anything to do with the problem though, just writing it down in case it helps.

- Once triggered, CS apps (Illustrator, Photoshop, InDesign…) act as if Control, Command and Option are always down. Oh well, and Shift too.

- Lightroom doesn't seem to suffer the bug, but it is not part of CS.

- Every non-CS app I've tested worked normally while the bug was triggered in CS. If you open OS X's keyboard app, Control Command Shift and Option don't show as down. So it seems they're only "stuck" in CS, not at the OS level or in all the other apps I've been testing.

- The shortcut itself is not important. In Things I tried Shift-Ctrl-Option-Command Space, Ctrl-Option-Command Space, Shift-Ctrl-B and a few others, and it didn't make any difference.

- Once triggered in one CS app, the bug is immediately triggered in other apps from the CS suite too.

ie: I launch Illustrator, trigger the bug with Things, then if I launch Photoshop it immediately asks me if I want to erase the prefs. This dialog is supposed to show only if you press Option while Photoshop launches.  Same for InDesign. It seems the bug is triggered for all CS apps at once, even the ones not launched!

So I tried to find a process that would be shared between those apps and could be the culprit, like CS5ServiceManager or AdobeCrashDaemon. But even if I force-quit these processes I can still trigger the bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Nov 27, 2010 Nov 27, 2010

Copy link to clipboard

Copied

Please read the previous replies, especially the ones from Jesper identifying the OS API that triggers the bug (after it was changed in 10.6.5).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 30, 2010 Nov 30, 2010

Copy link to clipboard

Copied

Here's the tech document on this issue:

http://kb2.adobe.com/cps/881/cpsid_88159.html

We're working with Apple to address the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Jan 07, 2011 Jan 07, 2011

Copy link to clipboard

Copied

Is this fixed in 10.6.6?


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 07, 2011 Jan 07, 2011

Copy link to clipboard

Copied

No. It didn't make the cut in time.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 02, 2010 Dec 02, 2010

Copy link to clipboard

Copied

Thanks for the hack Jesper. Works great.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2011 Jan 20, 2011

Copy link to clipboard

Copied

Thank you very much Jesper, it worked for me and solved this really annoying issue.

I hope an official fix is released soon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jan 20, 2011 Jan 20, 2011

Copy link to clipboard

Copied

Thank you ever so much for creating this solution. I  haven't been this frustrated by a bug like this is quite a few years. I thought is was a new setting I was overlooking in my new CS5 & 10.6.6. I spent hours hunting down this new unwanted "feature".

Kudos to you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2011 Mar 12, 2011

Copy link to clipboard

Copied

Thank you Jesper the patch seemed to work for a whilebut after I select a source with the stamp the cursor seems to have a new layer floating around with it! I can't tell you how much this has been driving me crazy Come on 10.6.7 !

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 14, 2011 Mar 14, 2011

Copy link to clipboard

Copied

I'm having the same issue for maybe a month. Not sure, what triggered the bug.

Cmd-Z and many other shortcuts are not working.They stop working randomly.

I'm not using Spaces or any thing like that...

Jesper's utility doesn't help. What helps - is switching to other Application and then back.

P.S. It seems to me in case of Photoshop the problem has something to do with Workspaces. When I switch Workspaces the problem sometimes vanishes away. And I defined a lot of workspaces these days (that don't redefine keyboard though).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Mar 15, 2011 Mar 15, 2011

Copy link to clipboard

Copied

This is a very short term fix for me. When I switch another program or even another document within the same program, my keys get stuck again. Which makes multi-tasking very painful. It's like taking a swig of vinegar every 30-60 seconds.

I think I'll be rolling back. This is just terrible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guru ,
Mar 15, 2011 Mar 15, 2011

Copy link to clipboard

Copied

From March 14 2011 AppleInsider:

Apple on Monday seeded the eighth beta of Mac OS X 10.6.7 to developers, with the latest build again featuring no new issues and no new focus areas, suggesting a final release could be close.

Adobe engineers here can't comment if this Mac OS update fixes the problem, but I can't imagine it doesn't. So just hang tight for a week or two.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 21, 2011 Mar 21, 2011

Copy link to clipboard

Copied

Mac OS X 10.6.7 is now available, and it should fix the stuck modifier key problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 21, 2011 Mar 21, 2011

Copy link to clipboard

Copied

I've updated our knowledge base document here to reflect that updating to 10.6.7 corrects this problem.

http://kb2.adobe.com/cps/881/cpsid_88159.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Mar 21, 2011 Mar 21, 2011

Copy link to clipboard

Copied

Woo-hoo! Power to the people. RATM would be so proud. Thanks for everyone to make their voice heard and Adobe/Apple to work diligently to get this all fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2011 Mar 24, 2011

Copy link to clipboard

Copied

While 10.6.5 may have corrected the problem associated with shortcut keys, and even though I'm now operating with 10.6.7, I still have the same problem, which I began having two years ago, that caused my Mac keyboard to freeze after using the clone tool.  I had this problem using a Power Mac, and still have the freeze with a new iMac.  Earlier on Adobe suggested on this forum that it was a hardware problem, involving a faulty keyboard.  Three new wireless keyboards later, and the problem persists.  It can't be the use of a wireless keyboard, since I had the same freeze problem with using a wired keyboard. 

As many people have reported this problem, has there been any solution found?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

I would prefer it if we could start something like a public google doc that we could share as a list, but maybe each person could just cut and paste the lists I have started and add to it? Please include version number when possible.

Was effecting:

Photoshop CS3

Illustrator CS3

Items Running, that are NOT interfering:

Quicksilver

Dropbox

1 Password 3.4.4

Items disabled, that SOLVED the problem:*

X-Gestures 1.75

TextExpander 2.0

Jitouch

*Please note, these are items that MUST be disabled, removed from your startup items, and your computer restarted.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2010 Nov 24, 2010

Copy link to clipboard

Copied

Was effecting:

Photoshop CS5

Illustrator CS5

Indesign CS5

Items Running, that are NOT interfering:

Alfred

Dropbox

Things

Items disabled, that SOLVED the problem:*

None, simple reboot

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2011 Jan 11, 2011

Copy link to clipboard

Copied

Hey guys, I wanted to let you know that I had a similar problem, as seen in this thread:

http://forums.adobe.com/thread/775689?tstart=0

...and disabling Dropbox solved my problem.

I also had LogMeIn running, and I disabled it at the same time, but I don't know that this had anything to do with the error.  I've, interestingly, also restarted Dropbox and rebooted, now allowing it to start at boot again, and I'm not having the issue, even with Dropbox running.  It's like I had to reboot once with it disabled, and now everything's fine even if I'm running Dropbox.

I'm on OSX 10.6.6, by the way.  Photoshop CS5 Extended x64.

I'll chime back in if I have the problem arise again.

EDIT:  HyperDock 1.0 also causes the issue.  You can disable HyperDock from the HyperDock Preference Pane, and Photoshop's hotkey's work again, and re-enable HyperDock and cause the issue.  There is no need for a restart in this case.  I will be contacting HyperDock's developer later today; he's been pretty on top of things / responsive, since it's a newer application that just came out of Beta.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 04, 2011 Feb 04, 2011

Copy link to clipboard

Copied

I just wanted to draw your attention to my previous post, which I just edited, indicating that HyperDock 1.0 is also causing the issue under OSX 10.6.6.

You can disable HyperDock from the HyperDock Preference Pane, and Photoshop's hotkey's work again, and re-enable HyperDock and cause the issue.  There is no need for a restart in this case.  I will be contacting HyperDock's developer later today; he's been pretty on top of things / responsive, since it's a newer application that just came out of Beta.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

Bingo!  I think you guys have it!  I use Things— my quick entry key combo is different (control+command+shift+space), but it sure sounds like it could be the source of my issue as well!  (Maybe not a Things-specific issue, but something to do with some combo of complex shortcuts?)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

Hmm, keyboard triggers. I use them a lot with these applications:

- 1password (CTRL + ALT + L)

- Things (CTRL + ALT + spacebar)

- Tweetie (CTRL + ALT + OPTION + T)

So using one of these keyboard shortcuts could trigger the problem in the Adobe Suite. I can see that most of us use Things. Now is the question indeed who needs to fix this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Nov 24, 2010 Nov 24, 2010

Copy link to clipboard

Copied

nononxense - did you read Jesper's posts?  This appears to be a MacOS bug introduced in 10.6.5.

The apps triggering it (Dropbox, Things, etc.) might be able to code around it, but that's a bunch of different apps to fix.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 24, 2010 Nov 24, 2010

Copy link to clipboard

Copied

I suggest that everyone who is able to identify an app, that triggers this issue, contacts the developer of that very app. Wether it's up to them to code around a bug, or to report the bug to Apple or to change the way their apps work because that API call may be deprecated (it does not necessarily need to be a bug) - they will know best what to do.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2010 Nov 24, 2010

Copy link to clipboard

Copied

In my case it's Things, even if I change the default shortcuts. If I quit Photoshop and open it again it gives the problem. As long as I do not use the Things shortcuts it works flawless. I'll inform Cultured Code of this bug. Anyone else having the same issue. If everyone sends an email to Cultured Code they they will see its quite important to take action on this bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines