Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Why does Mac hang with Photoshop Elements 2019 and Mojave after previewing video clip in Organiser, but only the first time

Participant ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Hi I have videos and photos loaded into Organiser 2019 on my iMac running Mojave. The problem that has existed in the past few versions of Photoshop Elements and iOS persist . The problem is that after previewing a video clip in the Organiser, the program hangs. Only Force Quit works. I have done the adjustments advised by Apple, i.e  ensure the programs have correct security access and cleared all relevant caches etc. This was all done done under Apple guidance. t worked for a while. Today the problem is back, and seems now to be only on the first viewing of the clip. At this stage there is no image in the organiser for the clip, and I usually get a message saying " Preparing media". The clip plays. You return to Grid of media, and it hangs. Do a Force Quit, start again, repeat. This time there is an image of frame for the video in the Organiser grid. Play the clip, back to grid, and it doesn't hang. As all software is current and supported. i need to get this fixed. It seems lots of people have had various  hangs, and no real solution seems to exist, even though we were promised 2019 and Mojave would be OK. Chris

Views

496

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 05, 2019 Feb 05, 2019

Copy link to clipboard

Copied

Hi Chris,

Thanks for posting in Adobe forums.

It seems you are facing issue with spinning wheel in Adobe Photoshop Elements after upgrading Mac OS.

Could you please try the following steps :
• Click Apple icon >> System Preferences
• Security and privacy >> Click on the lock to unlock it then enter the administrator password >> Enable (check the radio button) the Photoshop Elements 2019 editor and Elements Organizer 2019 that appear in the list.
• Click on the lock again to lock it.
• Restart Mac

Hope this helps

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 07, 2019 Feb 07, 2019

Copy link to clipboard

Copied

Hi. Thanks for that. I have done that and it fixed

it for a while but not permanently. I have checked

and it is still set ok. I also did this for

Premier Elements which has the same issue

Chris

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2019 Feb 13, 2019

Copy link to clipboard

Copied

From Adriana Fantes. I have the same problem as Christ, and went to the genius desk at apple several times. however the problem stil exists. I can't do my work and in desesperation west to apple layout(Needless to day i miss Elements. )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 08, 2019 Mar 08, 2019

Copy link to clipboard

Copied

Hi Update.... as well above change re Privacy, Apple has now told me you need changes to the Terminal Utility. This is explained below, or get Apple to do it for you, as I didi. Been OK for couple of days. https://support.apple.com/kb/HT203538

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 19, 2019 Mar 19, 2019

Copy link to clipboard

Copied

Update from Chris! Above didn't work for long. Have now, on another thread got notification of Update from Adobe. Applied, but not sure yetis fixed Chris

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 24, 2021 Jan 24, 2021

Copy link to clipboard

Copied

LATEST

Update for above. Things have moved on as its 2 years since I first posted. But this is back consistently  with a vengenace. Now on Catalina latest and Adobe 2020 latest.

After first switching on, when previewing video in Organiser, the system hangs. Force quit Ok. Try to restart the Organiser from Dock. NO. Try to start from Photoshop menu. NO. Tried restart. Said Organiser not responding.  Couldnt close down Force quit from close down window. Nothing. So restarted  with power button. Then all OK. The clip that forced the hang worked OK. Rest of session Ok. 

The next day, exactly the same. The system is a bit random whether it shuts down properly normally, Have talked to Apple about this a few times but not fixed it.but live with this

Any ideas?

Do I ring Adobe or Apple?

Chris

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines