Highlighted

Elements and Catalina

New Here ,
Nov 26, 2019

Copy link to clipboard

Copied

I purchased a while ago Elements 12 along with Premiere 12 for my mac. At the time I had no need for Premiere so never installed it. I installed Elements and it has worked great. Since I've update to Catalina I get an error message when opening Elements that says file is corrupt and software needs to be reinstalled.

When I go to reinstall I get an error that states "Install needs to be updated. The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information."

I have searched hi and low and can't find anything that would assist me in correcting my issue. Can anybody help?

Thx

PSE 12 system requirements: Mac OS X v10.7 through v10.9.  It was't intended for use on Mac OS X v10.15 which wasn't even around at the time.  You'll need to upgrade to Photoshop Elements 2020, currently sale priced at a 40%.discount.  Also, computer users are always wise to read up on OS updates before comitting to them.  In case you didn't already know, Catalina also broke all your 32 bits apps.  None will work in v10.15.  This news shocked the sensibilities of a lot of other Mac users too but the info was available at apple.com ahead of Catalina's release.

TOPICS
Download and install, Mac, Problem or error

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Elements and Catalina

New Here ,
Nov 26, 2019

Copy link to clipboard

Copied

I purchased a while ago Elements 12 along with Premiere 12 for my mac. At the time I had no need for Premiere so never installed it. I installed Elements and it has worked great. Since I've update to Catalina I get an error message when opening Elements that says file is corrupt and software needs to be reinstalled.

When I go to reinstall I get an error that states "Install needs to be updated. The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information."

I have searched hi and low and can't find anything that would assist me in correcting my issue. Can anybody help?

Thx

PSE 12 system requirements: Mac OS X v10.7 through v10.9.  It was't intended for use on Mac OS X v10.15 which wasn't even around at the time.  You'll need to upgrade to Photoshop Elements 2020, currently sale priced at a 40%.discount.  Also, computer users are always wise to read up on OS updates before comitting to them.  In case you didn't already know, Catalina also broke all your 32 bits apps.  None will work in v10.15.  This news shocked the sensibilities of a lot of other Mac users too but the info was available at apple.com ahead of Catalina's release.

TOPICS
Download and install, Mac, Problem or error

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 26, 2019 0
Enthusiast ,
Nov 26, 2019

Copy link to clipboard

Copied

PSE 12 system requirements: Mac OS X v10.7 through v10.9.  It was't intended for use on Mac OS X v10.15 which wasn't even around at the time.  You'll need to upgrade to Photoshop Elements 2020, currently sale priced at a 40%.discount.  Also, computer users are always wise to read up on OS updates before comitting to them.  In case you didn't already know, Catalina also broke all your 32 bits apps.  None will work in v10.15.  This news shocked the sensibilities of a lot of other Mac users too but the info was available at apple.com ahead of Catalina's release.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 26, 2019 1
New Here ,
Jan 17, 2020

Copy link to clipboard

Copied

Where do I go for the 40 percent discont ? Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 17, 2020 0
LEGEND ,
Jan 18, 2020

Copy link to clipboard

Copied

You will have missed the holiday sales and black Friday/cyber Monday deals. But shop around. On-line sites such as Amazon, Costco etc. often have the full product priced lower than the Adobe upgrade price.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2020 0
New Here ,
Jan 18, 2020

Copy link to clipboard

Copied

I had been buying elements at Costco with my end of the year reward. The Costco here in the Minneapolis area have not had Elements since 15 I believe. I did get a price break on 2019. You would think Adobe and apple could figure it out and apply appropriate updates. I do have a subscription with photoshop also. But I am nervous about the learning curve. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2020 0
rhbsvdp LATEST
New Here ,
Feb 24, 2020

Copy link to clipboard

Copied

I make the corrections on a photo using elements 12.  After I'm finished I click on the FILE menu at the top of the screen and select DUPLICATE.  The drop down menu will give you the file name followed by the word copy.  click OK.  Now go to the FILE menu and click on SAVE AS.  Now select the PING option versus the .JPG option and click SAVE.   works for me.  Dick B

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0