I have a recommended GPU card, but settings says GPU acceleration is not supported.

Community Beginner ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Hello all. I have an NVIDIA GTX 1660 SUPER display adapter (which is one of the supported graphics cards) but in Adobe Premiere settings it says GPU acceleration is not supported. I am running Windows 10 Home, Premiere Elements 2021, NVIDIA GTX 1660 SUPER with driver version 30.0.14.9709 dated 11/26/2021. I deliberatley chose this computer because it came with a GPU card that was listed by Adobe as supporting GPU acceleration. Any ideas? Thank you.

TOPICS
Error or problem , Performance

Views

322

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 20, 2022 Jan 20, 2022

Problem solved! GPU acceleration was not supported on first launch, but after I entered serial number and relaunched the application, I am good to go. Thank you.

Likes

Translate

Translate
Community Beginner ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Problem solved! GPU acceleration was not supported on first launch, but after I entered serial number and relaunched the application, I am good to go. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

That is correct... see https://helpx.adobe.com/premiere-elements/using/gpu-acceleration.html

 

Where it says "GPU acceleration feature is not supported in the trial version of the application" so entering your serial number made the program activate

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2022 Apr 16, 2022

Copy link to clipboard

Copied

Ok, I had the same thing. However, I went and purchased a license, entered it, rebooted the computer, and teh software is now fully activated. 

Under settings it correctly identifies my GPU and is set to use it for rendering/exporting. 

However, when I actually export a timeline to video, i still doesn't actually use up GPU (looking in task manager) but uses up 90% CPU usage.

Any help with that?

I'm also using Premiere Elements 2022.

 

Device name XXXXXX
Processor 11th Gen Intel(R) Core(TM) i5-11600K @ 3.90GHz 3.91 GHz
Installed RAM 16.0 GB (15.9 GB usable)
Device ID 736141C0-BF46-470D-8AF6-AC5929C78B16
Product ID 00330-71467-17236-AAOEM
System type 64-bit operating system, x64-based processor

GPU: Nvidia RTX 3070 TI

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 17, 2022 Apr 17, 2022

Copy link to clipboard

Copied

GPU is not used for everything, but the CPU is always used, even while the GPU is doing its thing. 

 

You also cannot go by Windows Task Manager to see if GPU is working, you need a 3rd party program like Afterburner, Precision X1, or GPU-z. 

 

For example, right now my Windows Performance Monitor for GPU shows 27% "copy" utilization on my GPU & fluctuating 0 - 25% on 3D utilization.  Precision X1 shows it's running at 95-100% power target, GPU-z shows 98% GPU load, 54% GPU memory load.

 

Also, your RAM may be a bit on the low side for modern video editing, especially if you're doing anything with 4K videos.

 

I would suggest doing some timed test edits / renders / transitions / effects / encodings with and without GPU acceleration turned on in Elements.   Also check out your memory utilization in Windows Performance Monitor.  If it's using more than 70% of your 16GB, you'll likely benefit from additional RAM.  

 

I did a test edit when I first got Elements 2021 using high bit rate (80-90Mbps) 4K video with several transitions & effects applied.  I only had 16GB RAM at the time & it was maxed out in the test.  After upgrading to 64GB RAM, I ran the same test again and it was using around 30GB RAM.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

Thank you for the response. This is a new computer and I first installed CC with Premiere Pro and did the test; it exported the video in 5 minutes to the second.

Then I Uninstalled CC and it's programs, and installed Premiere elements 2022. From what it seemed to me Elements won't open projects from Pro so I made it it from scratch. Chances are some text, etc might be slightly different.

(I should add that this is a very simple video I'm doing. Literall, 30-ish minutes audio, background plate/picture (jpg), and 1 graphic layer with text. No motion or video involved.)

I had to buy Elements in order to have it utilize the GPU. I then ran that export and tried to match all the settings from Pro to Elements. This export took me 15 minutes rather than 5 minutes.

When exporting from Pro WTM showed 90+% usage while Elements never went above 18%. But you say I shouldn't go on that.

The above behavior differences from Pro to Elements... is that to be expected?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

As I understand it "Pro" and "Elements" are done by 2 completely different software teams, so varying differences are very possible.  

 

I say that about WTM because there are a lot of GPU intesive tasks that WTM doesn't see and cannot properly register.

 

From what you're describing, it sounds like the "Pro" team was able to greatly improve the efficiency with which Pro utilizes the GPU, and did so in a way that WTM can see it.  

 

A 200% speed improvement definitely makes it seem like Pro could be a better investment despite the price difference.   There wasn't much of a performance difference when I did my testing in 2020, but it was a trial version of Pro vs full version of Elements, so that may have had something to do with it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

Thank you for the educational responses!

Is there a way to buy PPro without subscription? This is for a charity organization and only record speeches to upload with graphic. No "real" editing. So they prefer to keep ongoing cost down.

90% of the reason I went with Adobe Premiere is because I have years experience with Premiere Pro, and really like how that works. I did my research and it claims elements also uses GPU for export and so I purchased that. In this situation they want quick exports so volunteers don't have to stay a long time after a service (church) to export files. We invested in a good graphics card for this purpose. (RTX 3070 TI). In my testing with PRO I was happy with the result.

So my only issue with Pro is an ongoing subscription cost; Does anyone know of alternative software that would utilize GPU that you can get without subscription?

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

By the way, using GPUz for monitoring GPU load, it goes between 20-30% most of the export, sometimes jumping to 40% for a second. So it's a little 'better' than WTM says.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2022 Apr 22, 2022

Copy link to clipboard

Copied

Update your graphics card driver: download from Nvidia.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 23, 2022 Apr 23, 2022

Copy link to clipboard

Copied

I have updated my graphics card driver.

 

I have ran numerous tests now; On a 15 minute export, 1 text graphic, one jpg image, and 1 mp3 audio file, mixed out as: 1920x1080 (1.0), 29.97 fps, Progressive, Software Encoding, VBR, 1 pass, Target 5.00 Mbps, Max 6.00 Mbps, AAC, 160 kbps, 48 kHz, Stereo.

 

With "Use GPU acceslerated effects, .... " checked (And it does detect my GPU properly and says it's supported) - it takes 3:48 seconds to export.

With "Use GPU accelerated effects.." not checked, it took 3:51 min/seconds to export. 

No difference. 

Watching the GPU and CPU monitors, I couldn't tell a difference between the two. 

 

But I'm still baffled why, in export settings, it is set to Software encoding, and it's greyed out, I can't change it.

Is there any way to loosen that up so I can actually select an option there?

Advanced Export Settings.jpg

Setting.jpg

  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

LATEST

The encoding settings in the export settings are only active when you have a Intel with Media SDK cpu.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines