• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
9

Audio waveform not showing visually

New Here ,
Jan 02, 2019 Jan 02, 2019

Copy link to clipboard

Copied

Having issues with this since updating to 2019. Basically, after importing a clip into the timeline everything is as it should be (video plays, audio plays) but the audio waveform does not show up until it's played through so I cannot visually see the audio waves unless I play/skip through the whole clip, which obviously makes editing a lot slower.

Attached an example. Image 1 is the clip just imported to the timeline and image 2 is after playing through a few seconds (as you can see the audio only shows up after I've played through the clip and the remaining audio waves are still blank)

Any help would be appreciated!

Using Windows and Adobe Premiere Pro 2019.

Audio1.PNG

Audio2.PNG

Views

261.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , Jan 02, 2019 Jan 02, 2019

First, go to Edit > Preferences > Audio and make sure that the setting "Automatic audio waveform generation" is ticked. If this is un-ticked no waveforms are generated when importing files. This will not affect already imported clips, it will only affect clips you import from now on.

Second, for creating audio waveforms on clips that dont have them, select the clip/s in the Program panel and go to Clip > Generate Aduio Waveform.

If the first trick fails i would have trashed the Preferences in Prem

...

Votes

Translate

Translate
Community Expert , Mar 25, 2019 Mar 25, 2019

Try resetting the Workspaces:

Reset a workspace

Reset the current workspace to return to its original, saved layout of panels.

  1. Do one of the following:
    • Click the Workspace menu icon and select Reset to Saved Layout.
    • Choose Window > Workspace > Reset to Saved Layout.

from here:

https://helpx.adobe.com/premiere-pro/using/workspaces.html

Votes

Translate

Translate
New Here , Sep 20, 2021 Sep 20, 2021

Another option is to click on the timeline display settings button - it's the wrench icon in this pic.... There you'll see an option to turn the waveforms on or off. 

timeline display settings.JPG

Votes

Translate

Translate
replies 120 Replies 120
Community Beginner ,
Oct 04, 2019 Oct 04, 2019

Copy link to clipboard

Copied

For what its worth I had a simmilar problem and adobe helped find a fix for me. I layed out the steps on my post here.


https://community.adobe.com/t5/Premiere-Pro/Audio-Waveforms-not-appearing-despite-sound/td-p/1064784...

🙂 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 04, 2019 Oct 04, 2019

Copy link to clipboard

Copied

franciss, Glad to hear it worked for you. It did not for me, hence my 12 Sep 2019 post. Note that just as I wrote it, I manually deleted the cache, outside PrP; I did not just use PrP's delete cache option in program.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Oct 10, 2019 Oct 10, 2019

Copy link to clipboard

Copied

Well none of that worked for me-- resetting, etc... What did was first opening the file in Audition and making sub clips there.  At least for the audio only files. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2019 Oct 21, 2019

Copy link to clipboard

Copied

SOLVED: Go to Preferences > Timeline > Check 'render audio when rendering video'

After that just select the clip and go to Sequence > Render selection.

Hope this works for you as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2019 Oct 24, 2019

Copy link to clipboard

Copied

In case anyone wonders in here, I FOUND A FIX. Right-click your audio clip that has no waveform, and click the option that says "Render and Replace." It will spit out the new clip with the audio waveforms in full view. Hope this helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

This solved the issue for me. Thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

It's a year later and this is still happening. I had a waveform, zoomed in once and it disappeared, now nothing is bringing it back. This mainly happens for me when I use nested sequences, but all the other clips in the timeline using the same subsequence are displaying properly. Just not the one I actually need to edit, of course.

 

Combined with the wacky display errors when you apply an ease to alpha animation, Pr 2020's UX continues to be an adventure.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

Go to Preferences > Timeline > Check 'render audio when rendering video'

After that just select the clip and go to Sequence > Render selection.

Hope this works for you as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2020 Jan 12, 2020

Copy link to clipboard

Copied

Just easily Right click on you audio track then Render and Replace.

Good luck.

Screenshot 2020-01-12 at 15.20.58.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Same problem here, almost over a year after first reported. The fact that you have to go whatever extra steps to see a waveform is embarassing. Did anyone at Adobe actually work as an editor? Time spend waiting and troubleshooting just keeps piling up 😞

 

Render-and-replace option seems to be working so far, thanks for that at least.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

I found a vídeo with the solution:
https://www.youtube.com/watch?v=AWi_ezZD0fU

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

I found a vídeo with the solution:
https://www.youtube.com/watch?v=AWi_ezZD0fU

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2020 Jun 04, 2020

Copy link to clipboard

Copied

(edit) solved with with explanation donated beforehand in this thread

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2020 Jul 10, 2020

Copy link to clipboard

Copied

The above solution didnt work for me -as well as most of the other suggestions. I closed PPro, deleted the .pek files, then it regenerated them when i reopened the project. Works like a charm...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Try right clicking on the clip on the timeline > Render and Replace. Worked for me. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2021 Jan 30, 2021

Copy link to clipboard

Copied

this worked for me! Thank you. Thank you. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2021 Feb 20, 2021

Copy link to clipboard

Copied

What worked for me is:

1. Unlinking Video and Audio

2. Right-clicking on the audio "line"

3. Render and Replace...

SimonasVS_0-1613856543673.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Summary of "Fixes" (Star-Rated, on a 5-star scale):

  1. *** Render & replace.  I and many others here have found this work-around, and it seems the most robust approach, in that is works the most often.  But it's slow, makes extra files, and in rare cases, even this fails.
  2. *** Avoid editing audio tracks in Multicam sequences.  For my own reasons, I often ignore this advice and later regret it.  For example, muting audio track 1 in your multicam sequence, is trouble.  You might think you can just unmute some other track, and thereby still have an audio waveform in your derived sequence.  But the underlying code behind the multicam sequence does some mapping, and this doesn't seem designed to allow us to do these sorts of edits.  You might get audio, or you might not.  If you've done fairly little in the multicam sequence, you might be able to just unmute audio track 1 of the multicam sequence, and the audio waveform in the sequence derived from it may return.  But, the more you edit things in a multicam sequence, the more likely the bug will not be recoverable, by user manual efforts.
  3. ** Clip > Generate Audio Waveform ... is quick to try.  I think this worked for me once in several years.  But mostly no help.
  4. ** Edit > Preference > Audio > check "render audio when rendering video" ... may help.  Default is off.  So try turning on, then re-add your video to you sequence.  Might get lucky.  I have little experience with this one.
  5. * Edit > Preference > Audio > check "automatic audio waveform generation" ... fixes problem only if this was unchecked (and the default is checked), and then only for clips added to timeline after this is rechecked.  Most of time, this was not the problem, so it's not the fix.
  6. * Clear cache & peak files, some think preferrably manually (to be more complete).  This has yet to work for me, and many here report the same non-result.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

From personal experience - Averdahl's solution may work, but I've never resorted to that myself because I actually use preferences to store the state of my editor, and prefer to not mess with it. The simplest solution I've found to work is to renaming the file and importing it again (sometimes more than once). I'm assuming this is a fairly basic cache issue and would be resolved by deleting the faulty preview and re-importing but, jesus mother of god, this should not be incumbent on the user. The fact that even manually invoking Generate Audio Waveform fails to generate a  valid waveform is just baffling.

 

My experience is that Adobe feeds on user sanity and has had this bug, among oh so many others, around since forever. Moreover, not only does pretty much every single major revision make me want to shoot myself, the absolutely absurd plethora of basic bugs and quirks that keep re-emerging is often mind-boggling on a Bethesda level.

 

Since these seem to be favorite solutions to various problems on the web:

 

@adobe : to be clear, I'm not suggesting introducing more bugs to widen the gamut, but if every second issue with your software requires the user to trash their preferences or nuke the cache, move files around, deal with lost work due to instant crashes, unzip and edit the project file, never upgrade, or roll back their drivers or editor, then it just might be time to invest in a better QA team. Or I don't know, maybe at least listen to their damn feedback.

 

But enough barking up a dead tree: even this basic issue hasn't been fixed in years and I'm confident won't be for years to come.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

Restarting program fixed it for me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Another option is to click on the timeline display settings button - it's the wrench icon in this pic.... There you'll see an option to turn the waveforms on or off. 

timeline display settings.JPG

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2021 Dec 04, 2021

Copy link to clipboard

Copied

Omg! Hahah Ur the best... so many people wa strying to make it and was finding solutions while it was JUST it..  i have no idea why siddenly it has got unchecked anyhow but it works. Thank You wo much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2023 Mar 25, 2023

Copy link to clipboard

Copied

@just take actioi16874188 maaaaaan i am sooo sooo gratefull right now !!! i literaly jumped up from by desk chair hahaha thank you 1M times !!!!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

Found a silly trick : if you have the full Adobe Suite, from Premiere timeline (or project bin) right click to open up your sound file in Adobe Audition.  The operation made the waveform appear for me.  You can then simply close Audition and return to your project.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Here's my solution: 1. Close out of Premiere completely. 2. Perform a search for all .pek files on whatever drive space your projects assets are located and delete them. 3. Launch the project and you should see Premiere generating new .pek files. I find it best to let your machine idle and allow Premiere to devote it's bandwidth to the task at hand until all .pek files have finished generating.

 

This has been a problem for me over the years where I lose the wav forms on the timeline, sometimes seemingly at random. Today it happened when I migrated a project and all it's assets to a new drive with more disk space (6TB of material on a 10TB drive). I came here to see if there were any updates to a solution since it's a pretty common bug from what I can tell. All of the .pek files were still alongside their respective counterparts, but using all the tricks in this thread I still couldn't get Premiere to recognize them. The deleation/re-generate method contiunes to be my best solve.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines