• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Colors are wrong when I use CUDA GPU Acceleration, but not when I use the Mercury Software Engine.

New Here ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Please see title above. I'm desperate for a solution to this problem.

 

My colors are wrong when I use CUDA GPU Acceleration, but not when I use the Mercury Software Engine.

 

Here's what I see in the program monitor when I'm using the Mercury Software Engine. These colors are correct, and accurately reflect what I see in-camera. These colors also accurately reflect what I see when viewing the original video clip outside of Premiere:

mercury.jpg

 

...and here's what I see in the program monitor when I'm using CUDA GPU Acceleration:

cuda.jpg

 

As you can see, my black levels are completely incorrect, making it impossible for me to color grade with CUDA GPU Acceleration turned on.

 

Mercury Software Engine simply isn't a reasonable solution for me, so I'd appreciate any assistance I can get with this issue.

 

Specifications of machine and all other details below:

 

  • Computer

    • OS: Windows 11 Pro

    • CPU: Intel i9-10850k

    • GPU: GTX 3060 Ti

 

  • Software

    • Premiere CC 23.0

      • This problem also used to occur with Premiere CC 22.0 (all version updates).

    • Graphics Driver: NVIDIA Studio Driver 522.30

      • I have also tried using the most recent version of the NVIDIA Game Ready Driver (526.47) and several earlier versions.

 

  • Footage

    • The sample shot above was captured with the Canon R6 using the IPB Light Codec in 4K at 23.976 FPS.

    • I can confirm the footage format is not the problem, as I experience this even with the proxy files I generate.

 

Please help me resolve this before I lose my sanity!

TOPICS
Editing , Error or problem , Formats

Views

67

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Have you set either your camera, your monitor's settings or the Nvidia control panel settings to assume all Rec.709 is full range rather than limited? Which is wrong, but so confusing a lot of people do.

 

And the IPB Light is the file compression setting, not the codec. Are you using a C-log form? That would be useful data.

 

As ... all Rec.709 video is set by standards to be encoded to 'limited' range code values, unless it's the full RGB 4:4:4:4 12 bit stuff. Which is not a common camera setup. So the vast majority of cameras record their Rec.709 as YUV (technically Y/Cb-Cr) files.

 

But there are a few cameras that allow users to set 'full' range on shooting Rec.709 even though they only produce YUV media. Which is simply wrong. It doesn't give you one iota more dynamic range, as that only controls how the data is encoded to the file, not the range of date recorded.

 

In a properly setup system, YUV Rec.709 media is displayed at 0-255 even though encoded 16-235. And RGB media is also displayed at 0-255 even though encoded as 0-255. So it works perfectly as long as the standards are followed all the way through from camera to monitor.

 

Next ... Premiere is set to follow the standards rather tightly. NO camera has an accurate screen, not even the Red, Arri, & Sony rigs above $70,000. On-set, they'll have an expensive and hignly calibrated monitor to check image values, not the camera screen. So do not rely on your camera's screen image as "correct" for anything.

 

Which is why most users and ALL Mac users should set the preferences option for Display Color Management to 'on'. And well ... both calibrate and profile your monitors, but it seems rare enough anyone calibrates the monitor these days.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Hi Neil,

 

Thank you for your response.

 

I appreciate all of your comments regarding the project settings and the footage itself, but this is definitely not the cause of my problem.

 

I took the exact same project file and footage, loaded it on my laptop using CUDA GPU Acceleration, and even connected that laptop to the same computer monitor. When I do this, the issue completely disappears.

 

This leads me to believe the problem is computer-specific, but I have no idea what could be causing it.

 

I did try your suggestion of using the NVIDIA Control Panel to adjust the color range from 16-235 to 0-255, with no effect.

 

In other words, I'm at a loss here!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

LATEST

The Nvidia should be set for 16-235 ... and that's the whole weird thing. There's a solid historical reason, but that hasn't been needed for what, 15 years now? Whatever. It works if set right.

 

But on yours, being as you're getting differences between laptop and that desktop ... I'm still trying to puzzle that out. As it's when that GPU is involved you get a difference. Which ... is odd.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines